No LED, no UART output on TTN Gateway after reset

After receiving the gateway today and trying to activate it, I ended up with the gateway not working anymore.

The AP mode worked and I was able to connect and partially do the activation, but after a second try, initiated by holding down the MODE button and connecting it to power, which flashed the LEDs for about 10 seconds, now none of the LEDs light up, and and FTDI connected to the UART will not show any information.

Holding down MODE while powering up will still flash the LEDs for around 10 seconds, after which they again power off. Any ideas? Any way to reflash the firmware, with the SD card? I couldn’t find any information or in fact the firmware itself.

Thanks in advance, Alex

Did it ever? (If you only connected after running into trouble, then maybe you’ve connected the wrong pins.)

Yes, but I don’t know how, nor where to get the image:

You’re right, I tried it only after running into problems, and then I never saw any output. Anyway, I followed a picture posted in the forum:

Anyway, any help is appreciated. There is definitely a lack of documentation. Reading through hundreds of forum posts is no replacement for a solid manual. Or at least some resources for self-help.

When I connected an UART cable I use for ESP boards, the wire that was connected to TX on that ESP board needed to be connected to RX on the TTN Gateway. (And likewise: what is labeled RX on the ESP is labeled TX on the gateway.)

I tried it every way possible, and also took two FTDIs and connected them together, just to make sure they could talk to each other. Which they did.

I did test all TPs on the board. VCC/VDD/VIN are okay. Most peripherals are off. MEMORY_VCC_TP gets 3.3V while the LEDs are flashing when holding “MODE” on power up. After that it goes low again.
Also, the only thing happening on the RX and TX pins of the UART is some 50Hz ripple from the power supply.

@milanoengineering I’m having exactly the same issues as you are reporting as well.

@htdvisser When can we expect to be able to try out flashing an updated firmware? In the meantime, perhaps someone could do a write-up of the the proper procedure using the existing firmware and make it available? That way it would be properly documented for subsequent releases.

I’m really puzzled as to why I’m not getting any output over the UART…

I’m having the same issue here as well. NO LED’s are even on (just the VCC on the board). I didn’t checked with UART yet. I’m as well interested in a solution to bring up my Gateway again.
Thanks in advance.

@e-bits, firmware and instructions are posted at

I just ran through the firmware updating procedure, but unfortunately it didn’t make any difference for me. Not sure what to try next as I’m not getting any UART output nor signs of life…


My gateway is alive again! :smiley:

It turned out I had a badly formatted micro SD card; I originally formatted it on a Windows 10 box as FAT32, but the gateway only picked it up after I formatted the card as MS-DOS on MacOS.

Anyway, after inserting the card and turning the power back on, the gateway picked up the new firmware in the update directory and lit up like a Christmas tree! After a while the ethernet link is active and the SSID is also broadcast. Currently the gateway is registered, activated and online. Oh joy!

The UART is also transmitting now and I can monitor it.

Thanks to @milanoengineering and @mrjdomingus for helping out!

Thanks to @htdvisser for

1 Like

Hi @kaared, sorry for late response. I was sick the last 3 days. Happy to hear that your gateway is working again. I got mine working as well but i formated the microSD card in Windows 10 and it was working right away.