No RX TTGO-BEAM with TTN Mapper

Used sketch =

Send GPS data seems to work, but no data in TTN data received?

TXMODE, freq=867500000, len=22, SF=7, BW=125, CR=4/5, IH=0
Packet queued

I think that there is a gateway on this freq=867500000 in my area
Is this True?

why no answer from this gateway?
Is there something wrong with my TTN login?

EV_TXCOMPLETE (includes waiting for RX windows

But i have never RX data back …

Received 0 bytes of payload RSSI 0 SNR 0

I have wired DIO1 DIO2 to I/O pins 33,32

// Pin mapping
const lmic_pinmap lmic_pins = {
  .nss = 18,
  .rxtx = LMIC_UNUSED_PIN,
  .rst = LMIC_UNUSED_PIN, // was "14,"
  .dio = {26, 33, 32},

Is the little antenna from the T-Beam too weak??

Who can help me with tips / advice?

TTN Mapper
Valid gps Fix.
Lat: 52.22 //xxxx
Lng: 6.00 //xxxx
65101: engineUpdate, opmode=0x808
65119: Uplink data pending
65123: Considering band 0, which is available at 2619
65262: Considering band 3, which is available at 0
65544: No channel found in band 3
65734: Considering band 0, which is available at 2619
66032: No channel found in band 0
66222: Considering band 1, which is available at 2619
66521: Airtime available at 2619 (channel duty limit)
66819: Ready for uplink
66979: Updating info for TX at 65119, airtime will be 3536. Setting available time for band 1 to 418719
67548: TXMODE, freq=867500000, len=22, SF=7, BW=125, CR=4/5, IH=0
Packet queued
71095: irq: dio: 0x0 flags: 0x8
71104: Scheduled job 0x3ffc8c48, cb 0x400d29a4 ASAP
71109: Running job 0x3ffc8c48, cb 0x400d29a4, deadline 0
71185: Scheduled job 0x3ffc8c48, cb 0x400d26ac at 133564
133564: Running job 0x3ffc8c48, cb 0x400d26ac, deadline 133564
133690: RXMODE_SINGLE, freq=867500000, SF=7, BW=125, CR=4/5, IH=0
134030: irq: dio: 0x1 flags: 0x80
134038: Scheduled job 0x3ffc8c48, cb 0x400d3ecc ASAP
134064: Running job 0x3ffc8c48, cb 0x400d3ecc, deadline 0
134384: Scheduled job 0x3ffc8c48, cb 0x400d26fc at 196352
196352: Running job 0x3ffc8c48, cb 0x400d26fc, deadline 196352
196479: RXMODE_SINGLE, freq=869525000, SF=9, BW=125, CR=4/5, IH=0
197778: irq: dio: 0x1 flags: 0x80
197786: Scheduled job 0x3ffc8c48, cb 0x400d3efc ASAP
197791: Running job 0x3ffc8c48, cb 0x400d3efc, deadline 0

EV_TXCOMPLETE (includes waiting for RX windows)
      Serial.println(F("EV_TXCOMPLETE (includes waiting for RX windows)"));
      digitalWrite(BUILTIN_LED, LOW);
      if (LMIC.txrxFlags & TXRX_ACK) {
        Serial.println(F("Received Ack"));
// ========= CODE changed to see if there RX action????
      //if (LMIC.dataLen) {  
        sprintf(s, "Received %i bytes of payload", LMIC.dataLen);
        sprintf(s, "RSSI %d SNR %.1d", LMIC.rssi, LMIC.snr);
      //}     //// uncomment to test RX data
Received 0 bytes of payload

198388: Scheduled job 0x3ffc4718, cb 0x400d1918 at 2073387
198713: engineUpdate, opmode=0x900

Why are you expecting any RX at all?

You’ll only get RX for confirmed uplinks, if your application explicitly schedules a downlink, and for network commands like those for ADR. For mapping, you should not use confirmed uplinks, and for other usages downlinks (including confirmed uplinks) are limited to only 10 a day.

Please see

The original code already shows you the RX if there is any. If you want to change the logging, I’d simply only move sprintf(s, "Received %i bytes of payload", LMIC.dataLen); above the if (LMIC.dataLen). But I’d leave the if in place; you’re now logging RSSI and SNR values that are really not true.

Well, the internet is big, just a file name won’t help most of us :slight_smile:

But i thought that if i transmit something that i always get some confirmation / answer.
I did not get anything (GPS data) in my TTN data page.
I am not sure if the gateway received and send i to the TTN page.

Is there another sketch to test transmitting some data to my TTN data page?
I tried several, but did not succeed.

I tested the LilyGO/TTGO-T-Beam as a sender and my LilyGO/TTGO-LORA32-V2.0 as a receiver.
This works, but the sender and receiver are next to each other.
The receiver gets sometimes an other message with more bytes crypt-ed with een RSSI -121
Probably from another Node or the gateway nearby??

I am a Newbee, i have read a lot, and tried a lot of example sketches.

Thanks for your answer and formatting my text.

No, LoRa is not some kind of WiFi. Instead, a device just transmits and hopes that one or more gateways receive its transmission and forward that to, e.g., The Things Network. If the device does not request confirmation then it won’t get any either.

Again, please be more specific; we cannot know all hardware that exists, and surely we cannot just guess how you programmed that hardware.

Maybe you just tested with LoRa (the radio modulation), not LoRaWAN (the standardised network protocol that uses LoRa)? But if you programmed that TTGO-LORA32-V2.0 hardware to be a single-channel test gateway which you also connected to TTN, then if data is shown in TTN Console then you also know that other gateways could receive your node’s transmissions. However:

Things like “Packet queued” really only refer to your device; the sketch has created a LoRaWAN-compatible packet and delegated that packet to the LoRa chip that will transmit it. It does not tell you if one or more gateways have received it; the device really does not know. So, given this logging and without knowing where you’re located, we cannot know if there are any gateways in your neighbourhood. Peeking at and might give you a clue, but the actual range might be worse.

Assuming you did not use the TTGO-LORA32-V2.0 as a single-channel test gateway, then I’d suggest:

Now, if you’re lucky that there are indeed TTN gateways in your neighbourhood, then you might see some data in TTN Console. Next, decrease the spreading factor to see if you still receive data.

If this doesn’t work at all, and if you don’t know if there’s a proper gateway in your neighbourhood then for your first tests I’d suggest to use the TTGO-LORA32-V2.0 for a single-channel test gateway. Note that you’ll only receive messages that are transmitted on the channel and spreading factor that such single-channel test gateway is listening to, while a proper node will use different frequencies for each transmission. So, such single-channel test gateway is only for your first tests, to ensure that the node is working.

Or maybe just some other device (like smart metering) that uses LoRa, not even LoRaWAN.

I Disabled the frame counter checks.
i noticed the frame counter is counting and with TTN mapping sketch still counting.
When i switch the T_BEAM device off, the the counter stops.
After starting again, the counter starts at Null.

So frames are coming in, but are not seen in the DATA.
Could this be that the format does not fit?
Do i have to make some other settings?

The same with another temperature humid sensor / sketch the frame counter adds.
So i assume there is a gateway active. On the mapping my home town is covered in colors with a lot of gateways.

How can i make the frames visible in the data page?
Thanks for your great help, i learned a lot until now.

Where do you see that? In the device’s page in TTN Console? (If yes, then the secret keys are correct, and indeed at least one gateway has received the device’s data, and TTN has determined which application and device the incoming data belongs to.)

You mean the device’s Data page in TTN Console? Beware that you will only see the data that was received since you have that Data page open. To (partially) see recent older data as well you can add the Storage Integration to the application; see Why application data is shown as historical? - #2 by arjanvanb

Are you saying you’re using some Payload Format function in TTN Console? If not, then TTN should simply show the hexadecimal representation of the payload.


the device’s Data page in TTN Console stays blank for a long time.

I tried to integrate the “Data Storage” but if i twice click the Icon then the screen blanks and never comes back.

The button Create integration is not accessible.

I also tried other integration witch do not appear as well.

What do you mean with “twice click”? Double click? Most interactions on websites only need a single click, and that’s also true for TTN.

Any chance you’re clicking the images in the documentation ( rather than in TTN Console (

Not accessible or not visible? It seems that the “Add an Integration” documentation you showed above is a tiny bit outdated; the button in step 5 shows as “Add integration” to me:


That said, given all the weird things you’re seeing in TTN Console, I’d try another browser.

Alternatively, if you don’t get the live data to show in TTN Console:

Problem with storage is solved.
I deleted the application, and made a new one.
Installing storage was no problem anymore.
The TTNmapper sketch data is now visible in “data”
When ik clicked on the entry in the data page it showed the GPS pos. of the Gateway.
Most of the send data was received in the Gateway on a high bulding 600 Meter away.
Some transmited data were received by a gateway exact 3 Km distants, with a lot of city buildings in between.
Therefor i asume that the transmission power of the TTGO-BEAM is good with buildngs in between.
I am happy with this result, and i like to thank @ [arjanvanb] for his help.

Next project job is to send my temp, humid and my own GPS data.
Then i will try to make it visible in graphics.
Also the weight sensors i like to implement in the sketch and send this also
And make it also visible in a graphic.
A lot of reading /study for examples in this forum.
Tips and links ??