Official setup to show Gateway on map?

I was in the same situation … wanted to se my GW … BUT was not showing … but then some day (around one week later) it was showing :smile:

even more important is that your gateway shows up on TTNmapper Map

1 Like

Mine is not showing in TTN Mapper?

Strange, mine always show up immediately. Some even don’t want to go away. I accidentally setup up a misconfigured GW last week, pulled it offline immediately and configured it properly, and now I have two gateways showing :roll_eyes: .

It needs to be mapped first by a node running TTN mapper code. Read the FAQ on the site :wink: .

I think assumption are not the best way to go on this issue. May be would be best to have an official answer from TTN guys

  • What is the condition to show GW on map ?
  • What is the condition to remove GW from map ?
  • What is the priority to “TTN Console Config” or “fake_gps” coord ?

May be I’m stupid but since GW are configured on TTN Console and are flagged with “connected or not” why the MAP is not reflecting them?

Anyway while writing just checked something and decided to take a look and guess what ?
I found my 2 GW at lat=10 and long=20 as other 31 gateways
image
image

Seems that is you use gps ans fake_gps it will set the GW whatever TTN console config and may be TTN console setup GW are never shown on map?

So return of my initial question what to do to setup GW only on TTN console and forget any gps like config in json config files?

2 Likes

So I reconfigured my GW shown in Tchad, Africa with correct location (copy paste of location declared in TTN Console)

                "gps": true,
                "fake_gps": true,
                "ref_latitude": 46.65769374,
                "ref_longitude": 0.36482225,
                "ref_altitude": 100,
                "description": "ch2i-gw04-ic880a"

Restarted packet forwarder wait a couple of minute and GW is shown !!!

2 Likes

Why do you have Fake_gps true?

Because there is no GPS on GW so it’s used to send latitude and longitude of the json file instead of the real coming from a GPS.

1 Like

The description in this github issue might help?

@Batilan’s reference says you should not do that, also repeated on the forum:

@Batilan, thanks very good information

I agree guys, but setting this on local config was not working (gw was not shown on location defined in console)

{
  "gps": false,
  "fake_gps": false,
  "description": "ch2i-gw04-ic880a"
}

But may be it’s due to old config that already setup the GW on the map on lat=10, long=20 so the GW was at the wrong place and the only way I had to place the GW at the correct location was to override these config in with local config changes (and fake_gps of course).
May be all is working fine on new gateways (I’ll check on next one) but when the gw has sent fake_gps one time, you’re stuck until we find a way to remove gw from map. At least it seems to work like that

Did you (also) configure a location in TTN Console, using the “edit location” link? (That’s the preferred way unless the gateway has a GPS.)

image

yes that is what I’m trying to do from beginning, remove all GPS from GW forwarder side and setup location ONLY from TTN console :wink:

1 Like

I’m responding to an old topic trying to accomplish the same thing. I have created a new gateway device without entering lat/long, and have connected an rpi-based gateway with GPS enabled. The GPS information appears to be collecting correctly, and I can see the gateway’s GPS-derived lat/long in the metadata sent to the application, so everything appears to be working as expected, with the single exception of the gateway location as shown @ https://console.thethingsnetwork.org/gateways There, my gateway is showing no location information (lat/long == 0/0). This doesn’t feel like a huge issue, but it’d be nice for the device to show up correctly on the map. Am I missing a step here?

I also have a Raspberry Pi RAK831 gateway and my gateway also refuses to show on the TTN map. My setup uses the GPS on the RAK supplied interface card. The GPS is working because I see the messages arriving from /dev/ttyS0. It reports the correct coordinates and shows 5-6 satellites. I also see the correct latitude and longitude and altitude are presented as metadata to my application, so I am confident the coordinates are being received by TTN. The syslog confirms valid time reference and GPS coordinates. Settings are all public in the console. I did have my location set statically in my local_conf before I enabled GPS about a week ago. The GPS has been running for about a week, but my gateway still has not reappeared on the map. I have tried placing it manually on the map, and removing it again - but have had no success getting GPS to place it.

Am I missing something?

1 Like

Is the metadata in the application always the same? Or does it change a bit? (In my experience the coordinates of a gateway with GPS drift a bit)

What are your configuration parameters in both global and local configuration regarding GPS? (All of them)

The coordinate metadata in the application does change. The following shows a couple of instances taken a few minutes apart.

"latitude": XX.83462, "longitude": YY.20914, "altitude": 138
"latitude": XX.83464, "longitude": YY.20927, "altitude": 139
"latitude": XX.83473, "longitude": YY.20941, "altitude": 164

This variability is consistent with what I see direct from the GPS on the Pi when running the following command

cat /dev/ttyS0 | grep GPGGA

The following are the GPS related fragments from the config files.

global_conf.json

"gateway_conf": {
    /* change with default server address/ports, or overwrite in local_conf.json */
    "gateway_ID": "AA555A0000000000",
    /* Devices */
    "gps": true,
    "beacon": false,

...

    /* GPS configuration */
    "gps_tty_path": "/dev/ttyAMA0",
    "fake_gps": true,
    "ref_latitude": 10,
    "ref_longitude": 20,
    "ref_altitude": -1,

local_conf.json

   "gps_tty_path": "/dev/ttyS0",
    "gps":true,
    "fake_gps": false,

It seems to me that I just need to configure the map to accept the GPS coordinates as higher priority than the manually set pointer location, so the GPS coordinates override the manually set location, but I do not seem to be able to achieve this.

Just posting an update to this message. I “rebirthed” my gateway a few weeks ago, with a slightly different MAC address. I simply changed one of the two bytes of seemingly random information inserted in the middle of the gateway ID. In my case the gateway ID appeared to be the standard MAC address of the Ethernet NIC, with “FFFE” inserted between the first three bytes (the IANA part) and the last three bytes (the vendor part). I tweaked this to “FFF0” to create a new - also unique ID. I used only a local config rather than the GitHub pull of the local config file by removing the GitHub pull from the startup script.

My gateway has now been running for a couple weeks. It showed up at the correct (GPS defined) location on the public TTN map. It still has not shown up on my private map on the TTN console.

I am guessing the only way to locate my gateway on my map in the TTN Console is to use the pin. Does anybody know if there is a way to have the GPS data also position my gateway automatically on the TTN Console map - just like it appears to do on the public map? I am likely to move my gateway around a little to optimise the location, and would like my TTN Console map to automatically show its new location.

1 Like

Chances are good it’s indeed unique (even more so within the TTN infrastructure), but just for the sake of completeness: that’s not guaranteed. See discussion and alternative at DevEUI for non-hardware assigned values and Generated Device EUI clashes with officially assigned EUIs.

Arjan - thanks for this. I was not aware that such a discussion existed. It looks like I have followed the deprecated process. Despite that, I would be confident that my “rebirthed” gateway ID will have the same chance of being unique as my original, given both originate from my MAC address, which is by definition already unique. If this proves problematic, I have no problems changing it again in the future.

I am however still keen to see if there is a solution for my initial question relating to the automatic positioning of my GPS enabled gateway on my Gateways map.