Rhf76-052am - getting it working with OTAA


(Iotatwtamu) #41

Here is a link to it but you will have to contact RisingHF to get a login to their wiki: http://wiki.risinghf.com/lib/exe/fetch.php?media=extranet:rhf76-052am-v2.1.15-20170612.ebin.bin.zip


(Zane L) #42

Todd, do you happen to have a copy of the new firmware for the RHF76-052 module? I’ve been emailing them to give me a login to their wiki so I can grab it, but they never respond.


(Brady Aiello) #43

I uploaded firmware version 2.1.15 to my Google Drive. I’m sorry about their Wiki weirdness. They should really change that.

https://drive.google.com/file/d/11BM1g6ZCwP19fvHKQXV9cleVZTU2gZlb/view?usp=sharing


(Brady Aiello) #44

I also went through the firmware update process with version 2.1.15, and it still says the version is 2.0.10. Is anyone else getting that?


(Zane L) #45

Thank you!

I’ll try the new firmware sometime in the next few days and see if I can get it to work.


(LEMO Internet a.s.) #46

Hi, I cannot upgrade firmware with AT+DFU=on and YMODEM file send. DFU command put device to DFU mode, reboot in 5 secs, but when I try to upload via ExtraPUTTY YMODEM, upload not start.


(Brady Aiello) #47

I’m having all kinds of trouble with these Seeeduinos as of late. I opened a new one, and it said it had version 2.1.15 on it. But I can’t even flash a sketch onto it. It just hangs forever now.


(Brady Aiello) #48

Yeah, this stuff is really temperamental. You’re supposed to load the firmware update code, then unplug, then press the DFU button, then connect to a serial emulator, then transfer the file. I used Tera Term to load the file.


(LEMO Internet a.s.) #49

I have a problem that gateway received join request and sent join accept, but on the node, nothing happens.


(Brady Aiello) #50

For OTAA, do you need to supply the App Session Key and Network Session Key? I don’t see them in the TTN Console for the device.


(Brady Aiello) #51

Nevermind, I got it. App EUI and App Key for OTAA.


(Brady Aiello) #52

This can’t possibly work. Where are you passing your AppEUI?


(Kalon33) #53

Using latest 2.1.15 firmware (that I knew of from this thread), my sketch is not working anymore. Especially that triggers an error when setting channels:

+MODE: LWOTAA
+DR: EU868
+DR: DR5
+DR: EU868 DR5  SF7  BW125K
+ADR: ON
+CH: 0,868100000,DR0:DR5
+CH: 1,868300000,DR0:DR5
+CH: 2,868500000,DR0:DR5
+CH: 3,867100000,DR0:DR5
+CH: 4,867300000,DR0:DR5
+CH: 5,867500000,DR0:DR5
+CH: 6,867700000,DR0:DR5
+RXWIN1: ERROR(-1)
+RXWIN2: 869500000,DR3
+POWER: 14
>>> SETUP DONE
+JOIN: Start
+JOIN: NORMAL
+JOIN: Join failed
+JOIN: Done
>>> JOIN ERROR
+JOIN: No band in 115215ms

Here is the code I use to connect:

lora.setDeciveMode(LWOTAA);
lora.setDataRate(DR5, EU868);
lora.setAdaptiveDataRate(true);

lora.setChannel(0, 868.1);
lora.setChannel(1, 868.3);
lora.setChannel(2, 868.5);
lora.setChannel(3, 867.1);
lora.setChannel(4, 867.3);
lora.setChannel(5, 867.5);
lora.setChannel(6, 867.7);

lora.setReceiceWindowFirst(1);
lora.setReceiceWindowSecond(869.5, DR3);

Any idea how to fix that?

Thanks for your help.


(Brady Aiello) #54

Hi, I would remove the Adaptive Data Rate line, because we already set a preferred data rate. I would also set the first Receive window with the specific frequency and data rate, like this:

lora.setReceiceWindowFirst(0, 868.1);
The method signature is this:
void LoRaWanClass::setReceiceWindowFirst(unsigned char channel, float frequency)

For me, I have OTAA working, with US frequencies, but a join at the moment takes about 3-4 attempts. ABP is much faster, but it’s discouraged for security concerns and the inability to reassign addresses and network keys and app keys on the fly.

Feel free to reference my work here. I’ve included frequencies and data rates for all countries TTN is available in.


I hope this helps.


(Kalon33) #55

Hello all,

For your information, latest firmware version, 2.1.16 dated from 2017-12-03, is available from Seeed github repo


(Jturello) #56

Hello,

I had the same issue on the Seeeduino LoRaWAN board with firmware 2.1.15, OTAA and a raspberry pi gateway.
I solved it by setting the timeout parameter of the setOTAAJoin function:

lora.setOTAAJoin(JOIN,60).

Hope this could help!

In the other hand, I tried to upgrade the firmware to 2.1.16 with minicom (i’m on linux mint 18.3), using ymodem, but every time the board tells me: firmware upgrade failed! I’ve followed the procedure: plug usb then press DFU and wait in minicom for the “CCCC” characters.

Did anyone managed to upgrade to 2.1.16 using minicom?


#57

I have upgraded the firmware with minicom. That part worked for me. But this version seems to have the AU channel plan completely screwed up.

Has anybody got this thing to work on AU915? I have never been able to get this thing to join.


(Toddkrein) #58

OMFG, I hate this POS board.

I’ve made the mistake of coming back to work on it again, after a many-month layoff, and nothing is working. The boards seem to randomly reset, even a new one out of the box. When I use transferPacket, I get the initial “+MSG: Start”, and nothing else. Until it resets itself. I’ve tried typing in the command by hand, and get the same result. It’s running 2.1.15. I’m running Arduino 1.8.1.

I thought maybe that TTN had changed something, and went to load the latest firmware (2.1.18), but I can’t get the board to go into upgrade mode. I get nada.

To check my sanity, we’re supposed to use:

#include <Arduino.h>

void setup()
{
//Serial1.begin(9600);
SerialDBG.begin(115200);
SerialUSB.begin(115200);
}

void loop()
{
while(SerialDBG.available())
{
SerialUSB.write(SerialDBG.read());
}
while(SerialUSB.available())
{
SerialDBG.write(SerialUSB.read());
}
}

right?

I’ve tried this on three different boards, so it’s not a HW issue…


(Toddkrein) #59

OK, figured out the Software update problem - We use “putty” at work, and it doesn’t play well with “extraputty”. Argh… there’s five hours of my life I won’t get back…


(Toddkrein) #60

… But it does look like 2.1.18 fixes whatever the problem was.