Setting up a Private Routing Environment


#86

:rofl:


(Mehrdadh) #87

Hi,

I’m trying to setup the routing environment on an Azure virtual machine. I have followed the instructions and setup my backend on Ubuntu 16.04.

Everything seems to run without error, except when I run the “gateway-connector-bridge” command, It stays up for few minutes and then it shows following error (FATAL Not all backends started in time) and closes. My gateway connects with my backend and after few minutes lost the connection because the error.

The error has short description and I don’t know what is it related to. Any help would be appreciated.
I’m really new to this community and sorry if my question is a basic question.

Thanks,
Mehrdad


(Mehrdadh) #88

I found the issue. I believe one of the TTN components were not running on the correct IP address.


(Carlos Hernandez-Vaquero) #90

Hello,

I hope you can help me with this.

I have installed private TTN network and gone through articles in blog.

I have run 'docker-compose up -d ’ and all the services are started successfully.
Now, i have changed the server_address in gateway( which has ttn software) to hostname i.e.“192.168.0.163” and left port as it is 1700

when i try to analyze packets are transmitted from gateway on 1700 port but no respose from the server.
Found that ‘destination unreachable’ from the wireshark even though the port is opened.

I have registered the gateway using ‘ttnctl’ and configured as Router - mynetwork-router.

I would like to know where can i see the server status ?

my configurations looks like below,

ttnctl.yml:
config file: /home/xx/.ttnctl.yml
data dir: /home/xx/.ttnctl

mqtt-address: localhost:1883
   router-id: mynetwork-router

mqtt-password:
handler-id: mynetwork-handler
gateway-token: eyJhbGciOiJSUzI1NiIsInR5cCI6IkpXVCJ9.eyJpc3MiOiJ0dG4tYWNjb3VudC12MiIsInN1YiI6ImRldiIsInR5cGUiOiJnYXRld2F5IiwiaWF0IjoxNDgyNDIxMTEyfQ.obhobeREK9bOpi-YO5lZ8rpW4CkXZUSrRBRIjbFThhvAsj_IjkFmCovIVLsGlaDVEKciZmXmWnY-6ZEgUEu6H6_GG4AD6HNHXnT0o0XSPgf5_Bc6dpzuI5FCEpcELihpBMaW3vPUt29NecLo4LvZGAuOllUYKHsZi34GYnR6PFlOgi40drN_iU_8aMCxFxm6ki83QlcyHEmDAh5GAGIym0qnUDh5_L1VE_upmoR72j8_l5lSuUA2_w8CH5_Z9CrXlTKQ2XQXsQXprkhbmOKKC8rfbTjRsB_nxObu0qcTWLH9tMd4KGFkJ20mdMw38fg2Vt7eLrkU1R1kl6a65eo6LZi0JvRSsboVZFWLwI02Azkwsm903K5n1r25Wq2oiwPJpNq5vsYLdYlb-WdAPsEDnfQGLPaqxd5we8tDcHsF4C1JHTwLsKy2Sqj8WNVmLgXiFER0DNfISDgS5SYdOxd9dUf5lTlIYdJU6aG1yYLSEhq80QOcdhCqNMVu1uRIucn_BhHbKo_LCMmD7TGppaXcQ2tCL3qHQaW8GCoun_UPo4C67LIMYUMfwd_h6CaykzlZvDlLa64ZiQ3XPmMcT_gVT7MJS2jGPbtJmcLHAVa5NZLv2d6WZfutPAocl3bYrY-sQmaSwJrzakIb2D-DNsg0qBJAZcm2o021By8U4bKAAFQ
discovery-address: localhost:1900
app-id:
app-eui:
allow-insecure: false
mqtt-username:
auth-server: https://account.thethingsnetwork.org
data: /home/xx/.ttnctl
config: /home/xx/.ttnctl.yml
gateway-id: dev

local_conf.json file:

{
“gateway_conf”: {
“gateway_ID”: “0000024b080501b0”,
“serv_port_up”: 1700,
“serv_port_down”: 1700,
“server_address”: “192.168.0.163”,
“forward_crc_valid”: true,
“forward_crc_error”: false,
“forward_crc_disabled”: true,
“gps”: true
}
}

Thank you!


(Mtails) #93

Hi everyone,

sorry first of all for revive this topic! I have a brief question regarding the Gateway registration when using the Private Backend guide. Can I register my LoRa Gateway, App and Devices locally on the same lab using the ttnctl console specifying private IPs? If so, I guess that using local IPs when asked for the router and handler would be enough to orchestrate all together. Otherwhise, should I use a public domain and enable port forwarding?

Thanks a lot in advance!

B.


(Stranger Flo) #94

One final remark for all those trying to get their private backend running:
Get yourself some different gateway (e.g. on Raspberry Pi basis) and use Brocaar as LoRa server. Just my humble opinion …

TTN stuff is pretty nice and easy when using the whole TTN environment as is, but it is probably not intended (or at least not favorable) to be used as a private network.


#95

and watch this topic for news about the new (flexible) V3 backend