The hard RAK831 cafe part 2


#144

Ah, I understand now about the GPS, you use an interfaceboard with a ublox module already soldered to it. Apparently the rx-tx are already connected to the Rasberry because you can read the NMEA messages. I used a mini interface board made by Charles https://github.com/hallard/RAK831-Zero. There is no GPS module footprint on it and also in the LoRaGW-setup repository https://github.com/ch2i/LoraGW-Setup I did not see anything about a GPS or PPS signal. So I have to findout to which points I have to connect (Rx&)Tx of the Ublox module and about anything in the software for GPS/PPS .


(Martin Sloup) #145

Here is the RAK831 converter board schema.

In my case it’s running on ttyS0, so I had to add GPS port to MP forwarder configuration:

{
    ...
    "gateway_conf": {
        ...
        "fake_gps": false,
        "gps": true,
        "gps_tty_path": "/dev/ttyS0"
    }
}

RAK831 not showing GPS
#146

Your posts are very helpfull .
So … I connected a PPS signal to the dedicated UFL socket on the RAK831 board.
Unfortunatly the timing offset/drift messages (up to 350uS) stays in my journalctl . I used a script to install the packet-forwarder so now I have to dig to find where I need to edit some files to enable the GPS.

edit
As this is a hardware topic I will have to open a new topic about how to connect a GPS module to the ch2i interface board and how to adapt the install scripts.


(Steve Beale) #147

i have just received tyhe new board the jumper as in photo
rak


(88bit) #148

Hi I’m running the RAK 831 gateway and need to test in a place where I don’t have internet access. I was wondering if there is a way to see information of the arriving packets. I’m mainly interested in the RSSI and if the packet is accepted as a valid packet.
My RAK 831 is currently setup to connect to the TTN network but I don’t have an internet connection in the place where I go. Its a tunnel.

Thank you in advance for your reply.


(Arinze Izukanne) #149

This might be digressing a bit but has anyone been able to setup a LoRaWAN gateway with the RAK833?

I am interested in knowing the controller board & OS used. I have RAK833 with EVB board but cannot figure out how to get Lora packet forwarder running on the OpenWRT


(Edzelf) #150

@88bit:
I guess you may edit /opt/ttn-gateway/bin/local_conf.json and change and change the line:
"servers": [ { "server_address": "router.eu.thethings.network",
to
"servers": [ { "server_address": "localhost",

Restart the gateway with:
sudo service ttn-gateway restart

The gateway wil now send messages to itself, and they will probably discarded.

Then look at the UDP messages by:
sudo tcpdump -XUq port 1700
Don’t forget to undo your changes in /opt/ttn-gateway/bin/local_conf.json.


(Kenyu) #151

we are working in this tutorial now. hopefully update you soon later and together will RAK833 formal launch


(Kenyu) #152

you like smaller GPS antenna?


(Kenyu) #153

where to get this heatsink? maybe we can help to introduce to more of our users. very helpful


#154

I got this heatsink from an old processorboard that I had in the junkbox. There was a small ventilator on it which I removed.


(Snorkman) #155

Dear TTN Community,

after struggling o more than 3 days to setup my gateway (RAK831 915MHz + RPi 3) I ran out of ideas what my problem could be.
I surfed every post related to this device and no one helped to solve my problem, that is the reason why I am creating this post.

To summarize, all the steps I did were:
1 - Install Raspbian
2 - Update + Upgrade
3 - Cloning ic880 repo
4 - Install using sudo ./install.sh spi
5 - Modify global_conf.json according to US_global_conf.json
6 - Modified the rest pin from 25 to 17
7- Rebooting

My local_conf.json looks like this:
{
_ “gateway_conf”: {_
_ “gateway_ID”: “B827EBFFFE3EF015”,_
_ “servers”: [ { “server_address”: “brazil.thethings.network”, “serv_port_up”: 1700, “serv_port_down”: 1700, “serv_enabled”: true } ],_
_ “ref_latitude”: -27.364722222222223,_
_ “ref_longitude”: -55.89333333333333,_
_ “ref_altitude”: 0,_
_ “contact_email”: "mymail@gmail.com",_
_ “description”: "First TTN Gateway of Posadas city "_
_ }_
}

And my global_conf.json looks like this:

After rebooting I check the logs of the and everything seems to be running the way it should, see the screenshots:

sudo service ttn-gateway status returns

As you can see there is no confirmation from the backen to my GW

and if I execute

cat /var/log/syslog | grep INFO

I am pretty sure that I did the right steps to make it run, and I still see “not connected” in TTN’s console.
Did any of you experienced the same thing when setting up your GW?
I commit myself to create a well documented tutorial for this device and all the community once this is running.

Thanks in advance for any help that you can provide.


(Edzelf) #156

Try to log in with SSH on your RPi and give the command:
tcpdump -XUq port 1700
Maybe you have to install tcpdump first.
After some time you should see messages to and from brazil.thethings.network.

Strange: I see “brazil.thethings.network” in your local_conf.json, but “us-west.thethings.network” in syslog. Are you sure your config is in “/opt/ttn-gateway/bin/local_conf.json”? Check it, because there are probably 6 “local_conf.json” files installed.


(Snorkman) #157

I also tried that and I can see traffic from the RPi to the server

08:24:59.035545 IP unam.52562 > brazil.thethings.network.1700: UDP, length 12
E…(.s@.@…
…R…R…{o…I…’…>…
08:24:59.733260 IP unam.58467 > brazil.thethings.network.1700: UDP, length 253
E…@.@.~... ..R..c...........'...>..{"stat":{"time":"2018-06-05 11:24:59 GMT","rxnb":0,"rxok":0,"rxfw":0,"ackr":0.0,"dwnb":0,"txnb":0,"pfrm":"IMST + Rpi","mail":"mymail@gmail.com","desc":"First TTN of Posadas city'...>..."}} 08:25:04.075539 IP unam.52562 > brazil.thethings.network.1700: UDP, length 12 E..(..@.@.~
…R…R…’…>…

I was wondering if the console show status “not conected” because there are no end devices (sensors) sending RF packets to the GW yet.


#158

and I am wondering why someone situated in Germany want to try that

[0#90]


(Edzelf) #159

You should see “Connected”, even if there are no devices at all.

Now you see traffic to brazil.thethings.network. But you should also see the acknowledge of this message from the remote server. Something like:
14:26:20.775853 IP 191.235.82.46.1700 > unam.58467: UDP, length 4
0x0000: 4500 0020 4040 4000 3111 c554 34a9 4ccb E…@@@.1…T4.L.
0x0010: c0a8 021c 06a4 ae21 000c aada 01fc 5a01 …!..Z.
0x0020: 0000 0000 0000 0000 0101 2020 2020 …
If you see no answer, your gateway is unknown at brazil.thethings.network or at us-west.thethings.network (I do not know which one you are using). Make sure that it is registered there. In my case:
“gateway_ID”: “D29076FFFEB8D675” is registered as:
“eui-d29076fffeb8d675”.


(Snorkman) #160

Because I am providing remote support, that is why.


(Snorkman) #161

Hello there,

first of all thanks for your reply.
I verified the 6 “local_conf.json” that are present in the packet forwarder directory and they all point to “brazil.thethings.network”.

Should I also modify the “global_conf.json” file inside :

  1. /ttn-gateway/packet_forwarder/basic_pkt_fwd/
  2. /ttn-gateway/packet_forwarder/beacon_pkt_fwd/
  3. /ttn-gateway/packet_forwarder/gps_pkt_fwd/
  4. /ttn-gateway/packet_forwarder/poly_pkt_fwd/

to be exactly the same as the one inside /bin ?


(Edzelf) #162

No, only the one in /opt/ttn-gateway/bin is vital. But is does not harm…


(Snorkman) #163

Ok I will also try that