TTIG stopped working (no longer connects to WiFi)

I have a TTIG that has been working for the past few months, and has now suddenly stopped.

The gateway was unplugged from it’s power source 12 days ago (when it was last online on TTN console), however after plugging it back in yesterday it has not returned online.

It’s current behaviour is:
flashes green with 1s period for a varying number of flashes, then goes solid green for 3ish seconds, followed by a rapid green/red flash, then starts the cycle again (green freq 1/s, solid green 3 seconds, etc…).

According to the table on , this would mean it is attempting to connect to wifi for a short period of time, then somehow immediately connected to wifi and LNS backend for about 3 seconds, skipping the middle stage, then suddenly scanning WiFi networks & setting up Config AP. Surprisingly I don’t think it’s likely that this is actually what is happening…

Things I have tried so far:

  • Searching extensively on the forums and elsewhere. Some people reported similar behaviour at TTIG launch, but these issues were quickly fixed by backend or automatic firmware updates a long time ago. All other issues I can find are not the same and show different behaviour. Suggested fixes in those threads don’t seem to work anyway.

  • Resetting & reconfiguring the gateway multiple times using the set up protocol and gui

  • Moving the gateway with respect to the WiFi access point

  • Removing and re-registering the gateway on TTN console. (I did not try this until later on as I briefly read it could mess things up. Not sure if there’s any credibility to that as it seems to have had no effect to the console entry, which has relinked to the gateway information).

  • All documented button actions for the gateway (All three of them I could find)

  • Unpowering and repowering the gateway many times, with varying periods between

  • Just leaving it for 12 hours…

Has anyone had any similar behaviour? Is this out of my hands or am I making a very basic and silly mistake?


1 Like

Is there any reason why, according to the title, you think it no longer connects to WiFi?

Surely the WiFi-chip is working, as it can still operate as an access point when in configuration mode. When in doubt if it connects as a WiFi client, then that might be easily validated in some web interface of your WiFi access point, or by using some ARP command within the same network? (I don’t know if the TTIG would respond to a ping.)

Aside, just in case it helps, it seems that the last_seen in (and confirms it does not connect to TTN, even if it has connected to WiFi. But I guess that just confirms what you see in TTN Console:

  "id": "eui-58a0cbfffe800d06",
  "description": "AG Office GW",
  "owner": "paul_b",
  "owners": [
  "attributes": {
    "brand": "The Things Industries",
    "frequency_plan": "EU_863_870",
    "model": "The Things Indoor Gateway",
    "placement": "indoor"
  "last_seen": "2019-12-22T17:18:29Z"

Similar details for (beware, that’s an HTTP URL; right-clicking and some “open in new incognito window” might help if your browser tries HTTPS instead):

  "timestamp": "2019-12-22T17:18:29.334663621Z",
  "uplink": "1025",
  "downlink": "460",
  "location": {},
  "frequency_plan": "EU_863_870",
  "gps": {},
  "time": "1577035109334663621",
  "rx_ok": 1025,
  "tx_in": 460

And another aside: if you feel like some soldering then you can get debug output, either using the USB connector or some UART wiring on the PCB, obviously voiding the warranty…

Thanks for your response.

You make a good point by questioning this. It could be a large number of things. The reason I thought it may be the WiFi connection mostly came from the fact that it spends a (slim) majority of it’s time flashing green with a freq of 1/s, which as mentioned before means ‘trying to connect to WiFi’ in the documentation.

I don’t think the WiFi chip is broken, but am wondering if something about the actual connection process is going wrong. I’ve done arp searches both with a device connected to the gateway by WiFi in configuration mode, and once ‘save and rebooted’ with local network details. In the first case, the gateway shows up at the configuration IP (though interestingly with one digit of the MAC address different to that on the sticker and the configuration gui). In the second case, the gateway does not show up at all. This could be, as you say that it’s not responding to pings, or it could be that it’s not managed to connect to WiFi at all. Sadly I can’t make any concrete judgements from this from what I know.

I don’t have any issues doing this other than that I don’t really have the time at the moment… I’m just a bit dissappointed there’s so little documentation to go off with this!

I will try with a different TIG later today and see what happens.


UPDATE: I have tried a different TIG, and it has worked fine first time on the same network with the same procedure. Would still appreciate any suggestions on how to fix the broken one though!

Is the broken TIG on a different power source? If you don’t use its built-in power plug, make sure your power source can supply 1A at 5V.

1 Like

Good thought, but sadly It was tried with several sufficient power supplies without luck.