TTN GATEWAY central 2

To reply on to my own problems: after simply ticking the box to allow for beta firmware and a reset, my gateway is now upgraded from 1.0.2 to 1.0.4b and has not gone down (without coming back up) anymore. I’m doing some ping tests to see if it actually stays up, but at least the issue of not coming back up has been resolved for me.

Some other thing I noticed: I chose not to hang the gateway from the window but to put it on it’s back. However the white plastic edge of the cover prevents the (foldable) antenna to go up in a 90 degree angle.

If I position the gateway upside down (on it’s white cover) the antenna can fold, but I’d make a small recess on the white cover to allow the gateway to stand flat (instead of hanging) with the ability for the antenna to fold in an upward angled fashion in a next hardware revision.

Two weeks ago I’ve ordered one of those affordable PICkit 3 programmers to try if that would make any difference. And it did! :slight_smile:

Last night I’ve uploaded the latest firmware with updated bootloader as described on the GitHub firmware page and now the gateway actually starts receiving and sending messages. It is still rebooting frequently like 25 times in the last 12 hours once there is a MQTT error like this

[2018-06-17 08:12:24] LORA: Kick LoRa module with ACK after not acked it for 60s
[2018-06-17 08:12:29] MON: SYS Stack size: 2870
[2018-06-17 08:12:29] MON: TCPIP Stack size: 3787
[2018-06-17 08:12:29] MON: APP Stack size: 3294
[2018-06-17 08:12:29] MON: LoRa Stack size: 3859
[2018-06-17 08:12:29] MON: heap usage: 278KB (279KB), free: 60KB
[2018-06-17 08:12:39] MON: SYS Stack size: 2870
[2018-06-17 08:12:39] MON: TCPIP Stack size: 3787
[2018-06-17 08:12:39] MON: APP Stack size: 3294
[2018-06-17 08:12:39] MON: LoRa Stack size: 3859
[2018-06-17 08:12:39] MON: heap usage: 278KB (279KB), free: 60KB
[2018-06-17 08:12:42] MQTT: Sending status packet
[2018-06-17 08:12:45] MQTT: Sending status failed
[2018-06-17 08:12:45]
[2018-06-17 08:12:45] MAIN: MQTT error
[2018-06-17 08:12:45]
[2018-06-17 08:12:45] MAIN: Leaving state 5
[2018-06-17 08:13:08] SNTP: State change from 0 to 0
[2018-06-17 08:13:08] SNTP: State change from 0 to 0
[2018-06-17 08:13:08]
[2018-06-17 08:13:08]
[2018-06-17 08:13:08]
[2018-06-17 08:13:08] **************************
[2018-06-17 08:13:08] *   The Things Network   *
[2018-06-17 08:13:08] *      G A T E W A Y     *
[2018-06-17 08:13:08] **************************
[2018-06-17 08:13:08] Firmware name: AmazingAckermann, type: 0, version: 1.0.4, commit: a7beae91, timestamp: 1525259181
[2018-06-17 08:13:08] Bootloader revision: 2, commit: c463e87e, timestamp: 1519396960
[2018-06-17 08:13:08] Build time: May  2 2018 11:07:39
[2018-06-17 08:13:08] Reboot reason: 0x10
[2018-06-17 08:13:08] BOOT: (persisted info) 6F 72 72 65 01 10 BC 79 EF FE F9 BA 77 6B 2C E7

@TTP, how come this user did not get 1.0.3 when the beta checkbox was not enabled, while 1.0.3 still seems to be the stable version according to ? Or has 1.0.3 been revoked altogether?

Or in other words: which version does one get when having beta enabled/disabled, and which is the recommended setting?

(For me, 1.0.2 and 1.0.4 yield a reboot loop, while 1.0.3 does not, where the 1.0.3 on my SD card is commit 2c56ce0, Mar 22 2018 12:21:52 while the official release was April 4th. The checksums 757211...2039b8 from the 1.0.3 release does not match the checksums 8793f2...489c20 as linked as “stable” from

Thanks, we needed an update after so many weeks of silence. Looks like I will just have to hang in there. The gateway has operated for only 15 minutes in the last 4 days

I had a similar experience. I upgraded to 1.0.4 by checking the “Beta Updates” checkbox in the Gateway setup. The Gateway ran for an hour and rebooted. Then it ran for about 20 hours until an MQTT error, rebooted 20 times within about 5 minutes and is again stable.

Here is what it looked like duringthe first and second reboot.
How did you add timestamps to the Serial console??

MQTT: Sending UPLINK failed: -1

MAIN: MQTT error

MAIN: Leaving state 5
MAIN: Entering state 6
INET: State change to 0
WIFI: Disabling modules
SNTP: State change from 7 to 8
CB: Disconnect
Head magic match void: trying to free an already freed block, ignore
SNTP: State change from 8 to 1
WIFI: Entering state 3
MON: SYS Stack size: 2845
MON: TCPIP Stack size: 3787
MON: APP Stack size: 3294
MON: LoRa Stack size: 3797
MON: heap usage: 185KB (279KB), free: 154KB
SNTP: State change from 0 to 0
SNTP: State change from 0 to 0

*   The Things Network   *
*      G A T E W A Y     *
Firmware name: AmazingAckermann, type: 0, version: 1.0.4, commit: a7beae91, timestamp:     1525259181
Bootloader revision: 1, commit: 7167873a, timestamp: 1496411298
Build time: May  2 2018 11:07:39
Reboot reason: 0x10
BOOT: (persisted info) 6F 72 72 65 01 10 57 3E 46 F8 0B 62 38 36 B1 82

WIFI: Entering state 0
WIFI: Entering SCAN state 0

MAIN: Initialisation complete
LORA: Changing state from 0 to 0

MAIN: Leaving state 0
MAIN: Entering state 1
FLASH: Magic bytes found: wifi config present
FLASH: Magic bytes found: activation data present
FLASH: Magic bytes found: FOTA data present
FLASH: Loading Firmware Data
CNFG: (Firmware HASH (sha256)) 65 0D 50 41 6F 3C 7A 21 B0 6A 61 4A FF BE C3 DD 3F 8A 2C 8F D1     98 70 9F 71 EF C5 53 6A 7D 31 AF
FLASH: Loading WiFi Data
CNFG: WiFi key:       ***
CNFG: WiFi conn_type: 1
CNFG: WiFi sec_type:  4
FLASH: Loading Activation Data
CNFG: Gateway ID:         burns_park_north_ttn_gateway
CNFG: Gateway Key:        ***
CNFG: Account Server URL:
CNFG: Locked:             true
CNFG: Locked first time:  false

MAIN: Leaving state 1
MAIN: Entering state 2
INET: State change to 0
LORA: Initialisation complete
LORA: Changing state from 0 to 1
SNTP: State change from 0 to 0
SNTP: State change from 0 to 0

*   The Things Network   *
*      G A T E W A Y     *
Firmware name: AmazingAckermann, type: 0, version: 1.0.4, commit: a7beae91, timestamp:     1525259181
Bootloader revision: 1, commit: 7167873a, timestamp: 1496411298
Build time: May  2 2018 11:07:39
Reboot reason: 0x10
BOOT: (persisted info) 6F 72 72 65 01 10 57 3E 46 F8 0B 62 38 36 B1 82

Looks like this bug is similar to the issue reported on GitHub

Initially I logged using PuTTY but now I’ve connected the gateway to a RaspberryPi as suggested by this topic: Raspberry Pi to monitor serial output of a node or TNN Gateway, and alert on Slack or Telegram

@nestorayuso the firmware of the mPCIe card is indeed closed sourced from Occam.

@jurrien the beta would be available via Github and leading upto that we will contact the testers if we need some help.

I am not sure if this is an issue but I have noticed that if I log onto the TTN Console to view my gateway, especially from a second computer when I already have a session open on another, it seems to crash the gateway. i.e. when I log on it is always saying something like “last message 19 seconds ago” etc which means it has been working, but while I watch no new messages from the gateway are received. If I log off and back on again, sometimes it has come back… May just be coincidence since the gateway is down more than it is up.

Has anyone else noticed this?

Is this only for The Things Gateway or for others too?

I do not experience this with my Raspi + iC880A logged in on my laptop and tablet.

I only have the Things Gateway

Hello, TTN Community

I ordered a TTN Gateway in Aug 2016 and finally it arrived 2 months ago (I Know!). I have not been able to make it work with neither WiFi or Ethernet. It seems either the gateway is broken or there is a bug while joining. I have sent several emails and TTN guys told me it was a software bug 1.5 months ago, and the result is the same: The gateway keeps rebooting and does not connect.

Steps I have followed:

I have written emails to TTN but they have not helped me with this issue. Anybody here has the same problem? How did you solve it?

I can see a red led being turned on, next to the lora chip, and it suddenly reboots. On the TTN Activation Website, it basically blocks at “Configuring…”

Thanks a lot!!


How to reset counters on overview gateway page and what happens when its reached 99999



Dont worry about it…They just keep on truckin’ ! :slight_smile:

2 of my gateways at least have gone >100k:

Received Messages 144629 (iMST Lite GW)

Received Messages 130108 (TTN GW)

And I’m sure others have far more than those :wink:

(I hear talk of some >1Mmsg but cant confirm)

Version 1.0.5
TELEC certification, with LBT, I want Japanese specifications too.

Am I the only one that still does not have a stable TTN Gateway? The gateway reboots every few hours. As I need a stable solution, the TTN Gateway does not seem the right solution.

I have tried the following:

  • Place the gateway in a temperature-controlled space
  • Update (and update, and update, and update, etc…)
  • Re-activate (also many times)
  • re-install firmware using SD-drive
  • Install latest versions of firmware (including beta)

Still it does not work as promised. I have tried contacting TTN to work towards a solution, but after months and months of waiting, there is still no solution.
At this moment I am trying to return the gateway and get my money back, as the gateway has not worked for more than 10 hours continuously since I have received it.

My other gateway (Lorank) works like a charm.

Anyone knows how to get in contact with someone that can actually solve my problem?

1 Like

Have you bothered to read the posts above yours? Check this post from TTP for the latest official news.

1 Like

Hi Jac, thanks for your reply. I have followed lots of topics and hundreds and hundreds of posts, but stopped as I only read the same thing over and over again; I read in this last ‘official’ post, is that an other try is planned to have things solved in an other month.

My current feeling of the TTN Gateway is:

1 Like

Ok, it’s been a really long time since I looked at any forums with regards the gateway and the firmware, what is the process required to get my gateway working given that it has the original/unstable firmware and I’ve not got any ability to flash?! given the refusal to even boot to the point where it reads the sd card?

Is there an option of returning the gateway for a working unit ?

1 Like

For some time my gateway was working great. Sometimes stopped after a couple of days. but after replugging the power it was doing well again.
After some busy time where there was no time to work on a ttn application, I started working on the project again. Because I wasn’t using the gateway i have been storing it at my studio. To work at the application i got it out again. For half a day the gateway was working GREAT. but after lunch it was in a bootloop again… i noticed the Gateway did automatically update itself.

Since I have the PicKit4 I downgraded the gateway to the previous version (may), this worked for 30 min and then got stuck in bootloop again.
Tried different versions, Stable & Beta from may and most current one. none with permanent fix (max 30 min)

Noticed in http://things-gateway.local/info after installing .hex with PicKit IPE and configuring Gateway via, all works for max 30 min. Then a bootloop occurs and “Broker Connection” won’t change to true.

first log after new instal & config:

After reboot:

Can’t get it to work anymore… :sob: