2 x Mtac LoRa - TTNMapper and Gain + Power


(Sosteco) #1

Hi! I have different questions for my Multitech Conduit gateway, I hope is good to ask everything in the same post.
First of all a little explanation of my setup and then the questions, I have a gw with two radios Mtac Lora equipped with directional antennas covering different areas. What I want to achieve is getting more coverage in focused zones. I have it working already with TTN but with some problems I seek advice and help.
Mtac Lora:
I have already installed them both but in configuration json I do not know how to activate both radios to achieve what I want, covering different areas. I have already messing up with global and ttn configuration but can’t make them work both. Any ideas? Any commands to help me activating and using them?

TTNMapper:
I have activated in configuration json GPS option and fake coords option with good lat,long and ref altitude but it doesn’t show on TTNMapper webpage. Any help here?
“gps”: true,
“fake_gps”: true,
“ref_latitude”: 36.7646701,
“ref_longitude”: -4.707789899999966,
“ref_altitude”: 20,

Power + Gain:
Do anyone knows if there is any command to activate 0 gain and 26 maximun power? It would be sweet to do some test with maximum power in the antenna but I do not find how to do it, just some TX lut that maybe I can modify and use in everyone same power?
I have read:
“tx_lut_0”:{
“desc”:“TX gain table, index 0”,
“pa_gain”:0,
“mix_gain”:8,
“rf_power”:-6,
“dig_gain”:0
Should I modify all luts to rf_power 26? Is that okay?
Thank you for your help and happy holidays!


(Jac Kersing) #2
  1. Where did you find two radio cards are supported? Last time I checked the multitech site explicitly stated only one lorawan card could be installed.
  2. Leave the power settings as they are. Increasing the power might result in transmitting above legal limit, but will always result in the gateway sending at a power level beyond the level required to reach the nodes which does not increase coverage in any way. (Coverage should be symmetric, a node should be able to transmit at a level that one or more gateways receive the signal and a gateway should transmit at a level where the nodes that can be received can receive its transmissions. Anything beyond that level is overkill and only results in ‘spamming’ other nodes further away)

(Sosteco) #3

Hi @kersing !
I readed here: http://www.multitech.net/developer/software/lora/configuring-two-lora-cards-on-a-conduit/
About coverage, ok I will power as it is now no problem.
I am still looking for a TTNMapper solution will keep updated.


(Jac Kersing) #4

Interesting, thanks for the link. It seems you need to run two packer forwarders with two configuration files, effectively making it two independent gateways. Make sure to register two gateways with different IDs on TTN as it won’t handle one registration for two gateways.

Out of curiosity, what frequency plan will you be using?


(LoRaTracker) #5

Did you try Multitech support and what did they say ?

Is increasing the default power legal in your part of the World ?


(Sosteco) #6

Hi!
So if I understanded well, I need to use again the installer.sh with new values for a new registered gateway in TTN isn’t it?
I plan on using same freq for both, EU 863-867
@LoRaTracker no, it is same as EU but it was for testing, @kersing just explained well already so no problem.


(Jac Kersing) #7

Running the installer a second time will overwrite the original configuration. You will need to copy local_conf.json to another folder, copy global_conf.json to the same folder. Then you can run the installer a second time.
You need to run the second packet forwarder specifying a different logfile and configuration folder, this can be done on the command line. Check the run script for syntax.