Activation being ignored

I configured a gateway and single device. tested then deployed to the field. It ran beautifully for about four weeks then started ignoring packets. Went on site and reset device and gateway. Can see the activation coming in on the console but fails to send the ack. Nothing has changed in the device,gateway or ttn setup. What could have caused this? did a search on forum but nothing helped and have run out of ideas.

Sorry to hear nothing helped, but: what suggestions from your search results have you tried/validated and what exactly are you seeing in TTN Console’s gateway Traffic page (if that’s working for you) and application/device Data page?

I feel that the many existing debugging posts explain what’s needed to get help for these kind of issues. So, please link to the suggestions you found and tell us what you saw?

1 Like

I did a search on “activation being ignored” and such like. In the gateway traffic i see keep alives and the device activation. In the device data page i see the activation and it is flagged as such. I do not see anything going back toe the end device. In desparation i wiped out all gateways and devices and started again. Same result. Could i have been outside the fair use policy and been locked out? Cant see anywhere whee it indicates such though.

How do you know that the ack is not being transmitted?

Do you have any other device that you can test with?

It would be super-useful to know a whole heap more - like what device & what gateway you have as an absolute minimum.

The fair use limit is currently not enforced as far as I know.

In cases like this, it is helpful to use all debugging methods available and understand how to use them.

What I think could help is to watch the device events for this device and/or application. You can do that by watching MQTT events and see if you notice anything weird. This API is described in

For example (with mosquitto client):

mosquitto_sub -h -p 1883 -u ‘application-name’ -P ‘application-access-key’ -t ‘application-name/devices/+/events/#’ -v

When a join is attempted, you should see at least a couple of messages using this.
The application access key is the key that starts with “ttn-account-v2.” and can be found in the console.