Adding a Device in TTS 3.11.2 Cannot add Appkey?

Hi all,

Have been looking high and low but I cannot find any info on this. I have installed TTS version 3.11.2 using docker. I have added a gateway successfully, I have added an application and now I want to add a device. So I select the Application, select End devices and select add device. I choose manually OTAA as the device I want to add is just my test device. Version MAC V1.0.2 a the addresses point to my server on which the stack is running. Click on Start, enter a device ID, AppUI and DevUI. Now network layer settings. I select the recommended plan for Europe, regional parameters and move to the join settings.

Up until now things go swimmingly and in line with what I see on video’s and on the web, however, the fun starts in the Join Settings section…no where to add an AppKey for my device, just an expanded “advanced settings” menu asking for things like “Hone NetID” application server ID?

I am lost, what did I do wrong?

Try the next / continue button?

Off the top of my head it’s on the next page.

What’s the worst that can happen?

Thanks for your reply. Yes, tried that and the device is then added but no traffic is coming in and I think it is because The Stack does not know the AppKey, in fact, when sending a Join request I am getting an error called “name”: “no_nwk_key” and I am assuming that its because the Appkey is unknown and thus the NWK key cannot be created (at least that is what I understand from the specs). When I look at the examples on the net I always see people to add the AppKey when they add a device and I am not getting that strangely enough.

Let me have a look at my server

I’ve got 3.11.12 running.

When I add a device, the first layout is Basic settings, then Network layer settings and then Join settings.

The last layout has a heading of Root keys and has the AppKey under it:

Screenshot 2021-03-31 at 15.15.00

Thanks to @benolayinka for getting me up and running on my install - good to be able to help out with answering questions!

How weird, I am missing the Root keys bit, I see the steps and below the Advanced settings.

image

I have tried different browsers and they give the same result, this might be a bug, cannot think of something in the config of the stack which would cause this but I could be wrong

Perhaps you could try an update/migration - but definitely a bit odd that part of the UI should fall off!

Thanks for your help!
I noticed that 3.11.3 is the latest stable version so I changed my docker-compose.yml file:

“image: thethingsnetwork/lorawan-stack:3.11.3”

docker-compose down
docker-compose up -d

The new image is pulled, logged in, verified its new version added a device but alas…same issue.

I will have another look tomorrow, maybe do a clean install.

Again thanks for your help, much appreciated!

couldn’t wait till tomorrow :smile:

Success!

I redid the whole install process of the docker containers and presto…I now can enter an appkey. It is a very strange problem though, I will see if I can reproduce somehow.

image

Thanks for the support!

I wouldn’t get too invested in reproducing it as the whole stack is still having major works on it - as long as an install comes good, best move on to the next adventure.

1 Like

Hello there, I ran into the same issue today (v3.12.0).

After some debugging I was able to reproduce it. As far as I can tell this is a permission related issue.
When a user lacks the Edit device keys in application permission for an application.

There is a indicator under Activation mode when manually adding a device that something with the permissions is not right (not very meaningful imo.):
:warning: ABP and multicast activation mode selection unavailable

And at the step 3 Join settings the Root keys section with the input for entering the AppKey is missing completely as described by @City028.

If I add the Edit device keys in application permission to the user, reload the page and manually add a new device the warning at the beginning disappears and the Root keys section appears back as normal:
image


In my opinion would be helpful to include some comprehensive error message at step 3 or earlier in the process if there are permission issues of any kind :slightly_smiling_face:

Let me know if I am missing something or if you need additional information.