Adding Application with specific AppEUI


(Dimmy) #1

Hi,
I’ve got some devices with hardcoded Appkey, AppEUI and DevEUI.
I’ve got all the information, and when i run my gateway in Network Server mode I can see the data coming in from devices (meaning information i have matches credentials in the device).
However, when i create an Application on TTN and add to it my own AppEUI (00-13-7A-10-00-00-00-00), I cannot get the devices to connect.

I’ve tried this on a few different devices, ones that allow me to use any AppEUI+Appkey+DevEUI all of those devices work fine if they use AppEUI generated automatically by TTN(e.g. 70-B3-D5-7E-D0-01-28-47), but no matter what i do they wont work with a modified AppEUI.

Any thoughts?
PS: brand of devices Netvox.


(Dimmy) #2

image
Tried getting my App to use AppEUI #2 (the one that is hardset by manufacturer of devices i use) - getting an error…
Tried using default AppEUI- works,…tried using 3rd AppEUI - generated by TTN as well - works…


#3

Did you ever find a solution for that? I am considering purchasing a Netvox device for use in the United States with TTN but am not sure if it’d work.


(Sensormu) #4

How can you know which AppEUI are included in your device?


(Dmocci) #5

The Manufacturer gives you the APPKEY + APPEUI.
I have the same problem, no data seen neither on Gateway nor application traffic.

Any advice?


(Dimmy) #6

Hi @sronan, indeed i have found a solution - you need to contact the distributor of Netvox devices and ask them about procedure of changing embedded APP EUI. It is possible ( all that you need to do is run a network server, connect your devices to it with known credentials, and send a message with a specific byte sequence). Unfortunately, this information is not publicly available (no idea why…), but if you contact distributor they MIGHT know it - if not contact Netvox representatives - they will give you instructions (its VERY similar to how you change period with which the devices report).
I cant share the info as i am bounded by confidentiality agreement, but i can say - im pretty happy with the quality of devices…only thing documentation is lacking, and changing APP EUI is unnecessary complex.


(Dimmy) #7

Hi @dmocci can you try following:
(To Verifying that the credentials you have are correct)

  1. Run your gateway in Network Server mode.
  2. Connect a device to it locally.
  3. See if the device connects.

(To verify Set up):

  1. Which frequency plan you using?
  2. Is there ANYTHING coming to packet forwarder? Like failed ‘join’ requests?

(Dmocci) #8

Hi @VS1, I made the following:

  1. Run the Conduit Gateway in NS mode and change the frequency band to US915 (Netvox devices are set up with AU915).
  2. Set up the APP KEY & APP EUI in the GW.
  3. Set up a mdot US915 with this credentials and made successful join !

Then,

  1. Go back to AU915 in the Conduit.
  2. Try with Netvox device, but no join, and no failed join request.

By the way, The default uplink channel frequencies of these AU915 devices are 916.8MHz, 917.0MHz, 917.2MHz, 917.4MHz, 917.6MHz, 917.8MHz, 918.0MHz, 918.2MHz 917.5MHz(@BW500)

Is there anything missing ? How I can check that the frequency change is well set up?

Thanks!
Diego.


(Jreiss) #9

Is your gateway setup for AU915 on FSB2?
It should match those frequencies.

Look at packetForwarders section of this api call for channel setup.
https://192.168.2.1/api/lora/config


(Dmocci) #10

jreiss

How I can check this? Tell me the commands please, I’m not a Linux expert :blush:
Besides, I also enter the webinterface of the Conduit and select “DISABLE” on the LoRaNetwork, is this ok?

Thanks!
Diego.


(Jreiss) #11

The Conduit would need to configured in Network Server mode for the api to fill the api URL.

Paste this URL https://192.168.2.1/api/lora/config into the browser. Replace the IP address if necessary.
No linux expertise needed.


(Dmocci) #12

Here is the result:
{
“code” : 401,
“error” : “not logged in”,
“status” : “fail”
}

The GW is now connected to TTN, in AU915 band.

I made a succesful join with a mdot in AU915, of course.

The problem is with the NETVOX devices. I cannot make them work.
I had created the Application and registered the device. (copying the APP_EUI & APP_KEY from Netvox)

Before, I made a local configuration (without using TTN), and the device worked!! It had joined and send data.

But, when using TTN, the NETVOX device doesn’t report. And I do not see any traffic in Gateway console too.

This is exactly what happens.

Maybe these devices are not compatible with TTN?

@VS1 can you send me more details about your solution? I need to send downlinks from private NS to the device in order to change the App_EUI and Key?

Thanks!!
Diego.