AEP Conduit connected but no data in console


(Dmocci) #1

Hi!

I’m using an AEP Conduit Firmware 1.4.3 and a EVB-mdot node both un AU915 band.
I had selected “DISABLE” in the Conduit web interface for LoRaNetwork.

I can see the log that the Gateway is receiving data but the join request is not shown on console:

##### 2019-02-27 21:02:45 GMT #####
### [UPSTREAM] ###
# RF packets received by concentrator: 4
# CRC_OK: 100.00%, CRC_FAIL: 0.00%, NO_CRC: 0.00%
# RF packets forwarded: 4 (92 bytes)
# PUSH_DATA datagrams sent: 0 (0 bytes)
# PUSH_DATA acknowledged: 0.00%
### [DOWNSTREAM] ###
# PULL_DATA sent: 0 (0.00% acknowledged)
# PULL_RESP(onse) datagrams received: 0 (0 bytes)
# RF packets sent to concentrator: 0 (0 bytes)
# TX errors: 0
### BEACON IS DISABLED!
### [JIT] ###
# INFO: JIT queue contains 0 packets.
# INFO: JIT queue contains 0 beacons.
### GPS IS DISABLED!
### [PERFORMANCE] ###
# Upstream radio packet quality: 100.00%.
### [ CONNECTIONS ] ###
# bridge.brazil.thethings.network: Connected
# Semtech status report send.
##### END #####
18:02:45  INFO: [TTN] bridge.brazil.thethings.network RTT 39
18:02:45  INFO: [TTN] send status success for bridge.brazil.thethings.network
lgw_receive:1165: FIFO content: 1 7b 1 5 17
lgw_receive:1184: [3 17]
Note: LoRa packet
lgw_receive:1165: FIFO content: 1 a2 1 5 17
lgw_receive:1184: [8 16]
Note: LoRa packet
lgw_receive:1165: FIFO content: 1 c9 1 5 17
lgw_receive:1184: [8 16]
Note: LoRa packet
lgw_receive:1165: FIFO content: 1 f0 1 5 17
lgw_receive:1184: [1 17]
Note: LoRa packet
18:03:12  INFO: Disabling GPS mode for concentrator's counter...
18:03:12  INFO: host/sx1301 time offset=(1551299708s:980665µs) - drift=2108µs
18:03:12  INFO: Enabling GPS mode for concentrator's counter.

MORE INFO:

admin@mtcdt:~# head -20 /var/config/lora/global_conf.json
{"SX1301_conf":{"lorawan_public":true,"clksrc":1,"clksrc_desc":"radio_1 provides                             clock to concentrator for most devices except MultiTech. For MultiTech set to 0                            .","antenna_gain":0,"antenna_gain_desc":"antenna gain, in dBi","radio_0":{"enabl                            e":true,"type":"SX1257","freq":917200000,"rssi_offset":-166,"tx_enable":true,"tx                            _freq_min":915000000,"tx_freq_max":928000000},"radio_1":{"enable":true,"type":"S                            X1257","freq":917900000,"rssi_offset":-166,"tx_enable":false},"chan_multiSF_0":{                            "desc":"Lora MAC, 125kHz, all SF, 916.8 MHz","enable":true,"radio":0,"if":-40000                            0},"chan_multiSF_1":{"desc":"Lora MAC, 125kHz, all SF, 917.0 MHz","enable":true,                            "radio":0,"if":-200000},"chan_multiSF_2":{"desc":"Lora MAC, 125kHz, all SF, 917.                            2 MHz","enable":true,"radio":0,"if":0},"chan_multiSF_3":{"desc":"Lora MAC, 125kH                            z, all SF, 917.4 MHz","enable":true,"radio":0,"if":200000},"chan_multiSF_4":{"de                            sc":"Lora MAC, 125kHz, all SF, 917.6 MHz","enable":true,"radio":1,"if":-300000},                            "chan_multiSF_5":{"desc":"Lora MAC, 125kHz, all SF, 917.8 MHz","enable":true,"ra                            dio":1,"if":-100000},"chan_multiSF_6":{"desc":"Lora MAC, 125kHz, all SF, 918.0 M                            Hz","enable":true,"radio":1,"if":100000},"chan_multiSF_7":{"desc":"Lora MAC, 125                            kHz, all SF, 918.2 MHz","enable":true,"radio":1,"if":300000},"chan_Lora_std":{"d                            esc":"Lora MAC, 500kHz, SF8, 917.5 MHz","enable":true,"radio":0,"if":300000,"ban                            dwidth":500000,"spread_factor":8},"chan_FSK":{"desc":"disabled","enable":false},                            "tx_lut_0":{"desc":"TX gain table, index 0","pa_gain":0,"mix_gain":8,"rf_power":                            -6,"dig_gain":0},"tx_lut_1":{"desc":"TX gain table, index 1","pa_gain":0,"mix_ga                            in":10,"rf_power":-3,"dig_gain":0},"tx_lut_2":{"desc":"TX gain table, index 2","                            pa_gain":0,"mix_gain":12,"rf_power":0,"dig_gain":0},"tx_lut_3":{"desc":"TX gain                             table, index 3","pa_gain":1,"mix_gain":8,"rf_power":3,"dig_gain":0},"tx_lut_4":{                            "desc":"TX gain table, index 4","pa_gain":1,"mix_gain":10,"rf_power":6,"dig_gain                            ":0},"tx_lut_5":{"desc":"TX gain table, index 5","pa_gain":1,"mix_gain":12,"rf_p                            ower":10,"dig_gain":0},"tx_lut_6":{"desc":"TX gain table, index 6","pa_gain":1,"                            mix_gain":13,"rf_power":11,"dig_gain":0},"tx_lut_7":{"desc":"TX gain table, inde                            x 7","pa_gain":2,"mix_gain":9,"rf_power":12,"dig_gain":0},"tx_lut_8":{"desc":"TX                             gain table, index 8","pa_gain":1,"mix_gain":15,"rf_power":13,"dig_gain":0},"tx_                            lut_9":{"desc":"TX gain table, index 9","pa_gain":2,"mix_gain":10,"rf_power":14,                            "dig_gain":0},"tx_lut_10":{"desc":"TX gain table, index 10","pa_gain":2,"mix_gai                            n":11,"rf_power":16,"dig_gain":0},"tx_lut_11":{"desc":"TX gain table, index 11",                            "pa_gain":3,"mix_gain":9,"rf_power":20,"dig_gain":0},"tx_lut_12":{"desc":"TX gai                            n table, index 12","pa_gain":3,"mix_gain":10,"rf_power":23,"dig_gain":0},"tx_lut                            _13":{"desc":"TX gain table, index 13","pa_gain":3,"mix_gain":11,"rf_power":25,"                            dig_gain":0},"tx_lut_14":{"desc":"TX gain table, index 14","pa_gain":3,"mix_gain                            ":12,"rf_power":26,"dig_gain":0},"tx_lut_15":{"desc":"TX gain table, index 15","                            pa_gain":3,"mix_gain":14,"rf_power":27,"dig_gain":0}},"gateway_conf":{"server_ad                            dress":"router.au.thethings.network","serv_port_up":1700,"serv_port_down":1700,"                            servers":[{"server_address":"router.au.thethings.network","serv_port_up":1700,"s                            admin@mtcdt:~# tail -f /var/log/lora-pkt-fwd.log
### [ CONNECTIONS ] ###
# bridge.brazil.thethings.network: Connected
# Semtech status report send.
##### END #####
16:40:04  INFO: [TTN] bridge.brazil.thethings.network RTT 39
16:40:04  INFO: [TTN] send status success for bridge.brazil.thethings.network
16:40:25  INFO: Disabling GPS mode for concentrator's counter...
16:40:25  INFO: host/sx1301 time offset=(1551294655s:522873µs) - drift=-566µs
16:40:25  INFO: Enabling GPS mode for concentrator's counter.

Any advice?
I’m also trying to connect some NETVOX devices, but I’m not lucky either…

Thanks!
Diego.


(Crumble1970) #2

You are on quite an old version of code, probably also on the EVB.
The latest version for the gateway is 1.7.0, although you may want to try 1.6.4
Also on the EVB - Check the LoRaWAN mode is public with a rx window of 5s

Campbell
MultiTech


(Dmocci) #3

Hi Campbell,

I’ve tried with 1.6.4 and 1.7.0 and the issue persists.
I’m now trying with the Multitech AP. The gateway appears “connected” on the TTN console.
Then, I had re-configured the EVB, but no Join is possible, no data appeared on “Traffic” screen on the Gateway console, nor “data” on the device console.

I’m not a Linux expert, but there’s something I need to “delete” or “add” to the Gateway directory?
I cannot figure out what’s wrong here!

Thanks!
Diego.


(Crumble1970) #4

If we address the first issue - Of gateway connecting to TTN.
Are you using the TTN client, or the built in packet forwarder option?
For simplicity can you try the built in option? Set the gateway to packet forwarder, and then under the server option bottom left choose TTN.

Regards
Campbell


(Jreiss) #5

I expect “clksrc”: 0 for Multitech gateway as shown in the global_conf.json desc. The packet forwarder will not run without a clksrc although the bridge may be up to show connected.

"clksrc":1,"clksrc_desc":"radio_1 provides clock to concentrator for most devices except MultiTech. For MultiTech set to 0

(Jac Kersing) #6

For mp_pkt_fwd on MultiTech clksrc value in the configuration is ignored. The first log shows packets have been received and forwarded to TTN.

@dmocci what are the packet counters for the gateway in the console?
Do you have the data tab of the gateway open during the join request? What does it show? Keep in mind only data being received while the page is open will show.


(Dmocci) #7

None. I have the data tab open during the join request. But no data is shown.

Now, I made factory reset to the Conduit GW: erase the Gateway data, and install the Firmware again (1.6.4). Then, I also erase all configurations in TTN console and register a new Gateway. What I intend here is to make all from scratch.

Then, follow the steps to connect to TTN: Gateway connected status is OK. (US915).

Then, I configured 1 node (mdot) in US915, and thanksfully the Data appears in console and the Join is made!! :smile:

The previous configuration was made in AU915. And it didn’t work. As kersing said, packets were received by the GW and forwarded to TTN, but no “join” was able to make and no data was seen in console. So maybe, when I cahnged the freq band, something went missing?

I want to change the Band to AU915, because is the band we use here in Argentina. There is a special procedure to do this?

Thanks!
Diego.


(Jac Kersing) #8

Change it in the TTN console and reboot your gateway and you should be done.


(Dmocci) #9

Thanks @kersing @Crumble1970 !! Issue solved.
I’ve changed the AU915 band in TTN console and made succesful join with the EVB-mDot board ! :smile:

By the way, I realized that the problem are the NETVOX devices. They have fixed APP_EUI & APP_KEYS and TTN cannot make the proper join.

Have you used one of these devices?

Thanks for the support!
Diego.


(Crumble1970) #10

Hi Diego
I’ve not personally touched the NETVOX boxes, but having seen similar issues in the past with other sensor manufacturers - Check with them to see if they have some opened code enabling some flexibility?

Campbell