An unknown error occurred, contact administrator in Console

Hello :wink:

In the console, trying to access my apps, when i try to click on one of them, it give me error message:

Screenshot 2021-05-22 at 12.22.05

It only affect one of my apps , on charles proxy, i can see i got a weird 200 with a failure, or sometimes waiting for response body , yet in the response body, i got text answer with some json corresponding to all my end-user nodes. I can share more info in private.

Screenshot 2021-05-22 at 12.19.25
Screenshot 2021-05-22 at 12.34.37

On the other app, this call works great.
I tried different browsers, without joy :confused: All was working fine yesterday

Any help greatly appreciated please


1 Like

Hi. I have the same problem on TTN V3. Everything was working until today when I received the following error.
“An unknown error occurred. If the error persists after refreshing, please contact an administrator” .
I tried different browsers with no luck. It only happens when I try to access my end devices. I can change my password, log in and log out with no issues.

i notice it work better with firefox, you may have to refresh couple of times the pages until it start working, but its better than not having access at all :sweat_smile:

Unfortunately, the latest deployment introduced an issue in the Console which we will hotfix and deploy likely today. This affects navigating to single end devices in the Console as well as the payload formatter pages for individual end devices.

@Raccoon there should be no issues for the application pages. I’ll investigate this. Couid you send me the name of your application in a private message?

Note that this has been fixed now.

A similar error was presented after callaborator’s permissions were changed (even when given more permissions). If a collaborator then opened such application (or gateway) a similar error like above was presented and accessing the application (or gateway) was prohibited.

Has this issue also been fixed already?

1 Like

I can confirm that the error is still there.

If the error persists after refreshing, please contact an administrator

Without any information on what you were doing at that time the message came up, there is nothing to act upon.

1 Like

I’m getting:
An unknown error occurred
If the error persists after refreshing, please contact an administrator

when i’m trying to access specific devices, either by clicking on it through the end device list, or just by putting the name in the url.

Refreshing, closing and opening the browser does not remove the error.
The error has been there since 11 maybe longer, and it is still there.

1 Like

I believe this is a different error. You say it’s just specific devices. Any idea what could be particularly different about them?

@kschiffer What about?:

1 Like

I’m not aware of such error and was not immediately able to reproduce. Can you provide some more concrete reproduction steps (e.g. what rights were exactly set/unset)?

I would have to test it again and write down all steps.
Two months ago I wanted to use a ‘collaborator’ account for demonstrations during a presentation, but during the preparations I ran into the mentioned problems in more than one sitiation.

I’ll see if I can do some tests again soon. I will open an issue if the problem is still present.


they have worked fine before, but i can report that i have 20+ end devices where i get:

An unknown error occurred

If the error persists after refreshing, please contact an administrator

I have 20+ devices where i get when i try to view them.

An unknown error occurred

If the error persists after refreshing, please contact an administrator

it also occurs when going through the end devise list.

It has worked fine before, I started to get the problem Tuesday (25/05/2021) morning.

Please do not open a new topic on the same subject.

Please do not repeat the exact same detail - it has the reverse effect to highlighting the issue.

TTI devs write code most of the time and occasionally check in here, so it’s just us volunteers on here the rest of the time.

The two appropriate places for formal support are the #ops channel on Slack or post a GitHub issue.

One other option is Support

1 Like

I am experiencing the exact same problem. It seems to be browser related. The error occurs on Chrome but not on firefox…

Can’t access apps or gateways… on chrome

I am experiencing the same error -

End Devices are working fine when created through the console directly.

The error occurs when creating the end devices using either the CLI and or the API. I’m currently working on automating bulk enrollment of devices (100+). Although I am testing the process with only a single device.

When using the API, I am posting the following to /api/v3/applications/{my_app_id}/devices endpoint and I get status 200. I am also posting the same to the endpoints for the JS, NS and AS Reg.s - also status 200.

  "end_device": {
    "ids": {
      "device_id": "lt-100e-1062375d",
      "application_ids": {
        "application_id": "globalsat100"
      "dev_eui": "000DB5351062375D",
      "join_eui": "70B3D57ED00200A7"
    "name": "LT-100E-1062375D",
    "description": "LT-100E-1062375Dadded using TTN Enroller",
    "network_server_address": "",
    "application_server_address": "",
    "join_server_address": "",
    "root_keys": {
      "app_key": {
        "key": "78FA7A693AC10421E3C267E6F93572A0"

When viewed in web console’s end device list, they are displayed properly, but when trying to view the specific end device I get the error.

The same happens when I try creating the device using the TTN CLI integrated into my own CLI - status 200, device returned, showing in TTN console, but error when trying to access its page.

Code snippet from own CLI that uses:

ttn-lw-cli end-devices create [application-id] [device-id] [flags]
foreach (var endDevice in endDevices)
    process.StartInfo.Arguments = $"/C ttn-lw-cli end-devices " +
    $"create {endDevice.ids.application_ids.application_id} {endDevice.ids.device_id} " +
    $"--dev-eui {endDevice.ids.dev_eui} " +
    $"--join-eui {endDevice.ids.join_eui} ";
    string output = process.StandardOutput.ReadToEnd();

I am clearly missing something since I get status 200 on creation but error on web console - although I cannot solve this one…

If anyone here can pin-point my mistake or point me in a better direction for csv bulk enrollment of 100+ devices then thanks in advance!


I would expect device creation to require a lot more information like frequency plan, LoRaWAN version and regional parameter versions.
Have you added a device using the console and checked the developer (F12) mode of the browser? It uses the API so you can check all the calls with all arguments.