Arduino MKR WAN 1300

Thanks again Arjan (however: LoRa and descendants :wink: ).
I checked timestamps and it’s 2 seconds after Tx.
I tested OTAA and it never joins. Actually, it seems to never send to gateway, although since the gw is single channel (actually on 868.3), maybe one join attempt is not sufficient (I tried with 5 sequential without success).
Uplink is SF12 (I am/was interested in distance, although I tested also other SFs).

From reading this thread am I to conclude that the MKRWAN libraries restrict LoRa functionality? Should I consider another board for my project?

Honestly, as a newbie more interested in applications than in soldering, I bought an MKR WAN hoping to have everything ready. However, I soon learned that not everything is plug-and-play when looking at details (I was able to setup a basic RPi gateway in a couple of hours and a working node soon after starting from zero Arduino/RPi knowledge, but after a month no downlinks yet, for example).
There is much more documentation for LMIC-based solutions, and the official forum for MKR WAN 1300 is sleepy (maybe not many buyers yet). I am sure the hardware is more than adequate, but the library seems not sufficiently mature (not limiting, but also not supporting much). I expect it to enhance in the future, but in the meantime I am ready to try other roads.
Likely LMIC could be used for MKR WAN too, but I was not yet able to use it.


MKR WAN can not be used with Lmic unless you add a Lora radio like RFM95 to replace the Murata Lora module

1 Like

Really no way to directly access the SX1276 inside the Murata? Thanks.

Well, you can always replace the firmware which is on the STM32L0 :wink:
(I believe this is what @onehorse/@GrumpyOldPizza are doing on their devices: they run everything in the Murata MCU)

Now I don’t think the Arduino is that bad…

  • I don’t have any issue with downlinks on my side
  • ADR is a special thing, but it kind of works: if the first packet is sent with a confirmation request, it will adjust the datarate for the following packets. It is somewhat limited as the datarate won’t be adjusted afterwards…
  • It is also quite stable: I have one running since 215 days sending a packet every 5 minutes (>60000 packets) and it never resets.

There is a way on the MKR WAN 1300 to somehow … half way to access the SX1276 directly. Basically they have something in firmware, where SPI accesses are half way bridged. But that is a less than stellar approach.

And yes, you could replace the firmware on the STM32L0 there … Should not be that tricky … Looks like Arduino has 4 GPIOs connected between SAMD and STM32L0 plus RESET & BOOT.

60000 packets - amazing!!! :ok_hand:
How are you powering your board if I may ask?

are you using the LoraSendReceive example? and at which SF? thanks.

Thank you, half good news :wink: . However, I would rather prefer to use the original library, if everything is really functioning.

No wizardry here: the MKRWAN board was the first LoRa node I bought at the beginning of the year. I programmed it to send some payload every 5 minutes to test my gateways at first, then I decided to leave it plugged in to check stability. It is still running today.
But there is nothing special done on the power management side: it does not sleep, and it is simply powered through the USB port by a cell phone “charger”.

The LoraSendReceive example works fine. I stared from there and made some changes for various tests, but I always use the same skeleton. SF doesn’t matter (my gateways are in the same room).
I believe the issue here is your gateway.

1 Like

Thanks, this morning I did some tests with SF7 and SF9.
AT SF7 downlinks work: they are sent at the same frequency as the uplink. This is good.
At SF9, like at SF12, TTN sends at 869.525, and my node is not receiving. I expect the gateway be part of the problem, but the LoraSendReceive example seems not made for RX2 (unless there is an extra wait time at lower level).

BTW, in case one don’t know…
(I don’t think it is well documented – at least I haven’t found)

The latest MKRWAN library is on GitHub.
It is the exact same library you get in the Arduino IDE if you accept the library updates.
One of the examples is called MKRWANFWUpdate_standalone and allows you to bring the firmware of the Murata chip the the latest available one which is currently 1.1.6.
So if yours reports and older version, use this sketch to upgrade.

If you are curious about the firmware itself, it is available as well on GitHub!
It is interesting to see which AT commands are implemented – for testing I made a quick sketch which passes directly AT commands to the modem, so it sometimes helps to better understand how it works.
Also the MKRWAN.h library can easily be extended to support additional AT commands.

1 Like

It’s all updated here, and I also looked at firmware, thanks. I am glad that downlinks work at SF7 at least, however in the next days I will check SF12 through a real gateway (just to sort out). If you have everything in the same room, you do not have issues with distance :slight_smile:

Indeed :grinning:
But I can confirm it works for me as well at SF12.

Which gateway are you using? thanks.

DIY Raspberry Pi based; I have two IMST IC880A and one RAK831 concentrators.

:smiley: ok not that much magic then, but thanks anyway, really shows that board is stable!

I’d like to continue using it provided I am able to manage to get the power consumption under control, LiMC seems to be more efficient here, however, more long term tests needed to find out.

Hi! I have this gateway and I’m trying to send a message from an mkr1300.My problem is that when I run the code in Arduino from the mkr to connect to the gateway, I can’t get a connection in all the sending…In some of them have errors, in other say me that I’m in door and I have to go outside and in other have a correct connection with the same code…Someone have made proofs of connection?? Is it possible the problem could be the radios or channels in the gateway?


we are having some issues with the MKR1300 -
We have I2S sensor - and send data to TTN every couple of minutes)

we have unpredictable freezes of both our test devices after 12 -48 hours) - we still don’t understand why! (they dont seem to freeze at the same timeframe)

any suggestions?

Did you try without any sensor attached?