AU915: Using channels 64 to 71 (500kHz)


(Florencia M) #1

Hi everyone, new user here.

I’m trying to set up a LoRa Node using a Raspberry Pi and a Dragino shield with LMiC library. I need to enable channels 64 to 71 using de AU915 band, which are supposed to be 500kHz each.

I’ve allready adapted the US915 part of the code as follows:

lorabase.h:

enum { US915_125kHz_UPFBASE = 915200000,
       US915_125kHz_UPFSTEP =    200000,
       US915_500kHz_UPFBASE = 915900000,
       US915_500kHz_UPFSTEP =   1600000,
       US915_500kHz_DNFBASE = 923300000,
       US915_500kHz_DNFSTEP =    600000
};
enum { US915_FREQ_MIN = 915000000,
       US915_FREQ_MAX = 928000000 };

lmic.c:

void LMIC_disableChannel (u1_t channel) {
    if( channel < 72+MAX_XCHANNELS )        
    LMIC.channelMap[channel/16] &= ~(1<<(channel&0xF));
}

and of course i’ve set the CFG_us915 flag.

I’ve managed to disable certain channels using the LMIC_disableChannel() API, however, the ones remaing enabled don’t behave as I would’ve expected. When I disable every channel except for 64 to 71, I get the node to send in 8 different channels but with a BW of 125kHz and definitely not centered in the frequencies indicated in the LoRa specification: “8 channels numbered 64 to 71 utilizing LoRa 500 kHz BW at DR6 starting at 915.9 MHz and incrementing linearly by 1.6 MHz to 927.1 MHz” https://lora-alliance.org/sites/default/files/2018-04/lorawantm_regional_parameters_v1.1rb_-_final.pdf

I’m a little lost on what to do now. If anyone has managed to get something similar to work, I would very much appreciate the help.

Note: I’m working with an spectrum analyzer to see at which frequencies and Bw is the node sending.

Thanks in advance!
Florencia


(Maxious) #2

I used this repo’s fork to get AU915 with LMIC and the Dragino Lora HAT https://github.com/gloveboxes/lmic-rpi-lora-gps-hat eg. https://github.com/gloveboxes/lmic-rpi-lora-gps-hat/commit/73af5fafe20231453cdfee8c7deaf082f89747d5#diff-ba4baa9bc6b31966427d76b4248871dfR798 for the disableChannel changes (which also accounts for 500 kHz channels)


(Florencia M) #3

@maxious Thanks for the quick response. I took a look at the code and it seems this was what I was looking for. I’ll give it a try and let you know.


(Florencia M) #4

It worked! Thank you very much for your help!


(system) #5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.