AWS Integration is not Syncing - even though everything seems ok

Hoping to receive help in this issue. Have checked the forum for similar posts but they all refered to integration bugs (which this also could be i suppose) but I tried all the suggested solutions but nothing works.

  • Tried rebooting elastic beanstalk
  • Tried updating cloudformation stack (already was latest version)
  • Checked logs and we are not getting any errors
  • The integration gives GREEN light when you check it
  • The stacks and servers are OK

The thingsstack server is running fine. We can send mqtt to separate DB but AWS IOT don’t want to receive any data from Thingstack. Won’t add any things. Won’t allow subscription.

And we get no errors.

Don’t really know how to proceed with my troubleshooting. If anyone could help that would be very kind.

We started debugging AWS IOT with the tools from AWS and it seems that Thingstack is not communicating with AWS at all. Which is very confusing since the integration is not reporting any crazy errors. @johan is there some known bug with the integration that can cause this?

What exactly do you mean with this? The Things Network community network or a locally running The Things Stack (open source)?

@johan we are running this version:

We are running the server on a linux virtual machine with amazon aws. We have set it up ourselves so its not the enterprise cloud edition.

But if everything works out well we will probably purchase that edition. However; we want to try before we buy.

Great. Please use instead; the AWS IoT integration is not available in the open source edition. Also, the integration for The Things Enterprise Stack is the brand new