AWS IoT - no messages from / to TTN

I installed the TTN - AWS IoT integration following the “AWS IoT Integration” instructions in “learn” section + the Youtube video on TTN channel.
AWS zone: eu-central-1 (Frankfurt)

The installation was successful, the node of the TTN application appeared in AWS IoT core, but no uplink message (or downlink) arrives on AWS.

TTN AWS Iot version is 2.0.3.
Elastic Beanstalk logs at sections “/var/log/app-1.error.log” and “/var/log/app-1.log” have no data logged.

Environment Properties seems all ok.
The only I don’t know about is AWS_THING_TYPE that I et to lorawan as in the example.

I always used “simulated uplinks” from TTN console to make the tests.
I tried also to launch mosquitto_sub at same time, with same topic used in AWS. With Mosquitto MQTT client all messages arrived as expected.

What can I check to see why doesn’t work?

Same problem here…

We have the exact same problem, an external MQTT client can subscribe to the TTN broker and receive messages but nothing arrives in AWS. Did you find a solution to your problem?

Unfortunately I didn’t found a solution, so changed to another system since I had no time for debugging (I was doing some tests and needed something that allowed me to transmit the data without having to debug and find workarounds).

did you get any success in sending TTN data to AWS?

I have followed the same tutorial and can not get the messages to pass.

I followed the same tutorial and am experiencing the same problem.

I see device data at TTN, but it’s not showing up at AWS->AWSIoT->Test->Subscribe to a topic.

I see my subscribe requests (some values removed) appearing in AWS->CloudWatch->Logs->AWSIoTLogsV2, for example:


  • “timestamp”: “2019-08-01 14:53:45.163”,*
  • “logLevel”: “INFO”,*
  • “traceId”: “”,*
  • “accountId”: “”,*
  • “status”: “Success”,*
  • “eventType”: “Subscribe”,*
  • “protocol”: “MQTT”,*
  • “topicName”: “william-isense-app-id-2/devices/william-xdot/up”,*
  • “clientId”: “iotconsole”,*
  • “principalId”: “”,*
  • “sourceIp”: “”,*
  • “sourcePort”: 62817*

I do not see any device messages in that log.

Did anyone ever solve this?

resolved my issue, I had noticed that even though my stack built, it started another stack for the elastic beanstalk that didn’t work because I was out of EIP’s.

Initially after setting up the CFN from TTN I had the same issue. But after updating the Elastic Beanstalk app as shown here it started working just fine.

Same issue here, but I resolved it simply by restarting the EB server. Go to the Elastic Beanstalk console > your TTN integration environment > Actions > restart application server(s)!

Hi, same problem occurs here…I have created the integration few months back and it is work fine till now…
Now I have created new thing (application) on the same integration
. If I tried to receive uplink on this new thing…there is no data… But older thing is working fine
I have tried updating elastic beanstalk and also tried restarting the server …
None helped…