Axioma QALCOSONIC E3 with OTAA

Hi,

I do have a problem to register an Axioma QALCOSONIC E3 with OTAA (Lora Version 1.0.2).

When I try to use my private Chirpstack server running on a private server,
I do get a MIC Failed whenever a join-request occurs (tried MSB and LSB).

On TTN I do not see the JoinRequest at all - maybe because I do not have a gateway connected and the next gateway is too far away. But I can connect an ADEUNIS fieldtester without problems.

So maybe somebody has the same device up and running and can help me to find the problem.
Any help appreciated.

Living in the Stuttgart area btw

Thanks

I have it up and running on TTN without problem.
axioma meter has integrated antenna with bad performance, far worse than ADEUNIS fieldtester external dipole antenna. I guess thats the problem.

do you have payload formats decoder for axioma meter frames?

Thanks Nestor,

did you use OTAA?

I don’t think the antenna is the problem (at least right now). The gateway does not respond with JoinAccept on JoinRequests.

I’m in contact with the vendor, hopefully figuring out the issue.

Currently I do not have a payload format decoder - next step though.

Hello guys, i’m looking for a decoder for a qalcosonic w1 as well, did anyone found it?

yes, I use OTAA

Hi MartinM

I have the same problem like you . Did you solve it?

I have my own GW so I can check all traffics. Every 6 hours send my QALCOSONIC E3 a “Join-request” message but TTN ignore it.

NEWS: I solved my problem with just dismounting of LORA module from the main board connectors and installing it back. Lora modul sent a new Join-request message and TTN recognized my device.

i also need a decoder :frowning:

check Noob - Setting up Axioma Qalcosonic E3 Heat Monitor device - all preconfigured!

1 Like

Here’s my noob’s decoder for Qalcosonic W1 with loraServer :

https://pastebin.com/raw/35Mif5nk

1 Like

@rmivdc @nestorayuso I am newly working on this I have registered the gateway with TTN and added the devices in the application. But unable to see any data output
please let me know the payload format and do we need to configure downlink too??

@rmivdc Thank you for this example. I am about to order several Qalcosonic W1 meters, to use with a smoothly running TTOG, but I can’t test the decoder until I actually get the units. Could you confirm that this decoder worked for you?
Thanks

I can confirm this script worked for me with an old version of chirpstack (loraserver)
I remember that the JavaScript version for the decoder was pretty old, maybe it has been updated since and this script has to be updated too…
Please also mention that qalcosonic W1 android app is broken and not updated since January 2020 and that I had to h4ck it to make it work for setting my W1 through NFC…
The best way to program the W1 seems to be through that infrared area on the W1 with dedicated qalcosonic usb cable.
Give me some days to find my W1 back and check this script again.

1 Like