Big Problems using ABP and OTAA with different nodes

Dear all,
I am struggeling with a handful of problems. Slowly but securly the fun with this project tranforms into sadness. But enogh complaining for now. Let me describe you some of my problems:

I own a gateway, connected to TTN. It is a Dragino LPS8, placed on my roof with a RAK Antenna.
It is the only gateway in the area.

One of my nodes is a Stemedu Lora Node 1.0. I am running it with the ABP-example-Sketch. Now the strange thing comes into play: The message sent from the node is seen by the gateway (I see it in the TTN console). But somehow it is not linked to the device of my application. After some days of running it will suddenly work. It also works instantly if I leave the area of radio reception and come back. The message will be linked to the device from the first message on. BUT: If I reset the device I have the same problem as in the beginning - The gateway sees the messages from the node but there is no link to the device. And again after some days it will work.
If I take it with me and drive to another city with another gateway it will also work. If I come back to my gateway it works too. If there was no reset…

I don’t understand this.

Furthermore I have problems with my heltec esp32 Lora Node in OTAA. The gateway sees the join request, the gateway accepts this, but nothing happens. Sometimes it works. But most time it dont.

At the moment the node is 10m from the gateway. The rssi received by the gateway is -46 with a snr of 7.8 and a SF of 7
If it is working I have a range of up to 7km around my gateway. So signal strength should not be a problem.

Do you have any ideas?
Thank you very much.


Have you read about ABP, uplink counters and replay attacks? If not there are plenty of messages on the forum concerning this subject.

Is the join request shown in the application?

wow, thank you so much! ABP Problem is solved. I resetted the frame counter and now it works again. I have been searching for a solution for days. But I did not know the “keywords”. I alswayss suspected the gateway or server. But know I know the problem with the abp bug. Thank you.

The otaa behavior I will check tomorrow!

So then the description below was a false test result? Indeed, it made no sense:

I’d assume that you thought it was fixed due to moving it around, while actually it was probably solved as the uplink counter kept being incremented while you moved away. By the time you came back it probably already reached a value that was greater than the last value that TTN knew about. Does that sound feasible?

I think my description was a little bit unprecise. I meant if I leave the area in a working state and come back, it will still work.

But this explains now why it was not working after reset but startet working after a few days when the counter value was high enough again - as you already wrote.