Both gateways disconnected for 48 hours after recreate

Hello, I had to change the gateway ID of my two existing gateways, so I deleted them and then I recreated them with the same EUI. After that, both gateways are with in a Disconnected status for almost 48 hours.

Screenshot 2021-04-27 at 16.11.54

I check the gateway logs and traffic logs, all seems to be just fine. Before the recreation, both gateways worked without any troubles. I’ve also tried to reboot the gateway, but with no results.

When I try to list my gateways using ttn-lw-cli g list I see:

[{
  "ids": {
    "gateway_id": "iptec-3133303721006f00-gw",
    "eui": "3133303721006F00"
  },
  "created_at": "2021-04-26T15:03:14.792Z",
  "updated_at": "2021-04-27T11:32:15.235Z",
  "version_ids": {

  }
}, {
  "ids": {
    "gateway_id": "iptec-3133303754006500-gw",
    "eui": "3133303754006500"
  },
  "created_at": "2021-04-26T15:05:05.083Z",
  "updated_at": "2021-04-27T12:14:40.762Z",
  "version_ids": {

  }
}]

But when I try to check gateway’s stats calling ttn-lw-cli g get-connection-stats iptec-3133303754006500-gw I get:

error:pkg/gatewayserver:not_connected (gateway `iptec-3133303721006f00-gw@ttn` not connected)
    gateway_uid=iptec-3133303721006f00-gw@ttn
    correlation_id=c581540c3ac24637b100f53a14793192
--- error:pkg/redis:not_found (entity not found)

Would anyone be so kind and help me to resolve this issue?

1 Like

I have been experiencing the same issue, I wanted step through the process of adding a gateway again so I deleted my gateway, after recreating the gateway it is stuck as Disconnected.
It seems like the old instance was not fully deleted since I am still receiving data with the old gateway ID.

1 Like

Hello, here is some insight, what is going on: Gateways disconnected after recreate with different ID · Issue #4103 · TheThingsNetwork/lorawan-stack · GitHub