Broken Power supply after long time TTIG

Hello i have one of the first TTIG Gateway.
Now after always connected to the 230V Power it is broken.
I tested it with USB Power working fine. Any suggestions how to fix it?
Thanks Matthias

Whilst I’m sure TTI and Browan would declare as ‘no user serviceable parts inside’, given its out of warranty by now a competant/qualified electronics eng should be able to diagnose and replace the internal PSU module - its a long time since I looked inside and no time to search forum (try that) where I have seen pictures and call out in the past but you could source a replacement. I think its a stock PSU module from the likes of MeanWell or one of the other well known brands.

Update: I check old photos from when I had a 915Mhz vs 868Mhz misship and looks like it is the Meanwell IRM-10-15. These are stocked by the likes of RS Components, Digi-Key, Arrow, Farnell etc.

image

Thanks is their a good trick how to open it easily?

But naturally no one but a qualified electrician should do anything with a mains power supply unless you declare that anything you may choose to do would be at your own risk.

Take a look at the pic, from memory the process is pop off the top and bottom covers which you can see are clipped into place with small lugs. Underneath you will then find a couple of small screws (I think one at one end two at the other?) - take them out and that allows the case to be split…again held by plastic clips/lugs.

If you (or anyone else with the same problem) are shy of opening the case and soldering the PCB: perhaps it’s actually a viable workaround to use the external USB power supply for the TTIG?

As I wrote it works with the normal usb c connector.
So I can use an external power but I don’t want.

I found the error an broken platic holder. I fixed it and when worked again.
Screenshot_20210601_135940_com.android.gallery3d

2 Likes