Can not use end device using AS923-2 in The Thing Stack

Why does TTN define AS923-2 as frequency 923 - 925. This is different from LoRa Alliance, Inc. I can choose AS923-2 to send data from the end device to the gateway but when I cannot forward data to the network server. The actual frequency when the gateway receives from the sensor is 921.4 - 921.6

Not had time to look at details but what jumps out as perhaps key is the (-1.80Mhz) Freq Offset. Look at (1) 923.2 - 1.80 = 821.4, (4) 923.8 - 1.80 = 922.0 - limited available channels in the sub-band in some locations? I need to go evaluate details after weekend… perhaps @Johan can shed light…

1 Like

The AS923 plans listed on that page are versions of AS923-1. They both have default frequencies of 923.2 and 923.4. “AS1” has additional channels below 923.2 where “AS2” has additional channels above 923.4.

Latest doc is here, just a list of plans with little detail.

Plans are defined here.

Which plan have you selected for your gateway and end-device in TTN?

Hi Mr. Jason Reiss,
Thanks for your help. I selected Asia 920-923 MHz. Gateway can get data from the end device. The attached image show the message form network server. I also tried sellect Asia 923-925 but it is still fail. Please give me some advices.


Which nodes? How configured/what frequency plan are they set to? Both GW & Nodes must use same plan…I assume you are in Vietnam - hence the AS923-925 ~AS2" as above? If so running lower may be illegal in territory and reall needs fixing :policeman: :police_car: :judge:

Hi Mr. Jeff,
According to Lora Alliance documentation, AS923-2 has a frequency of 920-923. It’s different from that of TTN

Indeed, and you saw my comment above wrt Freq offset under plan, and comment wrt reduced number of channels available under the plan…then you looked at the links provided by Jason @jreiss, specifically this one appears to hold - if @Johan comments you might get more…us voluteers dont set the plans unfortunately (or more likely fortunately :rofl: )

AS923-AS925 (“AS2”) may have been created before AS923-2 existed in Regional Params spec.

AS923-AS925 (“AS2”) == AS923-1
AS923-AS925 (“AS2”) != AS923-2

AS920-AS923 == AS923-2
You say that this plan is working. I would use this plan.

Unless you have more info?

The gateway can get data from the end device but the end device still cannot join the network server. It says “uplink chanel not found” error like the image attached above

Which plan have you selected for your gateway and end-device in TTN?

Both gw and device settings in TTN must match.

Uplink channel not found usually means the end device record in TTN is not correct.

I selected AS920-AS923 for both gw and end device

Is your device set to OTAA or ABP?

Hi Mr. Kersing,
My end device was set OTAA.

That happens if the device sends data on a frequency that does not match the device settings. Make sure your hardware is configured to use:

otherwise it will not be able to join.

AS920-AS923 looks to be another AS923-1 version.
Channels are 922.0-923.4 MHz so the channels your device and gateway are using, 921.4 and 921.6 are not supported.

Asia 920-923 MHz (AS923 Group 2) plans are what you are looking for.
They only support the two default channels as @Jeff-UK has shown.

The mapping of TTN UI dropdown selections to plans are shown in this file.

Yes, I think this is a problem. My end device has been set with AS923-2.The actual frequency it sends to the gateway is 921.4-921.6MHz. This frequency complies with the LoRa Alliance, Inc. specification for AS923-2. But on TNN I can’t find suitable option for AS923-2. The option Asia 920-923 on TNN is AS923-1. Does that mean I can’t use AS923-2 on TTN?

Thanks a lot for your reasonable explanation. Does that mean I can’t use AS923-2 on TTN?

“Asia 920-923 MHz (AS923 Group 2)” plans are what you are looking for. There are several options.

Group 2 = A923-2