Can´t connect RAK811 to TTN using dragino shield and RPi 3


(Dani17 Mr) #1

Hi,
My name is Daniela and I live in Mexico City. In the last two weeks I’ve been trying to upload information to TTN with WisNode-Lora. I configured my gateway with the features shown in the first photograph. The RaspBerry PI code is displayed. From what I read, the gateway configuration only allows it to be used in ABP applications. So the WisNode-Lora also configured it in ABP. In the second image, the commands used are shown. From what I read, I should have a code that would say the following: at + recv = 3,0,0. However, it appears at + recv = 6,0,0 or ERROR -13. Does anyone have any idea how to solve this? The third image shows what appears on the screen when the gateway is started. For the tutorials I have consulted, it is working. In the fourth image you can see the status of the gateway in TTN. Finally, the fifth image shows how I am setting up my device in my application.I need your help, I should finish this project as soon as possible.

I leave a link below with a folder where you can see each of the images. Thanks again!

https://drive.google.com/drive/folders/16umW5IirLVJEXwdVS8b5Bj93Sx73WieM?usp=sharing


(Cslorabox) #2

This is a project which is difficult enough using the correct parts like a real gateway, and is going to be extremely difficult with a single channel sorta-gateway.

That said:

  1. There is no indication that your gateway has ever received a LoRa packet, it is only showing status messages

  2. Your gateway is listening on 915.0 MHz, which is not a typical frequency for LoRa nodes, if your node expects a multi-channel gateway it is probably never going to transmit on the this frequency at all. You will need to make sure the node transmits on 915 MHz at least some of the time, or preferably only uses that frequency. Or else move the gateway to a frequency which the node is using.

  3. It is unclear why your node is giving error -13, but that does not seem to be a good thing

Overall the best advice is to get appropriate hardware such as a real gateway. But if you want to pursue this, start by making sure that the node is configured for the same channel, spreading factor, preamble, and IQ inversion as the gateway, then figure out how to get the transmit command to not return an error.


(Dani17 Mr) #3

Hi, thanks for the fast reply

I’m in Mexico and that’s why i’m using a node listening on 915 MHz, which is the frequency that is set at the factory.

1.How can I know that both the gateway and the rak811 node can receive messages at that frequency?

2.The Error -13 it refers to: CODE_TX_LEN_LIMITE_ERR according to the user manual RAK811 Lora AT Command V1.5, I found it on page 6 at https://downloads.rakwireless.com/en/LoRa/RAK811/Software_Development/RAK811 LoRa AT Command V1.5.pdf.
There is also the image of the table with the errors in the following drive: https://drive.google.com/drive/folders/16umW5IirLVJEXwdVS8b5Bj93Sx73WieM

When do we change the SF what other parameters should change? because we already configured the SF of the gateway to 12 which is the default for the rak811 but it is still not communicated


(Cslorabox) #4

Your gateway screen shot shows it is listening at SF7.

SF12 would give you an extremely short data allowance at a 125 KHz bandwidth, if your regulations in Mexico are anything like in the US it is essentially not usable for LoRaWan because the headers by themselves would consume all the allowance.

For a nearby test SF7 isn’t a bad place to start (you can also try numbers up to SF10). Try setting both your gateway and node to SF7, 125 KHz and the same frequency, preamble, and IQ inversion. Experiment with other alternatives only once you get this working.

Also make sure that your number of hex digits is even - accidentally having an odd number could be another thing that triggers and error, as a packet would be expected to be a whole number of bytes, and a byte takes two digits to represent.