Can't change gateway location

Hello everyone,
I’m trying to change the location (set manually) of my gateway from the TheThingsStack console but even if everything seems to be fine when I update the page everything goes back to the way it was before. Can you help me?

Gateway console → Location → use map to change location interactively or type in gps co-ordinates where known, dont forget to update altitude (ASL) if known, then dont forget to “save changes”!! have been caught out in past clicking away from Location page without saving and old position re-asserts :blush:

Thank you @Jeff-UK for your answer. Tried dozens of times. Saved the changes. No way.
The gateway has been in another city for over a year and I only realized now that it doesn’t implement the changes.

Is it ‘yours’ as in do you have full user rights to amend update details? Does it belong to an organisation?

It’s mine, as a private person. I’m the only user that uses it, so I think I have full user rights.

I have just done it the way Jeff describes.

If you are looking at the position on TTN mapper you will need to wait for a while, give all the servers a chance to update.

And do you have it on manual update?


No TTN mapper, I’m looking at the “the things stack” location.
Yes, location set manually.

I go to my Gateways. I click on my gateway, i click to “Location”. The location is wrong. I set the correct location with the map (latitude and longitude are changed consequently) , I click on “Save Changes”. Everything seems ok. I click on Overview and the changes are disappeared.

I have just changed my gateways location, logged out and back in and the location stays the new location.

You may need to flag to TTI Core team on TTN Slack using the #support channel as sounds like you have done all the right things but dont understand why old data persisting and as none of the volunteers here have database access not much we can do. What is the GW-ID?

Thank you all for the help. The Gateway ID is tsl01.
I think I have identified the problem. The “Set location manually” setting is not considered. I realized that as soon as I update the position on TTS the position remains correct until the first message “receives gateway status” arrives. In the message there are the old wrong coordinates (set in the LPS8 and I didn’t even remind me). By updating the coordinates in the dragino I can maintain the right position. The problem is that “Set Location Manually” is not considered.