Can't join OTAA / Libelium LoRaWAN 868 Module


#1

Hi,

so, I can't join TTN via OTAA anymore with my Raspberry Pi with an Libelium LoRaWAN 868 Module.
I'm using this code example provided by Libelium.
My Gateway is up and running, I could join the network with another device (which uses another Module for LoRaWAN connections), so I'm sure it's not the Gateways fault.
With the Libelium Module, I managed to have it "seen" by TTN yesterday, although there was this same join network error, now not even this works anymore.
Note; doesn't matter whether I send a confirmed or an unconfirmed message, it's the same error.

LoRaWAN example - Send Confirmed packets (with ACK)
------------------------------------
Module configuration
------------------------------------

1. Switch ON OK
2. Device EUI set OK
3. Application EUI set OK
4. Application Key set OK
5. Save configuration OK

------------------------------------
Module configured
------------------------------------

Device EUI: <redacted> Device Address: 26012213

1. Switch ON OK
2. Join network error = 1
4. Clean channels OK
5. Switch OFF OK

Has anything changed in the last few weeks, or could it be another error?
Will provide any further information if neccessary.

Thank you in advance.

Edit;
I should probably add, "Join network error = 1" means * '1' : Module communication error - so there's probably no connection to the gateway possible.
It's in line of sight, around 300 meters away on a tower, 137 meter above ground.


(Arjan) #2

There is no such thing. If an OTAA Join Request is rejected, no response is sent at all. But not getting any response could also mean the request was not received by the gateway, or that the Join Accept (which would be visible in TTN Console) is not received by the node.

So: see the Traffic page of your gateway in TTN Console.

You might still use the wrong format for your node (like MSB vs LSB), but since it did work earlier, I guess that's not the case here.


#3

You're right, I mistook error 1 here. Fixed it in my post.

There's absolutely nothing on the traffic page - so I guess it's "out of range" or there are interferences, blocking the signal?

The Gateway is in line of sight, less than 500 meters away on a tower, 137 meters above ground. There shouldn't be many interferences or something.


#4

The connection has to be the problem.
There were 2 activations that made it to TTN, so it can't be a software related problem.
Either, the gateway is in a very unfortunate position, or my sending node (the Module / Antenna?)is just too weak to make the clear line of less than 500 meters to the gateway.

See this topic as "closed".


(Arjan) #5

If you also see an outgoing Join Accept, then you know TTN accepted the keys. If you only see the Join Request, but no outgoing Accept, then the keys are wrong.


#6

Join request and join accept were send, so this part is fine.


(Satellite Applications Catapult) #7

I’ve seen this behaviour (subsequent join requests) when Join Delay was too short (supposedly set for private and not for public network. I’m just searching for it in Libelium docs (ugh)


#8

1 year later :roll_eyes:


#9