Changing AppEUI in TTN v3

By mistake I insert the same value for DevEUI and AppEUI for my device in TTN v3.
My problem is, I can’t change the wrong AppEUI.
And when I try to delete the device, I get a warning that I can’t use the same device ID again.

But I would like to keep my device ID and just correct the AppEUI. In v2 it was easily possible. But in v3 there is no possibility to change the AppEUI.

Is there any way to solve this problem. Maybe by ttn console or something like this.

Does CLI provide a route? @descartes Nick?

Using my crib sheet at http://descartes.co.uk/TTSv3CLI.html

ttn-lw-cli end-devices set [application-id] [device-id] [flags]

with flags of --join-eui string (hex)

But some of the flags would contradict the console so your mileage may vary.

That said, does it matter that the Dev & App/Join EUI are the same?

1 Like

Hello, I have to raise the issue again.

I need to change the AppEUI number.
I enter the CLI command:

ttn-lw-cli end-devices set --application-id cloc-addhoc --device-id eui-0004a30b0xxxxxxx --join-eui 1234567453450000

Unfortunately I get the following message:

WARN No fields selected, won’t update anything

Which fields do I have to fill in, the documentation says nothing?

Thank You!!!

If you look at the format of the command, you’ll see you haven’t told it which device you want to change but you have told it that you want to change three fields. You may want to compare and contrast what I put vs what you’ve added

1 Like

Ok, very thanks for the quick reply!

I compared it with your example. According to the documentation, only the field after the flag is set, right?
In the example below only one field.

ttn-lw-cli end-devices set cloc-appid eui-0004a30b00xxxxxxx --join-eui xxxxx2414e49000

The message is still:

WARN No fields selected, won’t update anything

Sorry but I see no error

The second thing I tried was to reset the AppEUI number.

ttn-lw-cli.exe end-devices set cloc-xxxxxx eui-xxxxxx0b00f7eda5 --unset join_eui

Here, too, an unassigned error message comes up:

flag “net_id” not found

What am I doing wrong? Thanks!

In case someone has the same problem. Here are the ways that worked for me.

Solution 1: It is better to delete the entries in the correct order via the console and create them again.

Solution 2: Use cli on Linux or MAC. (I had used cli on windows)