Configuring a Multitech mDot Box for use on TTN


(Grant Faber) #1

We’ve got a Multitech mDot Box that I got as part of the developer kit. We want to use it for range testing and site survey in the coming weeks as we roll out additional gateways. However, we’re having trouble getting it to connect to the gateway once the gateway is configured for TTN.

We’ve had to update the firmware on the gateways and nodes to the Aus verison (bumps up the frequency). The firmware has also been updated on the mDot Box. When the gateway (Conduit 210A) is configured as public with packet forwarding to TTN then the Box can’t connect. The only way we’ve had it connect is when the gateway config is set to defaults.

Has anyone used the mDot Box on TTN?

Link to mdot Box


#2

HI Grant,

I was led here while trying to decide whether to get one myself.

My interpretation of the mDot Box info at http://www.multitech.co.uk/brands/multiconnect-mdot-box is that it will work in LoRa mode to a gateway by default (all 3 listed modes), but not LoRaWAN configured to The Things Network.

For that I think you’ll need to program the mdot to connect to TTN. @thinginnovations code may help here: https://developer.mbed.org/teams/Thing-Innovations/code/mDot_TTN_OTAA_Node/

I’m still searching for the finished product which will allow TTN tests using this mDot Box. I’ll let you know if I find it.

Ben


#3

Grant,

This link http://www.multitech.net/developer/forums/topic/mtdot-box/ suggests that configuring the mdot module that goes into the mdot box is the way to get it to join TTN first. This is probably done using AT commands and not mbed development as I wrongly said above.

So once it’s configured using AT commands you should get a packet you have to decode (format help http://www.multitech.net/developer/software/dot-box-and-evb-software/data-packet-format/)

Does this sound like a possible fix, or have you tried this?

Ben


#4

Some people cleverer than me have given me some AT commands which will help:

# wake up (try this twice)
AT
# factory defaults
AT&F
# public network mode
AT+PN=1
# network join OTAA
AT+NJM=1
# set AppEUI
AT+NI=0,<Hex AppEUI> 
# set AppKey                                                                    
AT+NK=0,<Hex AppKey>
# store settings
AT&W
# join
AT+JOIN
# send something
at+send=hello

This should let you join TTN and then start sending.

Ben


(Grant Faber) #5

Hey Ben,

Thanks for all that research, I’ve had a busy couple of weeks on other things. I’m going to give the config a crack now, see how it works and let you know.

Grant


#6

I had a one time issue with an mDot that I cannot replicate. It was set to public mode (AT+PN=1, verified via AT&V) but it was only waiting for 2 seconds before failing to join a network. I had to manually toggle it from AT+PN=0 back to AT+PN=1 for it to wait the full 5-6 seconds to join. You might want to try toggling PN a few times.


(Grant Faber) #7

I followed the instructions above, including setting the subband and this is the config I set:

Library : 1.0.8-AU915-AU915-debug
Device ID: 00:80:00:00:00:00:bb:30
Frequency Band: FB_915
Frequency Sub Band: 2
Public Network: on
Network Address: 00000000
Network ID: 70:b3:d5:7e:f0:xx:xx
Network ID Passphrase:
Network Key: 56.65.eb.5f.75.6e.a5.2f.35.79.3f.xx.xx.xx.xx.xx
Network Key Passphrase:
Network Session Key: 00.00.00.00.00.00.00.00.00.00.00.00.00.00.00.00
Data Session Key: 00.00.00.00.00.00.00.00.00.00.00.00.00.00.00.00
Network Join Mode: OTA
Tx Data Rate: DR253
Tx Power: 11
Log Level: 6
Maximum Size: 242
Minimum Size: 11
Maximum Power: 20
Minimum Power: 2
Data: 0

It doesn’t connect yet, though I wasn’t able to use the at+join command, still working that out. I’ve also tried configuring OTA Auto Join by using AT+NJM=2 but it doesn’t recognise the 2, only 0 and 1. I’m going to try using ABP activation and the commands listed on the Multitech support site for mDot Box. It says:
"The +NJM command controls how the device joins the network. In Manual mode, there is no join request sent and the device must be manually configured with a network address (+NA), a network session key (+NSK), and a data session key (+DSK).

The device must be provisioned with the network server as well. In OTA mode, the device only needs to be configured with a network name (+NI=1,name) and network passphrase (+NK=1,passphrase). The network session key, data session key, and network address are all automatically configured."


(John caipa) #8

Hi Grant, i would like to be able to do the same with my mdot box, can you tell me if you achieve to configure the device?


(Grant Faber) #9

I still haven’t been able to get it to work.


#10

Hi Grant,

I got mine up and running just recently. I misled you with the AT commands - those are for the generic MDOT AT command firmware. Some of them work, but a quick look with the HELP command when connected to the MDOTBOX shows they are device specific. There is no join command.

Your configuration as shown from AT&V looks correct. I would do an AT&F to wipe it and start again. Minimum configuration for an OTA device seems to be:
AT+PN=1
AT+NI=0,
AT+NK=0,
AT+NJM=1
AT&W
AT+EXIT

Have a look at the console after doing exit and see what you can find. I hadn’t configured public mode, so was never getting an ACK.

It may be related to your regulatory location (AUS), perhaps the firmware isn’t as well tested on that. Also check you’re on v2.1.2 ftp://ftp.multitech.com/wireless/mtdot/

Firmware: 2.1.2
Library : 2.0.16-mbed126

Let me know how you get on.

Ben


(Grant Faber) #11

Hi Ben,

I switched over from ABP to OTA and got it working. I used the help function on the mDot Box to map the fields. I used the following fields:

AT&F Reset Factory Defaults
AT+FSB=2 Frequency Sub-band
AT+PN=1 Public Network Enable/disable public network mode.
AT+NJM=1 Network Join Mode 0: Manual configuration, 1: OTA Network Join (default: 1)
AT+DI=devEUI Device ID Device EUI-64 (MSB) (8 bytes)
AT+NA=devAddr Network Address Network address (devAddr in TTN) (4 bytes)
AT+NK=0,App Key Network Key Configured network key (App Key in TTN) (16 bytes)
AT+NI=0,App EUI Network ID Configured Network EUI (App EUI in TTN) (8 bytes)
AT&W Save Configuration

The mDot Box now joins the network and I’m getting data through in Survey mode, but not Demo mode. What result did you get get?

Grant


(Grant Faber) #12

How did you fix this? I was having a similar issue, but mine is due to the Device ID resetting itself after the device is powered off.

EDIT: I did some research and found the DevEUI on the mDot Box is coded at the factory and not meant/able to be changed. In the end I updated my Device EUI in my TTN App to match the factory set DevEUI on the mDot Box. Joins are now successful after cycling the power on the mDot Box.


#13

Great news Grant

How are you intepreting the data from the mdot box? Got any suggestions how to plot this?

Trivia:
After losing several mdots to flash corruption I received some advice from @andrewl and Multitech. It involved rebooting into the bootloader and erasing the flash. This also erased the DevEUI so a special firmware to set the DevEUI was supplied. You could override the DevEUI here, but given that the DevEUI is printed on the sticker I’d seriously avoid changing it, and as you’ve done, fix the app. I’m also wondering how they knew the frequency without me specifying so perhaps it’s dictated by the DevEUI.


#14

the firmware image you used to reset the Dev EUI is frequency specific, so presumably you used the 868MHz specific version without even knowing it!


(Paulbardini) #15

Hey Brandon Did you work out this problem - this same has happen to me. Toggle the pn 1 - 0 and it connected. never to happen again.


#16

I just made my configure script always toggle it back and fourth. I never saw it happen again but the toggling seems to work, so I just left it as is to prevent it happening again.


(Paulbardini) #17

Thanks for your reply mate.
P


(John caipa) #18

Is there a way to change the frequency band from US915 to AU915 with the AT commands for the mdot-box ?, is the problem that I am having since my Conduit gateway is configured for AU915


(Grant Faber) #19

You need to load the AU firmware to the mDot box to adjust the sub-band settings.


(John caipa) #20

Dear daforg, Did yourmDot box work with this change? Do you have a link where I can find it? Thanks in advance