Connecting the Multi tech gateway to things networks


(Adil Hidayat) #22

@kersing I’ve not been sleeping for several nights trying to figure out how to connect my MultiTech AEP to TTN. I’ve followed the official guideline https://www.thethingsnetwork.org/docs/gateways/multitech/aep.html got everything configured and working on the AEP, added the gateway to TTN but my gateway status remains ‘not connected

I’ve check the connectivity from my MultiTech on port 1700 but there seems to be no activity (no traffic).

This is what my local_conf.json looks like:
admin@mtcdt:~# cat /var/config/lora/local_conf.json
{
/* Settings defined in global_conf will be overwritten by those in local_conf /
“gateway_conf”: {
/
gateway_ID is based on unique hardware ID, do not edit /
“gateway_ID”: “00800000A00003C1”,
/
Email of gateway operator, max 40 chars*/
“contact_email”: “adil@my6.my”,
/* Public description of this device, max 64 chars /
“description”: “My6 LoRa Gateway”,
/
Enter VALID GPS coordinates below before enabling fake GPS */
“gps”: true,
“fake_gps”: true,
“ref_latitude”: 3.138695?,
“ref_longitude”: 101.597866,
“ref_altitude”: 56 m
}
}

Looking forward for your kind assistance…


(Jac Kersing) #23

There are errors in your json. There should not be a question mark on the ref_latitude line and no ‘m’ on the ref_altitude line. Correct these and restart the packet forwarder (run ‘/etc/init.d/ttn-pkt-forwarder restart’ without quotes)

Next, the gateway should be logging output to /var/log/lora-pkt-fwd.log, check this file for any error messages.


(Adil Hidayat) #24

@kersing, your response have been very helpful. I’ve corrected the errors in my json file and now my gateway is visible on TTN. Thank you :kissing_heart:


(Adil Hidayat) #25

@kersing, will there be any issues running NodeRed on the MultiTech after running the ttn-pkt-forwarder? I tried running NodeRed but i could not get into the login page, the browser keeps on refreshing (continuously) the login page without the Username and Password fields.


(Jac Kersing) #26

The ttn-packet forwarder disables the build in lora server startup. May-be the NodeRed checks its availability? I’m running mLinux mode, not Conduit so I can’t check at the moment.


(Adil Hidayat) #27

I’ve got the AEP connected to TTN for few days now with the ttn-pkt-forwarder . I did some checking on the conduit and I’m not sure if this is considered normal. Refer to the images below:

Should i disable/stop the basic_pkt_fwd & lora-network-se ? There’s only 1 sensor device in close proximity using the gateway and yet the CPU utilisation is 72~90% at times.


(Jac Kersing) #28

The installer script for Poly forwarder explicitly disables the conduit software because the two packet forwarders can not run simultaneously. Please disable the basic forwarder if you want to run poly forwarder.


(Ian Tairea) #29

@kersing I made the same mistake of adding ‘m’ to altitude.
I am getting this error when trying to restart script…

admin@mtcdt:~# /etc/init.d/ttn-pkt-forwarder restart
Stopping ttn-packet-forwarder: start-stop-daemon: warning: failed to kill 1687: No such process

Thanks Kersing, for all your work.


(Jac Kersing) #30

Edit ‘/var/config/lora/local_conf.json’ and remove the offending ‘m’, next restart the forwarder.
Check ‘/var/log/lora-pkt-fwd.log’ to see if it started correctly or if any (other) issues are reported. The output to the file is buffered so output will not be complete while the packet forwarder is running. (Usually indicated by the file contents stopping in the middle of a line of text)


(Ian Tairea) #31

Working, AEP now connected to TTN. Thank you, @kersing !

Like u said, I had to fix the /var/config/lora/local_conf.json file. I did this by entering

vi /var/config/lora/local_conf.json

removing the ‘m’ from altitude, then exit and saving by entering

:w

to save and exit.

So in summary, steps I took to get connected…

  1. Follow this guide https://www.thethingsnetwork.org/docs/gateways/multitech/aep.html
  2. When running installer sh installer.sh Make sure you enter your details correctly. i.e. no ‘m’ for meters on altitude.

(Bearattack) #32

@kersing you seem to be the master around here!

I’ve been trying to get my conduit AEP connected to TTN for quite some time now, but to no avail.
Followed your instructions (and some others), but nothing seems to work…
Now everything seems to be in a mess.
Is there an easy way to recover, or wipe everything and start again??
I’m hoping you can lead me in the right direction please!

I was going to try and flash to mLinux and try again, but thought you may be able to save me first… Many thanks!

I’ve dumped the output to all your questions/directions above

admin@mtcdt:~# cat /var/config/.installer

secure
timezone
network
date
disable-mtech

admin@mtcdt:~# ls -l /var/config/lora

-rw-r–r-- 1 admin root 6026 Aug 11 15:55 global_conf.json
-rw-r–r-- 1 admin root 70 Aug 11 15:31 global_conf_src
-rw-r–r-- 1 admin root 689 Aug 11 15:48 local_conf.json
-rw-r–r-- 1 admin root 313 May 5 01:01 multitech_overrides.json
drwxr-xr-x 2 admin root 0 Aug 11 15:31 samples
-rw-r–r-- 1 admin root 3193 Aug 11 15:55 ttn_global_conf.json

admin@mtcdt:~# cd
admin@mtcdt:~# ls -l

drwxrwxrwx 2 1001 1001 0 Feb 21 02:35 Multitech_Lora
-rwxr-xr-x 1 admin root 7418 Jun 7 17:56 create-package.sh
-rw-r–r-- 1 admin root 54 Jun 7 17:56 info
-rw-r–r-- 1 admin root 3964611 Jun 7 17:59 multitech-conduit-pktfwd.tar.gz
-rwxr-xr-x 1 admin root 18489 Jun 7 17:56 multitech-installer.sh
drwxr-xr-x 2 admin root 0 Aug 11 11:06 multitech-release-4YXLxzjZHYT889M92cUo
-rwxr-xr-x 1 admin root 11110761 Jun 7 17:56 packet-forwarder

admin@mtcdt:~# cat /var/config/lora/local_conf.json
{
/* Settings defined in global_conf will be overwritten by those in local_conf /
“gateway_conf”: {
/
gateway_ID is based on unique hardware ID, do not edit /
“gateway_ID”: “00800000A0000F09”,
/
Email of gateway operator, max 40 chars*/
“contact_email”: "adamxxxxx@xxxxmail.com",
/* Public description of this device, max 64 chars /
“description”: “”,
“gps”: false,
“fake_gps”: false,
“servers”: [
{
“serv_type”: “ttn”,
“server_address”: “thethings.meshed.com.au”,
“serv_gw_id”: “adams_test”,
“serv_gw_key”: “ttn-account-v2.VptlP3V3g6Hl34BtWefNLrMgUjI7QZHRf3JQGKjG9uNmSbEolVKusj3esjB8zcWGaEGUTPp80WBkdSKAzXKHwA”,
“serv_enabled”: true
}
]
}
}
admin@mtcdt:~# grep gateway /var/conf/lora/local_conf.json
grep: /var/conf/lora/local_conf.json: No such file or directory
admin@mtcdt:~# grep server_address /var/config/lora/global_cong.json
grep: /var/config/lora/global_cong.json: No such file or directory
admin@mtcdt:~# cat /var/config/lora/local_conf.json
{
/
Settings defined in global_conf will be overwritten by those in local_conf /
“gateway_conf”: {
/
gateway_ID is based on unique hardware ID, do not edit /
“gateway_ID”: “00800000A0000F09”,
/
Email of gateway operator, max 40 chars*/
“contact_email”: "adamdrenoyanis@hotmail.com",
/* Public description of this device, max 64 chars */
“description”: “”,
“gps”: false,
“fake_gps”: false,
“servers”: [
{
“serv_type”: “ttn”,
“server_address”: “thethings.meshed.com.au”,
“serv_gw_id”: “adams_test”,
“serv_gw_key”: “ttn-account-v2.VptlP3V3g6Hl34BtWefNLrMgUjI7QZHRf3JQGKjG9uNmSbEolVKusj3esjB8zcWGaEGUTPp80WBkdSKAzXKHwA”,
“serv_enabled”: true
}
]
}
}


(Jac Kersing) #33

@bearattack Sorry, looking at the output it seems you are trying to install the TTN released packet forwarder. I know nothing about that forwarder so I don’t have a clue what the issue might be or how to solve it.


(Gabo2048) #34

Hi kersing,
I want to know, how do i converter my conduit mlinux to aep?

Thanks.


(Jac Kersing) #35

@gabo2048
Sorry, that might render conduit unusable so it is not something I support.


(Bill Chen) #36

@kersing
Hi,
I’ve just started Multitech recently. Eeverything works the same as your procedure for configuring AEP model, but when it comes to TTN Configuration, it asks me to enter the password. I tried ‘admin’ but it shows ‘permission denied’. Is the password set by users or the default password isn’t ‘admin’? I didn’t change the password in AEP.

Thanks


(Jac Kersing) #37

Sorry I don’t understand where you are stuck. Could you post a screenshot?


(Bill Chen) #39

Sorry for the bothering, I entered the wrong prefix. It works now. I’m able to connect it to the TTN Gateway, but i’m not sure how to send up data to TTN server. I don’t see any optional nodes in Node-red.


(Jac Kersing) #40

The EAP Node-Red can not be used with TTN. If you want to use Node-Red you will need to install an instance on another computer. Then you can use the Node-Red connector for TTN.


LoRa connection is not responding after installing TTN Packet Forwarder
#41

@kersing is correct, no TTN node on EAP node red version, but you still have MQTT one node, and you can connect to TTN with native MQTT, decoding will just differs, but works, I’ve already done this on a EAP
But to be honest, I experienced some crash after 2/3 days of works (not stable and had only 4 LoRa nodes) and installed a node red instance on a local server.


(Fvera88) #42

Hi guys!
I´m trying to instal the installer.sh and when i run appear this error
Someone had this problem??
Could you hel pme??Captura