Connecting the Multi tech gateway to things networks


(antivirus123) #1

Hi to all, im a little new to LoRaWAN technology but have gathered some of the information up til now. I have a multi tech gateway MTCDT-H5-210A-AU with a lora chip in it MTAC-LORA-915 and couple of Mdot devices also MTUDK2-ST-MDOT(included 915MHz antenna). But i dont know from where to start actually and how to set up the gateway and connect it to the ttn server to make it running. Please advice me how to start and get things working.

Thanks,

Aamir Shabbir Hussain


(Jac Kersing) #2

To set up the gateway, use the instructions at new MultiTech Installer for TheThingsNetwork. This will setup the gateway to use wired network, use the instructions at step 5 of this page on the MultiTech site to setup the cellular link.


(Terrence Spencer) #3

He is using the Conduit AEP, not the Linux version.

It’s frustrating for us AEP (GUI mode) owners, as there is very little step by step help.


(Jac Kersing) #4

I’ll see what I can do to make conversion easier for AEP owners. Connecting the AEP to TTN would imply loosing AEP functions as having two backends (the EAP embedded one and TTN) control the radio is asking for trouble.


(Terrence Spencer) #5

So are you saying using the AEP model makes it difficult/impossible to connect to TTN?
I am new to LoRa, so I can’t read into the subtlety of some answers.
Thank you.


(Jac Kersing) #6

I wasn’t trying to be subtle.

I know it won’t be impossible because other people did it, I don’t think it will be difficult, but that opinion is based on documentation only, not practical experience trying to convert a gateway. If everything goes according to plan one of the forum users will help me convert a Linux conduit to AEP over the weekend so I can start working on some documentation or (hoping) adapt my installation script to work for AEP as well.


(Terrence Spencer) #7

Oh, I see, you are going to attempt to convert your Linux over to AEP. Got it.

Thank you for your help.


(antivirus123) #8

Hi Kersing thanks for your help i followed the same steps you mentioned here until the configuration of the installer.sh file but still we dont get the gateway on the TTN

And i am really confused about the instructions given on the TTN website to connect the gateway to TTN because i see that there are 3 links which give instructions on how to connect the gateway to the TTN

  1. https://thethingsnetwork.org/wiki/Installing-your-Multitech-mLinux-Conduit
  2. https://thethingsnetwork.org/labs/story/multitech-gateway/step/configuring-the-gateway
  3. IS the same which you have given in the forum but we also got some steps after this configuration of the installer.sh file which are as follows:
  1. Restart the installer to continue installation.
    sh installer.sh
    Once the installer finished (without errors) the Conduit is connected to TheThingsNetwork.

I dont know which link to follow and what should i do after setting up the installer.sh file.

Please reply soon how to solve this problem.


(antivirus123) #9

After the above step Once the installer finished (without errors) the Conduit is connected to TheThingsNetwork.

It says the following

Follow remaining instructions from http://staging.thethingsnetwork.org/wiki/Backend/Connect/Gateway
Test the gateway
How to determine if TTN can see the gateway?
From here? http://ttnstatus.org/


(Jac Kersing) #10

@aamir

The instructions at 1 and 2 are old and require manual steps which the installer automates. If you use the installer.sh you need to run it twice. The first run performs a network setup, the second run uses the configured network to get additional files required for the installation.

My instructions do NOT contain this. Once the installer is finished after the second run your conduit is connected, there is no need to perform additional steps. Please do not mix different sets of instructions.

To check if your gateway is connected, check the staging status page @ http://staging.thethingsnetwork.org/gatewaystatus/ your gateway should be listed on that page. (The EUI of your gateway can be found in /var/config/lora/local_conf.json on the conduit)


(antivirus123) #11

Hi Kersing,

I checked the /var/config/lora/local_conf.json but i could not find any thing named local_conf.json

Please let me know how to resolve the issue and the gateway is not on the list i checked it


(Jac Kersing) #12

Use

grep gateway /var/conf/lora/local_conf.json

and post (or use private message) the result. Also execute

grep server_address  /var/config/lora/global_cong.json

and include the result of that as well.

BTW, you do not have to post screen shots, just select the text in putty and paste it in your message. (Between [ code ] and [ /code ] (skip the space) to keep the formatting intact.)


(antivirus123) #13

I tried both commands it says

“No such file or directory” Please let me know what to do

The step no 3 which you have told by which we have to connect with the gateway the problem is if i use the ROOT username i dnt know the password i tried root but it doesnot work so i did everything by logging to the admin username is that ok


(Jac Kersing) #14

For AEP you need to use ‘admin’ so that is not a problem. Could you run the following commands (each line is a seperate command) and provide the output:

cat /var/config/.installer
ls -l /var/config/lora
cd
ls -l

(antivirus123) #16

The output of 1st command is:

secure
timezone
network
date
location
loraconf
disable-mtech
package

The output of 2nd coammnd is:

-rw-r–r-- 1 admin root 5871 Jun 22 06:00 global_conf.json
-rw-r–r-- 1 admin root 91 Jun 22 05:37 global_conf_src
-rw-r–r-- 1 admin root 704 Jun 22 06:00 local_conf.json
-rw-r–r-- 1 admin root 744 Jun 22 15:29 lora-network-server.conf
-rw-r–r-- 1 admin root 19456 Jun 22 06:00 lora-network-server.db
-rw-r–r-- 1 admin root 602 May 19 20:16 multitech_overrides.json
drwxr-xr-x 2 admin root 0 Jun 22 06:00 samples
-rw-r–r-- 1 admin root 4283 Jun 22 06:00 ttn_global_conf.json

The output of 4th is:

-rwxr-x— 1 admin root 21516 Jun 22 15:06 installer.sh


(antivirus123) #17

Hi Kersing,…My gateway id is “008000000000B667” and it is on the network but still i cannot see the latitude and longitude of the gateway there it says 0,0 fo rlatitude and longitude what could be the problem is there anything i have to do more?


(Jac Kersing) #18

Please run:

cat /var/config/lora/local_conf.json

#19

Hi Kersing,

I try run your installer with follow result:

sh installer.sh
installer.sh: line 9: $’\r’: command not found
installer.sh: line 14: $’\r’: command not found
installer.sh: line 28: syntax error near unexpected token $'{\r'' 'nstaller.sh: line 28:say() {

any suggestion?

Irek


(Jac Kersing) #20

@Irek
It looks like the installer script suffers from LF to CR/LF expansion. Please download it again and transfer it to the MultiTech in binary mode. Do not open in any windows tools.
Did you use the instructions for AEP Conduit or for mLinux? If not please use those.


#21

@Kersing
Thanks for response. I was trying the script for mLinux, but in the meantime I upgraded conduit to AEP version. Of course with downloaded binary your script works properly :slight_smile: Now I’m successfully connected to TNN.
Irek