Connecting TTIG to The Things Stack (TTN V3)

I’ve tried to read everything and do it.
i can’t do it.

  • ttig bought at rs
  • still fully active in v2 since 12/2019
  • data read out via serial port (signs correct for copypaste)
  • start claiming in according to instructions
  • error message “Gateway with EUI 58A0CBFFFExxxxxx already exists and is not authorized for claiming”
  • cli learned, over “”, login ok, command …claim authorize, error
    “ttn-lw-cli gateways claim authorize 58a0cbfffexxxxxx
    INFO No API Key provided. Creating one
    WARN Finished unary call {“duration”: 0.0603, “error”: “error:pkg/auth/rights:no_gateway_rights (no rights for gateway 58a0cbfffexxxxxx@ttn)”, “error_correlation_id”: “db2eb2a83ba64aae92394bb898b14e53”, “error_name”: “no_gateway_rights”, “error_namespace”: “pkg/auth/rights”, “grpc.method”: “CreateAPIKey”, “grpc.service”: “ttn.lorawan.v3.GatewayAccess”, “grpc_code”: “PermissionDenied”, “namespace”: “grpc”, “request_id”: “991c0285-654c-476d-8621-fc8cfc57c9b5”, “uid”: “58a0cbfffexxxxxx@ttn”}
    error:pkg/auth/rights:no_gateway_rights (no rights for gateway 58a0cbfffexxxxxx@ttn)

every commands ends with Permission denid
what can i do?

help me please… thx a lot

Have you previously tried to register it in V3 - using Add Gateway, before trying Claim process? Could a colleague or collaborator have done so or tried?

thx for fast answer!
no, should I have done that?
I understood it to mean that a claim should definitely be accepted.

Should I add one first?

The information at The Things Indoor Gateway | The Things Stack for LoRaWAN is up-to-date. Don’t add a gateway, just claim it.

that’s how I understood and tried it
so sorry…
unfortunately it doesn’t work for me

Okay, so it sounds like someone else already claimed this gateway. Since you already have the CLI set up, you can look up the gateway registration with the following command (replace the EUI with the actual one):

$ ttn-lw-cli gateways search --eui-contains 58A0CBFFFExxxxxx
// output:
  "ids": {
    "gateway_id": "some-gateway-id",
    "eui": "58A0CBFFFExxxxxx"
  // ...

You can then run the following command to find out who registered this gateway (replace the ID with the gateway_id in the output of the previous command):

$ ttn-lw-cli gateways collaborators list some-gateway-id
// output:
  "ids": {
    "user_ids": {
      "user_id": "some-user-id"
  // ...

Now that you know who claimed the gateway, you should be able to reach out to them (they should typically have the same username here on the forum) and ask them to delete the gateway if it’s not theirs.

Does this mean there are TTIGs with the same WiFi password out in the world? Is that by batch?

??? Where does this come from???

I’ve got multiple devices, some from the same batch and some from other batches and all have (seemingly) random passwords. I didn’t notice any duplicates. However the password is just a few characters so some overlap may occur at some point…

If someone has claimed @dvbahder’s gateway, that means they have a TTIG with an EUI sufficiently similar with either an identical or sufficiently similar WiFi password that they managed by some statistical miracle to claim the TTIG.

I’m trying to eliminate the the first possibility for the WiFi password - if they are all random, it would be interesting to compute the probability of someone managing to claim someone else’s TTIG by misreading or mistyping (or both) the EUI & the password.

May-be someone ADDed a wrong gateway? Or a coworker (bought at RS usually implies not a consumer acquired device) already claimed it?
Two possible explanations I think more plausible.

A restocked/returned item? Perhaps registered by previous owner. A couple of years back in early days of RS shipping I had a mis-ship/mis-pack where they sent a 915Mhz device - in 868Mhz box! That had to be returned - so not unknown… and yes I had to register it before I realised it wasnt operating as expected…

1 Like

i’m back

I bought the device as new (, I unpacked it, registered with ttn (my first account with ttn) and it worked straight away since 11-2019 to this day and is still working
in the v2 i can see it and it has no other owners, no collaboraters

I tried the instructions from htdvisser
in cli answer is


i have in another account (school in Dresden, since 2020) a mikrotik, is working fine in v3,
with the same commands, i’ve correct answers
the comands are working in my account…

is there anything else i can try?

thx for help!

We run the risk of splitting hairs here, but Hylke said claimed …

We run the risk of splitting hairs here, but Hylke said claimed …

That’s probably a mistake. I don’t think that passwords can be repeated since they are generated based on a gateway specific hardware secret.

I think someone else “registered” this EUI. @htdvisser’s recommended steps to resolve this issue are still valid.

Sorry for the confusion. I meant “claimed the EUI” – either by registering a gateway with that EUI (ignoring all the warnings), or by claiming a gateway and then returning it to RS like @Jeff-UK described above.

Since the CLI says that this gateway has no collaborators, it’s possible that someone did register it, and then (instead of deleting it) revoked their own rights on the gateway. @dvbahder could you please share the full EUI of your gateway, then we try to find out what’s going on here.

Gateway ID

Gateway with EUI 58A0CBFFFE800FB0 already exists and is not authorized for claiming
on cli my rigths only for own v3 gateways, could`nt find any gateways#

I should just wait until v2 ends and then register my ttig new in v3 with a new ID

Status in v2 (is working)
Gateway ID eui-58a0cbfffe800fb0
Description TTN Gateway Indoor DvB
Owner dvbahder
Status connected (v2)
Frequency Plan Europe868MHz
Router ttn-router-eu

there is another idea? thx

ID yes, but it’s the EUI that’s already registered so it will be blocked until someone finds out who has used that EUI already.

but doesn’t it say in v2 that i am the owner?

You never actually own an EUI, you merely look after it for the network.

In short, no, an entry in v2 doesn’t verify the ownership of a gateway as anyone can enter any EUI they like. And it has been clearly stated by TTI that they aren’t going there - search the forum for such discussions from around mid-June when migrations started.

You need to petition TTI to help you with this - only TTI staff have access to TTI systems so only they can help you further - maybe @KrishnaIyerEaswaran2 can help.