Couple of questions after setting up my gateway

Hey guys,

I set up my Pi + RAK831 Gateway last night and it seems to be running fine. I just wanted to check if I’ve done everything correctly. I’m in Australia and I pretty much followed this guide here:

https://www.thethingsnetwork.org/labs/story/rak831-lora-gateway-from-package-to-online

But I deleted the global-conf file after setting it all up and overwriting it with AU-global_conf.json from TheThingsNetwork GitHub and I changed the reset pin to #17. Is this correct for Australia?

I originally couldn’t connect my AU915 MKR WAN 1300 Arduino at all but after changing the global-conf file to the Australian one and did a reboot it all started working. :slight_smile:

Also the only other question I had is within that tutorial, you enter the lat/lon, altitude and the Descriptive Name. I can also edit this in TTN. If I want to change it, can I just edit these values within TTN gateway settings (website) or do I need to also re-run install.sh?

Thanks!

Aaron (?),

Seems you are much at the same stage I am, also in Australia too. I have built my RAK831 from a combination of https://www.iot-store.com.au/products/rak7243-cellular-lorawan-gateway-raspberry-pi and information from YouTube (mobilefish.com tutorials) and RAK documentation & supplied images etc.

The only question of yours I can assist at all with I think is the GPS - I have found that providing my GPS module has signal, the GPS coordinates captured by it, and output in the syslog, do transfer through to the TTN console and have overwritten previous vague values I entered there.

For my part, my gateway is showing as connected and seemingly communicating with TTN but no evidence my devices are communicating with TTN, so trying to debug that.

Regards,
Roger.

I’m not sure if the OP has a GPS-enabled gateway too? If not, then it should not send coordinates from some configuration file (nor send any time), but instead use TTN Console; see Gateway GPS configuration in local_conf.json.

1 Like

Thanks

Yep mine is GPS enabled. I’ll try enable it and see if it becomes more accurate.

But I did want to alter the description. Not sure if I can just do that in TTN Console or if I need to re-run the script on the Pi where I also set it on that to begin with.

rogerg are your nodes connecting to the gateway? Just no communication between the node + TTN?

I’m not sure if my devices are connecting to the gateway. My gateway is visible in TTN but no devices are showing as connected. Not sure if that’s a TTN configuration issue or Gateway to device configuration issue at this stage :thinking:

Devices never connect to a gateway, they connect to the network.

What frequency is your gateway and what frequency are your nodes? Did you check the traffic tab of the gateway (keep it open as only packets received while the page is open are displayed)?