Create a mapping node with t-beam step by step

There are regulations in germany…(we have the power of german engineering and regulations):grinning: but they say 25mW or 2W and so on and other modulations.

They say if its not specified its 1%. So with 6 sec intervall and 60ms airtime its 1% (shorter then 8sec is not working with my setup, even 3sec gives ca. 8sec Intervall, dont know why).

Tried again to install the softRF-mapper without any success.
Arduino reinstall, remove the library and install the package new gives still the same error.
So I will complete the deuxvix mapper installation readme in this thread in the next days with my approach…

So here is my approach to get a t-beam running with the DeuxVis sketch.
I completed the description from DeuxVis, that gives me problems when I tried to do it.

  1. Read the readme for this sketch first.
    1.1 If not done yet, install the drivers to connect your PC with the t-beam
    1.2 Create a mapping node in TTN to get the important device address and keys.

  2. Install Arduino Software
    2.1 I choosed to install it on c-drive, not another partition. The windows-folder with the libraries will be at your personal documents-folder.
    2.2 Download the software mentioned
    Arduino IDE [ESP32 extension]
    To download, you have to click the green clone/download button and choose zip-file.
    Don´t extract the zip-file.
    2.3 Download the file from Lora-TTNMapper-T-Beam and unzip the files.
    The 4 most important files are Lora-TTNMapper-T-Beam.ino, config.h, gps.cpp and gps.h
    2.4 Put the 4 files in the same folder.

  3. Start Arduino Software
    3.1 Install the zip-files (Arduino IDE, TinyGPS++, LMIC-Arduino by clicking the menu: sketch/include library and choose zip-library
    Here you have to choose the three zip-files downloaded before.
    3.2 After the 3 zips are included, close the Arduino program.
    3.3 Go to the new folder and double click the file Lora-TTNMapper-T-Beam.ino
    3.4 The windows should now include 4 tabs, one for each file.
    3.5 After that go to menu and click tools/board and choose “heltec wifi lora32”
    3.6 Connect the t-beam to the PC, power it on (the newest t-beam is automatically on) and check the serial-port in the Arduino-Software under Menu/tools/port if its correct.
    3.7 Before upload you have to edit the config.h tab with your own device address and keys in the arduino Program that you generate in TTN - see step 1.2
    Go to the Device Overview in the TTN-page of the mapping node.
    Copy the network session key and application session key in hex-data by clicking the <> sign and click the clipboard sign and replace the data with brackets { 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 }
    The last line to change is: static const u4_t DEVADDR = 0x00000000
    You needs to replace the device address in “natural numbers” - not in hex-code! Keep the 0x and replace only the 00000000 with your device address (DevAddr)
    3.8 To check if everything works fine but without upload, click the “ok”-sign on the upper left in the Arduino-Program.
    After that, the Program should compile the data and when it finished without any error-messages you can try to upload it to the t-beam.
    3.9 Upload the data to t-beam by clicking the right arrow >
    The Program should compile the data and after that it should upload the data to the t-beam device.
    3.10 After upload process is finish (Leaving…Hard resetting via RTS pin…) separate the usb-cable and start t-beam

You should now have a mapping t-beam, it starts transmitting, when it has a gps-fix.


This is another mapping sketch that I got to work with my V0.7 t-beam.
It has OLED support with nice grafics and a lot of info on the screen - awsome.

But the following instruction is currently missing to get is running:
You have to install this library first

They say for V10 t-beam you have to modify something - I dont know what and how and didn´t test it with t-beam V10

Hello. I did all stapes but in Serial Monitor i can read the follow text " No gps Fix ".
Do you have any idea what am i doing wrong ?

Great resource by @LoRaTracker, as mentioned elsewhere when looking for this problem on the forum:

Unfortunately it didn’t work out. I wonder if the the Activation Method ABP is the write choice

An error like “No gps Fix” has nothing to do with LoRaWAN, hence is not related to, e.g., the LoRaWAN activation method.

Ohh i see. As intigretion i am using TTN Mapper and the status is Running. But still can’t receive data from TTGo T-Beam

Without GPS fix, how should the tbeam transmitting the position?

  1. Make sure you get GPS signal.
    1.a. if you don’t get GPS reception outside, check if the GPS antenna is connected and in good position
    1.b. if you did everything to get GPS fix and still no reception, contact your dealer, your device is defect.
  2. After GPS fix it could take 1minute till the node transmitts the first position.
  3. If no receiver is in range, you have another problem.
  4. The protocol is according the description in GitHub.
1 Like

GPS still dont work. The thing is the simble Blink sketch did work too. The pins with 3.3 V are actually 1.8 V.

The GPS is independent to the sketch afaik.
So if the GPS thing is not working you can use it for stuff without GPS function or put it in the bin and call your dealer.
I had one without GPS working and kept it as hardware backup.

Hello gang
After from a long search on TTGO T-Beam i am facing some news and some old problems.
Ηow can i activate gps? Some users says i have to use a library in order to activate the GPS module. The thing here is i cant find nothing on this.I can upload programs on my device and working great. Only GPS make my life nightmare.Can anyone help me on this ?
Thanks for your time.

Again, if the red led of the GPS don’t blink, it’s defect. The GPS module works when its powered. Maybe you don’t believe me, so keep on wasting time searching for a solution…good luck.
And this thread is not about fixing a t-beam. It’s about creating a mapping node.

1 Like

Thanks a lot.

Tested with T-Beam v1.0 - works fine as well.

Which sketch did you use?

For v1.0 use this sketch, the relevant libraries and dependencies. Be aware to press the PWR BTN when the IDE wants to start the download to the board (115kBd).

Hi, i have an TTGO T-Beam with the hottimuc firmware. But i don´t know how does it works. After the GPS Fix i get two messages, all 30 seconds “Packet queued” and “EV_TXCOMPLETE”.
If i drive around with my car, i get the two messages all time every 30 seconds. Is this OK? I think i should get some error if there is no gateway in the range?


There is no general acknowledgement, sent back to a node, that a packet sent has been received by a gateway.