Data/Event Stream not working


The Data and Events boxes are not working.
There is only an error message:

Cannot show events
An unknown error occurred. Please try again later.
refreshRestart Stream

Steps to Reproduce

v3.7.1 clean install with docker-compose on debian 10.3

What do you see now?

Cannot show events
An unknown error occurred. Please try again later.
refreshRestart Stream

What do you want to see instead?

the latest events and data from the device, for the application or from the gateway


docker-compose with v3.7.1
debian 10.3

Have you tried a different browser? I find this happens often with some browser when I try another everythings is displayed correctly.

tried it with chrome and firefox no luck

when i open the data tab for a node i can see this in docker-compose logs:

stack_1      |   INFO Request handled                          duration=631.934µs method=GET namespace=web remote_addr= request_id=01E7JDDB7S0AREFVVTFP7WCFMP response_size=2167 status=200 url=/console/applications/modularnode/data
stack_1      |   INFO Request handled                          duration=206.993815ms method=POST namespace=web remote_addr= request_id=01E7JDDBSEM7T32142GKB7DWN7 response_size=275 status=200 url=/oauth/token
stack_1      |   INFO Request handled                          duration=315.321353ms method=GET namespace=web remote_addr= request_id=01E7JDDBP4BJ9DZGNVSV7NDH8C response_size=160 status=200 url=/console/api/auth/token
stack_1      |   INFO Finished unary call                      duration=55.79388ms grpc_method=AuthInfo grpc_service=ttn.lorawan.v3.EntityAccess namespace=grpc request_id=01E7JDDC0V699MQ9QV2RRE0GWD
stack_1      |   INFO Finished unary call                      duration=60.001764ms grpc_method=Get grpc_service=ttn.lorawan.v3.UserRegistry namespace=grpc request_id=01E7JDDC356GN209XE7E5PRVD3
stack_1      |   INFO Finished unary call                      duration=99.865752ms grpc_method=ListRights grpc_service=ttn.lorawan.v3.ApplicationAccess namespace=grpc request_id=01E7JDDC6198EBS3R53DD2V0W6
stack_1      |   INFO Finished unary call                      duration=101.440169ms grpc_method=Get grpc_service=ttn.lorawan.v3.ApplicationRegistry namespace=grpc request_id=01E7JDDC6095N1ZD9PHHVDNWZ2
stack_1      |   INFO Finished streaming call                  duration=1m0.059025624s error=context canceled grpc_method=Stream grpc_service=ttn.lorawan.v3.Events namespace=grpc request_id=01E7JDDC9JV3RYRCEZEKVR2G1C

after the “INFO Finished streaming call” i get this message in the browser:

Cannot show events
An unknown error occurred. Please try again later.
refresh Restart Stream 

pressing Restart Stream does nothing

ok now i have all ssl/tls on nginx and it works
wrote down what i have done.

This topic was automatically closed after 30 days. New replies are no longer allowed.