Data not displayed in end node life window

I am new in this LoRa world, but I want to setup an example from ST.
It is based on stm32wl-nucleo64-board for end device and “STMicroelectronics NUCLEO-F746ZG Nucleo board and RisingHF LRWAN_GS_HF1 expansion board with antenna” for gateway.
Examples are from the following pages (from ST site):

Now: I set all things, based on the youtube video material (, this is first from a series of 6 videos) and all was good; until this Friday, since I haven’t received data in the application console.
The situation persisted all day on Saturday and Sunday. During this time, I set the gateway and the end-device again, several times, all without success.
My question is the following: is there any problem with sending data from the Gateway to the End-device (any internal problem of the TTN server)? Is there a problem with the free account?
I use this server to send data from gateway to TTN:
I need an answer because I dont understand why, if the gateway receive some data from my end-device, and all is set as in the manufacturez example, few days ago works and now not working…

Thank you for support,

The network is up and running

1.What do you see in the console of the gateway and the application?
2. If your node is trying to connect, you will see activity in the gateway console.
3. Are your gateway connected to the network? (If you got it connected once it’s bad practice to delete and recreate it)
4. Sorry, most important newbie question, how far apparat are your node and gateway?

Please answer all 4 question.


  1. Pictures from gateway and application live data:

  2. I flashed the end-defive several time and this is the serial console:
    L2_SPEC_VERSION: V1.0.4
    RP_SPEC_VERSION: V2-1.0.1
AppKey: 2B:7E:15:16:28:AE:D2:A6:AB:F7:15:88:09:CF:4F:3C
NwkKey: 2B:7E:15:16:28:AE:D2:A6:AB:F7:15:88:09:CF:4F:3C
AppSKey: 31:94:AD:FD:43:9B:D0:94:E3:07:51:68:7C:A9:7C:C9
NwkSKey: E7:36:7C:B1:25:76:B5:88:72:21:4A:90:D1:E6:B6:51
DevEUI: 00:80:E1:15:00:0A:96:1D
AppEUI: 01:01:01:01:01:01:01:01
DevAddr: 00:0A:96:1D

10s035:VDDA: 254
10s035:temp: 12
10s041:TX on freq 867100000 Hz at DR 5
10s111:MAC txDone
15s091:RX_1 on freq 867100000 Hz at DR 5
15s138:MAC rxTimeOut
16s097:RX_2 on freq 869525000 Hz at DR 3
16s157:MAC rxTimeOut

========== MCPS-Confirm =============

20s044:VDDA: 254
20s044:temp: 12
20s048:TX on freq 868300000 Hz at DR 5
20s118:MAC txDone
25s098:RX_1 on freq 868300000 Hz at DR 5
25s145:MAC rxTimeOut
26s104:RX_2 on freq 869525000 Hz at DR 3
26s164:MAC rxTimeOut

========== MCPS-Confirm =============
  1. the gateway is connected to network, see picture from pct. 1;
  2. I tested with a distance between end device and gateway from 1 meter to 5-6 meters, with the same result.

Are you sure you key are in the correct order (msb or lsb) in you sketch?

I used the example from ST. I did not change anything else than in the video tutorial. Moreover, with the settings from video tutorial, everything worked from the first try until this Friday.
Then, I re-flashed everything, I re-set everything as in the tutorial without success…
Maybe the end-device is broken…
I used only STM32Cube IDE for flashing.
The distance between end-device and gateway is the same as the first try…

If the key are the same as in the example you have a problem, only one device on the network can exist with set keys.

The key need to be that same as the node you have registered in the application, and the application will not allow double registration of keys.

You need to update your sketch to represent the key in the application.

You might have gotten away with it in the past, but this is a big problem for most devices, please search the forum.

LoRaWAN (Long Distance Radio Access Wide Area Network ) not the same as WiFi or BLE

I will change the keys in the code, I will flash again the end-node, I will update the new info in the application on TTN.

i changed the keys in the code, I re-register the end node, but the issue is still present: the gateway received data but in application live data, the data are not present.
Any other ideas?

Thank you, Mihai

The fact that you set a DevAddr (and an ‘experimental node’ one at that) suggests using ABP - is that how you have configured as part of your device registration? Have you tried running as OTA?

If ABP have you reset fcount in console? Cleared/Reset DevNonce for re-use? (Joining via OTA should take care of all for you…)

I solved the issue.
Somehow, the end-device, stm32wl-nucleo64-board, even was flashed everytime from STM32CUBE IDE, can not re-join to the network.
My solutios for this issue is: erase the chip using standalone STM32CubeProgrammer and then flash the chip (again) using STM32CUBE IDE. After that, the end device join to the network and the data are displayed in the end device live data window.

Now, the whole system is working as new!.

Thank you verry much for your support,


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.