Device location cached, does not update

I have prepared a gateway for a customer, running it for tests in our office location for a short while. A few weeks ago the gateway was shipped to the customers location (in another country even), but all the devices that use this gateway still get our office location as geolocation in the JSON message. The gateway is registered at the proper location in TTN, and the gateway location also shows up correctly in the JSON message, but the devices location in the JSON message seems to be cached somewhere and remains static at the wrong location (being our office location).
Does anyone know how we can ‘reset’ the devices location? Is this device location caching happening somewhere in Collos? Does this have anything to do with recent changes in the geolocation services landscape within TTN?
PS: I should add that we also delivered these devices to the customer, so at some point these devices have in fact communicated with this gateway at our office address, but both devices and gateway are now in this other country

So you’re not referring to the location as part of a gateway in the gateways list?

If you are: any chance the location_source is not "registry"? And any chance the gateway (which brand/type?) is configured using some file that might set a location as well?

@arjanvanb thanks for your reply. I am not referring to the location in the gateways list, as that is correct. I am referring to the location of the device which is of the type “location_source”: “registry”.
I never set the location of the device when creating a new key, but they always register at our office address automatically, because of the gateway here. What I experienced before is that if we send sensors to customers abroad, the location of the sensor in the console quickly ‘flips’ to a foreign gateway. In this case it doesn’t, at least not as swift as I would expect.
I looked up some more sensors we sent there and to my surprise I found a few that were in fact showing the proper location and some were still at the old location, although being in service for about a week and sending hundreds of messages.
The gateway is a Kerlink. I never programmed any location in it since I didn’t know where the customer was going to install it, and it has GPS anyway. Since some sensors did in fact change location properly, it doesn’t seem to be a gateway problem.
I guess we’ll just wait a while longer to see if the problem persists or get solved ‘magically’ :wink:

Hi, My gateway is sending the location information from its GPS receiver, but still i don’t see the location information in the console. following is the json object. Any idea why its not getting updated

“antenna_locations”: [
“latitude”: 12.85761,
“longitude”: 77.65171,
“source”: “SOURCE_GPS”

Pretty much none of the gateway implementations pass on the location. I believe BasicStation can / does.

It’s mostly legacy BS based on the idea that nano-second accuracy is a thing for sensor data. The GPS is a sexy add-on for the gateway that is a ooo-shiny of no particular value unless the internet connection bizarrely doesn’t provide NTP, then it may, if configured to do so, provide an accurate clock source.

Pretty much all of the gateway implantations are able to pass on GPS location data and will do so if a GPS is connected and configured.

It is mostly because class B required GPS for precise timing. I think with BasicStation NTP synced clocks are considered suitable as well but for the Semtech protocol based packet forwarders GPS is required for class B.

I think we both agree here - I’m saying most don’t because all too often they aren’t configured but this is based on observations of Pi serial port issues :roll_eyes:

Which leads to my suspicion that it’s BS because the vendors don’t seem to make the GPS they ship on the gateway actually work out the box.