Disable ttn packet forwarder on boot


(Ad0rs) #1

Hi
I have the IP67 conduit from Multitech
I installed the ttn packet forwarder using the tutorial from TTN
Now, I want to disable and use the forwarder of the gateway itself
I know how to stop it every time but when I restart the conduit it works by default

Can you tell me how to do it please?
my firmware is 1.4.4


(Paul Stewart) #2

I think you could just reinstall the Multitech firmware, bit drastic but it should work


(Ad0rs) #3

Thank you for your response
Can you tell me how to do it, please?


(Paul Stewart) #4

I’m no expert, but head here to grab your appropriate firmware http://www.multitech.net/developer/downloads/

Then once you have the bin file - log onto the Multitech, and under the administration menu item, there is firmware upgrade.

Just install the same version over the top.

Then I think you will have to jump into global_conf.json and modify it to connect to TTN servers.

I’m sure there are other examples in the fourm on how to do that.

cheers
Paul


(Ad0rs) #5

Hi
Thank you for that
Will try it
I don’t want to connect to TTN anymore since I found a way to connect my conduit directly to my application server


(Ad0rs) #6

I wanted to re-write the firmware
However, my firmware is 1.4.4 which is not found in the Multitech download page
The latest firmware there is 1.4.3
I think there’s a way to stop the ttn forwarder as a default, or delete it
I just don’t know the right commands to do so
@kersing , could you please help in this?
I am beginner in Linux commands


(Jac Kersing) #7

I’ll try. I’m unable to test so this might not work.

I’m providing software for people to join TTN to increase network coverage, not help them leave TTN and decrease coverage. I think TTN and its community provide added value beyond what the AEP is able to provide, so why do you not want to contibute?

Cut-and-past the following commands to the Conduit command line:

update-rc.d -f ttn-pkt-forwarder remove
update-rc.d lora-packet-forwarder defaults 95 30

cat << _EOF_ > /etc/default/lora-packet-forwarder
# set to "yes" or "no" to control starting on boot
ENABLED="yes"
_EOF_

Reboot after these changes and hopefully you are set.


(Ad0rs) #8

Hi

Thank you for your help @kersing
I did the same but replaced “lora-packet-forwarder” with “lora-network-server” in second and third lines
and it worked

as for the other matter:
I sincerely thank all who added value to the community
I myself am new to lora and the TTN community helped me a lot
The reason I can’t use TTN:
I am using it and sending data of 100+ bytes per packets per nodes each 1-3 minutes
the TTN fair policy doesn’t help in this
and I might later even abuse the duty cycle for certain tests (inside a lab in a building so it won’t be a problem)
I hope a can add more to the community later in other projects


(Osman) #9

Hi,

Which network/application server you are using now? Could you kindly share your experience.


(Ad0rs) #10

Hi @Osman
Sorry for the late reply
I am using Multitech as a network server (Multitech gateway can be a network server itself)
And AWS cloud for application server