Do I need to migrate my Gateway now?


My The Things Gateway is more and more often not functional, I do not know on what it is depending. The 3rd LED just blinks for hours, and later it works for some hours until it stops again working.

So I was wondering if I need to migrate it now to V3? Right now it is working (3rd LED is on and not blinking), so I tried to login to the console to see the status there. But obviously the V2 console is gone, it redirects to the V3 console, and in the V3 console my Gateway is not shown.

I expect as the V2 console is no longer active, I should have already migrated my Gateway to V3, right?What do I need to do to get the Gateway working reliable again (and see it in console). I did not find a manual or document I could follow to troubleshoot/migrate my Gateway.

Help is much appreciated!

The TTKG configuration guide is here: The Things Kickstarter Gateway | The Things Stack for LoRaWAN

Some details that got me stuck at first:

  • Do not add “@ttn” to your gateway-id in the TTKG configuration
  • Use a wired connection to configure the TTKG. While configuring the new details in the TTKG, do not setup a WiFi configuration at the same time. For me, if I tried to do this at the same time, the gateway card would show up as “ND” (not detected). So, set up the v3 connection to the server first, then configure WiFi later.

Thanks for sharing this link! I was able to follow the instructions. At least all 4 LEDs are now on, and my sensor is able to provide data (there is no other gateway in reach for it) but the strange thing is in V3 console I still see the gateway as “Disconnected”, and no live data. Any clue why this is the case?

Do you see the data in your application?

Yes I do, but I noticed even after resetting, and reconfiguring the gateway with the API Key from the V3 console, my application still sends over v2!?! I did reuse the same gateway id as in V2 should I change it to a new gateway ID?

"rx_metadata": [
          "gateway_ids": {
            "gateway_id": "packetbroker"
          "packet_broker": {
            "message_id": "01G9TE2NBDXXXXXXXXXXXXXXXX",
            "forwarder_net_id": "000013",
            "forwarder_tenant_id": "ttnv2",
            "forwarder_cluster_id": "ttn-v2-legacy-eu",
            "forwarder_gateway_id": "XYZXYZXYZXYZ",
            "home_network_net_id": "000013",
            "home_network_tenant_id": "ttn",
            "home_network_cluster_id": ""
          "time": "2022-08-06T20:38:21Z",
          "rssi": -36,
          "channel_rssi": -36,

Anyhow I do not understand how the Gateway can still use v2 after I configured everything from v3 console.