Dragino LHT65, connect to the "thethingsnetwork", help!

I am newbie with the Lorawan technology. I bought a dragino LHT 65. I follow the steps to join lorawan network with the user manual:

but blocked at the “Step 2”, the device LHT65 do not join automatically the TTN network. I try to connect the device (hold Act button for more then 3 sec) the led flashes several times green , then red with 15 sec repeating time. And after 10 minutes or so no flashing led anymore. I never see a blue flashing led.
here is the setting in the thethingsnetwork:

what is the problem ?
the device Dragino lht65 do not connect to a gateway ? Dragino LHT65 need a gateway to connect? Personnally I do not buy a gateway.
there is no ‘free’ gateway ? the device is set up in Paris.

Please help!
Thank you

Dear John,

Yes, the LHT65 (as well as any other LoRaWAN sensor) needs to be inside the coverage area of at least one The Things Network gateway.

You can check the coverage in your area using https://ttnmapper.org/

Kind regards

Or indeed here https://www.thethingsnetwork.org/map


i checked the coverage,and i see that a gateway is nearby. dragino location 1

normally I could connect, couldn’t I ?

thank you
Best regards


with https://www.thethingsnetwork.org/map dragino location

thank you
Best regards

I think for serious development on LoRaWAN you need your own gateway for testing.
Indoor gateways are not really expensive anymore, like the The-Things-Indoor-Gateway or the Dragino LPS8.

That way you can know for sure if your message is arriving at the gateway and forwarded to TTN.
Having your own gateway allows you to view LoRaWAN traffic on the TTN console. You cannot see the exact contents (it’s encrypted) but at least you can see if OTAA join requests are coming in. You can see if your didn’t accidentally swap APP EUI, DEV EUI, put the bytes in the wrong order, etc.
So you can start from a “known good” situation, then bring it outside to see if it works for real.

If you use someone else’s gateway, you never really know for sure. The gateway might be an indoor model with poor coverage outside, poor/intermittent network connection, etc.

You could try to contact the owner of the closest gateway and ask for console access.
The contact page for the owner is http://www.thethingsnetwork.org/u/bertrik (for example)
(replace bertrik with the name of the gateway owner)

1 Like

Hello Bertrik,

as I understand, I should buy a Gateway. waiting the goods, I cannot test Dragino LHT65?
the product Dragino LHT was sold as product working without a ‘specific’ gateway. does the product not connect to a One Things Network gateway ?

thank you
Best regards

Yes it will connect to The Things Network - devices connect to the network when a gateway receives an appropriate signal, devices don’t connect to a gateway as such.

But we have no way of debugging your configuration because without a gateway that you can see the console of, we would only be guessing as to what the problem is.

It would appear from reading the documentation that you haven’t set up the correct App EUI, so that’s something to look at.

1 Like

Hello Descartes,

I verify twice that the settings App EUI, DEV EUI, APP KEY are the same than the provided Label in the packaging. So I think the problem does not come from settings information.
I think, the problem comes from the product Dragino LHT65 did not success to connect with a One Things Network gateway because the Blue LED of the product never flashes.
But according to https://www.thethingsnetwork.org/map, there is a Gateway, maybe not free ?
So, i do not understand the issue.
thank you
Best regards

PS: Why I could not connect the product with One Thing Network?

Your screen shot shows otherwise.

Gateways can handle 1,000’s of devices.

PS, We are THE Things Network. Not One Thing Network.

Strange, I’ve got four LHT65 devices and for all of them the AppEUI starts with A8 40 41 which is registered to Dragino,

Of course we all know @kersing meant the Dev EUI.

The instructions say the App EUI should start 3F 77 AD. Your screen shots says you have 21 B6 3B

No, I meant AppEUI. Dragino assigns both AppEUI and DevEUI from their own range.

Curious, the instructions show Dev EUI starting A8 40 41 and App EUI starting 3F 77 AD


here is the photo of the label IMG_20201109_174419

1 Like

I just checked one of mine close by and my Dev EUI is also A8 40 41…

In another of the reuse of App EUI cases (I suspect) looks like mine starts A0 00 00…

To get it up and running (IIRC) I just used the ‘Manage EUI’s’ setting in App console to add the A0 00 00 … as alternate to system generated App EUI and it worked just fine. But then I think I’m running an earlier firmware version (1.4.x/1.5.x?) ?) - would need to go check. OP may find differing firmware versions may well behave differently that the instructions for the v1.7.3 build, but unlikely…for a time there were many older versions out in disty stock…

@descartes the use of 3F 77 AD… just reflected the specific device used for creating the docs - just looked back at rev 1.3 doc/instructions and it was the same there (that section of text/images just looks to be cut & paste).

How can you tell? OP would need to post lable picture I think… :wink:

Difficult to tell likely local RF environment however I would note this is quite dense urban and map doesnt make distance clear but must be 400m-1km to (supposed - may not be actual) location of GW, with high rise blocks, multi-story car parks, self storage units, housing, office, supermarket and other building clutter in the way!

@John_Lion, if it were me I would take node from the approx Boulevard de Picpus & Campus Picpus area back down the Rue de Toul to close by the GW location and reset device, power up & check there (Having checked lable details for 3rd time ofcourse! :wink: ) If still no success take it close to one of the other GW’s in your region as GW may been relocated without being updated on the map! …oh, and buy a GW to improve testing & add to your local community :+1:

It may also be that the local topography is working against you if the GW is set at a low level…would need to know acurate node location to check if you have effective line of sight:


My message took a while to compile and crossed so thanks for posting - that helps check :slight_smile:

And you have gone back having created the Device registration and added the App EUI to the App?

Hello Jeff,

thank you.
I will check one more time.
Maybe I should buy a gateway and try again.

thank you
Best regards