Dragino LoRa IOT Kit Help

Hi there!

I am starting to learn about LoRaWAN and fortunately I found a dragino LoRa IOT kit laying around. The gateway that I have in this kit is the LG01-P Gateway.

Unfortunately, I have problems while trying to follow the user guide from the wiki page. It seems that I can’t upload the test programs via arduino to the LG01-P Gateway.

what have I done:

  1. I am able to set up the wifi client for my gateway via the web GUI

  2. I also managed to connect the gateway via SSH to perform a factory reset

  3. I am trying to upload the test example to the gateway, but it is stucked as I can’t seem to enter the right password via arduino. I tried to put in ‘dragino’ but with no luck. The verbose message that I got from the IDE was this:

    processing.app.debug.RunnerException
    at cc.arduino.packages.uploaders.SSHUploader.uploadUsingPreferences(SSHUploader.java:150)
    at cc.arduino.UploaderUtils.upload(UploaderUtils.java:77)
    at processing.app.SketchController.upload(SketchController.java:732)
    at processing.app.SketchController.exportApplet(SketchController.java:703)
    at processing.app.Editor$UploadHandler.run(Editor.java:2075)
    at java.lang.Thread.run(Thread.java:748)
    Caused by: com.jcraft.jsch.JSchException: java.net.ConnectException: Connection timed out: connect
    at com.jcraft.jsch.Util.createSocket(Util.java:389)
    at com.jcraft.jsch.Session.connect(Session.java:215)
    at cc.arduino.packages.uploaders.SSHUploader.uploadUsingPreferences(SSHUploader.java:122)
    … 5 more

and the display that I was stuck with was this:

delsoon

Any ideas how can deal with this rather simple problem I suppose, but I have been stuck with this for a few days now. I tried to contact them asking for help but because of the time difference it is just hard to communicate effectively.

Thank you in advance for your kind help!

regards

1 Like

you bought a lora kit , and this is the support forum for the things network (lorawan)