DRAGINO problems and solutions topic part 1

I’m trying to set up a Dragino LG01-S LoRa Gateway but have run into a problem.

It’s working fine but I would like to run a VPN client on the Dragino and create a connection back to my own VPN server.

I’m halfway there and can get the Dragino to connect to my VPN but it becomes inaccessible once connected and only stays connected for around 60 seconds. It does not respond to pings from the VPN server.

I guess that I am missing a firewall rule somewhere but, as I can’t connect to the Dragino once it is connected to the VPN, I can’t work out where/what the rule needs to be!

My VPN config creates an interface called tun0 so I have created a new interface called “vpn” in /etc/config/network and assigned tun0 to it. I’ve also added the vpn interface to the existing firewall WAN rule.

Has anyone managed to get a VPN working on the Dragino or does anyone have any experience getting a VPN client working on OpenWRT?

I’m using a Raspberry Pi 3 and a dragino lora shield as a gateway, while it works for 10 packets or so it stops after that. I’m still getting it on the gateway but doesn’t show on TTN. It works again after I create another device and use it’s credentials (ABP)

1 Like

My WiFi-Router uses the package openvpn-polarssl and has the tun0-interface within the “green” zone.

For openvpn-openssl a tutorial is here:

Thanks ChristianH.

Unfortunately, the Dragino is running a modified version of OpenWRT and it crashes if you try and bring up the tun0 interface. Dragion are looking into it so maybe they will issue a fix.

In the meantime, I have written a script that creates an SSH tunnel to a remote server and I run what I need via that.

I have a gateway (Raspberry Pi 3 + dragino) and only one mote (arduino + dragino).

  1. in Traffic Gateway, I’m getting payload from several DevAddr, but next to me there is only my mote.
  2. in the Traffic Gateway also, I can see the packets arriving, but in the Application Data it does not show anything.


Has anyone seen anything like this?
Thanks in advance.

With long range radio, other nodes obviously don’t need to be close to your gateway. But as all payloads are 25 bytes: can you confirm that all packets you’re receiving match the times that your node is sending? (Or did your node only send at 19:44:46?)

Unless all different DevAddr lines are in fact your node: receiving transmissions on a gateway but not in an application often means that the keys are wrong. I assume you added the node (device) to the application in TTN Console? Also see Hex, lsb or msb?

arjanvanb, Thank you for your quick reply!

I was able to figure out the problem and now I’m broadcasting normally, the packages are also appearing on the Application tab.
The problem was that in the lorabase.h file, the base frequency of operation was incorrect. I changed to 915 MHz and disabled all other channels. It’s working perfectly now! :star_struck:
the question that I am unraveling now is when inserting an LM35 in the node, I can visualize the temperature monitor and transmit it to the gateway, but in TTN it appears payload with 00 00 00.

the data configuration on my sensor node is::
static uint8_t mydata [4] = {temperatura};

there may be some misconfiguration here…


I’m a newbie in building gateway and I don’t know if I build my gateway wrong. My gateway is dragino Lg01. When trying to join ABP my connection in my gateway are OK. I received the data from my node in ttn console. But when I try using OTAA, I don’t received any data in the ttn console. But upon checking the traffic in my gateway in ttn console there is a joint request of my node. Only join request. I also tried to connect to the other gateway by looking available gateway in the ttn map and went to the location and the connection of OTAA in the ttn console was OK. I received the data from my node. Can you help me to figure out what’s wrong in my gateway?

In this link http://wiki.dragino.com/index.php?title=Connect_to_TTN I followed the tutorial in building the gateway.

Hi everyone

I am testing Dragino’s single channel gateway and Lora device in the AS923 environment.
Please tell me how to solve some of the problems that I am facing.

  1. Test environment
  1. LoRa gateway
    LG 01-JP (firmware IOT-4.3.0, single_pkt_fwd_v 002.hex)
  2. LoRa device
    Lora mini Dev + Arduino-LMIC for LG01-JP for AS923
+ helloworld_otaa.ino / helloworld_abp.ino
  1. Problems faced

When both OTAA and ABP exceed the frame counter 140, the TTN connection is lost.

OTAA Frameup Counter: 144
ABP Frameup Counter: 147

3.My Sketch - setup () function

LMIC_setClockError (MAX_CLOCK_ERROR * 1/100);
LMIC.dn2Dr = AS923_DR_SF9;
LMIC_setDrTxpow (AS923_DR_SF9, 13);


LMIC_setClockError (MAX_CLOCK_ERROR * 1/100);
LMIC_setLinkCheckMode (0);
LMIC. Dn2Dr = AS923_DR_SF9;
LMIC_setDrTxpow (DR_SF9, 13);


Just noticed that Dragino LG01 have released new firmware and lorawan scripts for Single Channel gateway


Not tested, may look later to see whats changed… added downloads packets it says

1 Like

Hi, jezd.

Thank you for your reply.

I have not tested it since I read the new firmware and single channel forwarder release. Because it does not support AS923.

Hi, jezd.

According to your advice, I changed the firmware of LG01-JP to IOT-4.3.2 and packet forwarder to single_pkt_fwd_v003.hex, but the problem was not solved.

ABP stops at 147 and OTAA stops at 144 or 145.


My advice? anyway, I updated the code here and the basics still seem to work, I didnt do any more testing than that - I did note they single_pkt_fwd_v003.hex code didnt change the version number reported by the internal web page, in fact I dont think they changed the old version in the source code

Playing with single channel gateways just reminded how incredibly limiting they are sadly - its back in the cupboard for now

Hello @HaSch
I’m trying to build a gateway with Raspberry PI3 and Dragino Hat, which allows downstream messages.

Looking in the forum, I found your post in which you claim to have tried the code this code: https://github.com/bokse001/dual_chan_pkt_fwd/tree/dual_chan_pkt_fwd_up_down
and after some changes you are able to make it work.

I’m not able to find other posts on the subject, being the post dated,
I ask you to confirm if it works and allows the downstream messages.


I can confirm that Pi 3 with Dragino Hat works with the modified boksem code as I described with up and download.

Thanks HaSch
I will try this code with your changes

Has anyone done any dragino + mqtt direct application? the dragino firing the packages to the server on a normal pc via mqtt?

Hi all
I did the test with Raspberry PI3 and Dragino Hat v1.4 and
I confirm that with the changes suggested by @HaSch ,
it works
by also receiving the Downstream Messages !

I made a further modification to the global_conf.json file

For the test I used a sensor with the code .ino taken from the examples folder of tftelkamp / single_chan_pkt_fwd.git,
subsequently modified, to transmit, only on channel 868100000

The default installation on the raspberry, / bokse001 / dual_chan_pkt_fwd
receive the messages only on channel 868300000, so I modified the global_conf.json file
by inverting the values of the two freq and freq_2 fields
{ “freq”: 868100000,
“freq_2”: 868300000,

{ “freq”: 868300000,
“freq_2”: 868100000,

in the sensor code, to receive the DownStream message,
I added the following line of code, inside the setup () function, before do_send (& sendjob);

 // Let LMIC offset for +/- 1% clock error
 LMIC_setClockError (MAX_CLOCK_ERROR * 10/100);

Hello. Using my LG01P gateway, I am not able to transmit the incoming data (via LoRa) to the server. Someone with similar problem? Each time you transmit different, always forward the same value to the server

Hi all
to implement, a gateway with Raspberry PI3 + Dragino Hat v1.4, which allows to use the Downstream messages, I opened a new Topic where I gathered all the information