DRAGINO problems and solutions topic part 2


(Frankxuan) #16

Hi,
what i want to say is not the problem of example code makes that problem. The range is so short, which is I want to ask why.


#18

russlandeleted

you want to set up a single channel gateway ?
see for LMIC info

LMIC_setupChannel(0, 868100000, DR_RANGE_MAP(DR_SF12, DR_SF7),  BAND_CENTI);      // g-band
     //LMIC_setupChannel(1, 868300000, DR_RANGE_MAP(DR_SF12, DR_SF7B), BAND_CENTI);      // g-band
     //LMIC_setupChannel(2, 868500000, DR_RANGE_MAP(DR_SF12, DR_SF7),  BAND_CENTI);      // g-band

ect


(Russlan) #19

ok, i tried it with OTAA and the LMIC library for it, But i still cant get the package to the TNN.
Pin Mapping:
const lmic_pinmap lmic_pins = {
.nss = 10,
.rxtx = LMIC_UNUSED_PIN,
.rst = 9,
.dio = {2, 6, 7},

If i open serial monitor i always receive:
-starting
-packet queued
-Ev_joining
-unkown event
-unkown event
-unkown event


(Russlan) #21

first i tried it with APB, but i received Errors
then i tried it with OTAA but the TNN doesnt receive my packages

-yes, i checked it 4x time. Manuel, copied, with ox and etc.
-yes , they are actualy 2 and they are 4 meters away
-i used the code from LMIC which was made for 868Mhz
-My Lora dragino is 868Mhz


#22

first check if its really transmitting
open your console and your application and then start the node

join
you should see the node now trying to join the network (yellow thunder)|


#32

maybe this helps


(Iroshana) #43

Hi Everyone,

I’m new to thingsnetwork & I started learning LoRa communication recently. I have a problem using Dragino LG-01P gateway. I’m using SX1276 915MHz Serial Lora module from Ebyte (Model No : E32 915T20D) with arduino Uno to transmit data & I uploaded LoRa simple server yun sketch to gateway. But it doesn’t show any received data. I changed the frequency to 915MHz in the code. Please help me to fix the issue. When I try to read data from another SX1276 915MHz Serial Lora module as a receiver, I can read the transmitted data. Please help me how to fix the issue.

Thanks In Advance.


#44

I’m sorry , we don’t support these lora-lora communication modules at TTN (LoRaWAN)


(Iroshana) #45

Thank you very much for your reply. Actually I’m not going to do lora-lora communication. I’m trying to learn how to send data to thingsnetwork from the lora module I mentioned & using dragino gateway. I said I used 2 lora modules as TX & RX to make sure that TX is working. What I actually need is send data from Ebyte Lora module to thingsnetwork using my gateway. Problem is my gateway doesn’t read the transmitted data. So I have no way to push my data to TTN.

Thanks in advance.


#46

I see.

First thing to do is get your single channel gateway online with TTN
It’s known that these 'gateways don’t perform very well !

Then you want to use these Ebyte (Model No : E32 915T20D) as nodes to send data.
And there is a problem, the output power from the module (100 mw) is to high and not legal in most countries.
And this specific type can’t be used for LoRaWAN over TTN


(Iroshana) #47

oh really. I just bought that module since It is available in aliexpress for few bucks. I didn’t know those power constraints. Thank you very much for letting me know. Anyway for basic learning I’ll use it & then I’ll buy a suitable module. Anyway my next step is add my gateway to TTN & test. But before that I should make sure that rest of the things are okay. My problem is my Ebyte module sends data but dragino gateway doesn’t read them. I uploaded Lora_simple_server_Yun sketch to gateway. (it is an example sketch from dragino). What that sketch does is just read the data from client LoRa node & prints the output on Serial monitor. Unfortunately only serial print I get is “Listening to 915MHz” & no any data displayed on serial monitor. That is my problem. I really appreciate if you can tell me what may be the issue & how to fix it. If it is fixed, then I can push those data to TTN & test my setup.

Thanks.


(LoRaTracker) #48

Thats been answered over in the Arduino forums, its not going to work.

Incidently, its not a good idea to post the same question in two different places at the same time, its a waste of the responders time (who are volunteers).


#49
  • the module is a wireless uart and can’t be used for LoRaWAN / TTN
  • cheapest solution is : buy a RFM95 module and connect to your arduino uno

(Kek) #53

Hello,
after following this tutorial I find my gateway unable to connect to ttn(“not connecteda” in the console overview). After trying http://noc.thethingsnetwork.org:8085/api/v2/gateways/eui-<your-eui>
i got the following reply:
{“satus not found”,code:5}.What causes this issue and how can it be fixed?


(Ananda123) #56

I ma using Raspberry Pi 2 and Dragino LoRa/GPS Hat as a node. This node transmits data to 8-channel RAK831+RaspberryPi Gateway. I am trying the following code: https://github.com/ernstdevreede/lmic_pi/archive/master.zip

My pin mapping in thethingsnetwork-send-v1.cpp is:
// Pin mapping
lmic_pinmap pins = {
.nss = 6,
.rxtx = UNUSED_PIN, // Not connected on RFM92/RFM95
.rst = 0, // Needed on RFM92/RFM95
.dio = {7,4,5}
};

When executing the code, I am getting the following error:
FAILURE
radio.c:475

In radio.c line 630 and few codes before that line are the following:
630 ASSERT( (readReg(RegOpMode) & OPMODE_MASK) == OPMODE_SLEEP );

Does error at ASSERT( (readReg(RegOpMode) & OPMODE_MASK) == OPMODE_SLEEP ); mean there could be problem reading the Lora modem? Any guidance/help in how I can solve this error would be highly appreciated.

One more request, if anyone has another good tutorial for these particular devices to work as a node, Please let me know.

Thank you


DRAGINO problems and solutions topic part 1
(Mrzel03) #58

Dear forum

I have a problem. When I want to upload a Sketch to the Dragino LG02, this Error appears (picture attached). I have the LAN-Port Connected and the Arduino IDE shows the Port1. Then, when I want to upload the sketch, it doesn’t work. Can you help me pls? Thank you in advance.

Dragino%20Sketchupload%20error

Also, it would be nice, if someone can link me a usable Sketch for the Dragino LG02 as a Gateway for Sensor nodes.

Best Regards

Mario


#59

you can’t upload on that port… select the right device/port in the ide


(Mrzel03) #60

It just shows the Port1, nothing more…?


#61

and you read the manual ?


(Liamcox94) #69

Hi all,

I have an issue with the LG01, I am probably missing something obvious but any help right now is greatly appreciated.

The issue is that none of my data seems to be forwarded to The Things Network. My received messages are not incrementing and there is no traffic on the gateway.

I am positive that my LG01 is connected to the things network and I am fairly sure that my LG01 is receiving data. If I go into the diagnostics I can see the sensor data being received. It just doesn’t leave the gateway.

I had this exact same setup running back in November and now I am having no joy.

Please point out something obvious I have missed.

Thanks a bunch,
Liam