Error compiling in arduino, esp8266 with lorabee module

Hi everyone, I’m a newbie with arduino and LORA and I’m having some trouble with my first project.

I’m trying to connect a Dragino LoraBee (SX1276) with a ESP8266MOD to TheThingsNetwork, I have downloaded MCCI LoraWAN LMIC library and I have edited the file “lmic_project_config” to the europe region.

I have generated my ABP keys in the web and changed them in the ABP example file and I have defined the pinout.

The problem comes when I run the code, monitor serie gives me this output:


 ets Jan  8 2013,rst cause:4, boot mode:(3,6)

wdt reset
load 0x4010f000, len 3424, room 16 
tail 0
chksum 0x2e
load 0x3fff20b8, len 40, room 8 
tail 0
chksum 0x2b
csum 0x2b

Pd: Sorry for posting simple doubts on the forum, but I couldn’t find any solution after trying different proposed solutions on the internet

What does the code on this line say?

PS, please format code & logs using the </> tool on the toolbar

This is oslmic.c from line 50 to 54, the error is produced on line 53 which is the one that have “ASSERT(0);

void os_init() {
    if (os_init_ex((const void *)&lmic_pins))

Yeah, I already knew that, I was wondering if you’d checked it and looked for any clues as to why it had thrown and assert?

In the end, it all came down to a hardware issue—a pin that was making a poor connection. I soldered it, and now it works. Thank you, and I apologize for any inconvenience caused.

1 Like

Thanks for reporting what the issue was. Too many forumites forget to report back when things are resolved with the solution.