ERROR: [main] failed to start the concentrator


(Luisft Silva) #21

SPI is enable and I did not go directly to the local_conf.json i think. when I’m following the tutorial this asks what my Gateway ID, my Gateway Key and the reset pin. And recommends pin 17 for raspberry 3 which is my case, I just put “17” and enter. Can I confirm in any way that I’m using the right pin? For power supply I have one with 5v 1A


(Jac Kersing) #22

For a 3B that is not a lot of power… recommended for RPi3 is to use at least 2A power supply.
For the RPi3 there is also an SPI timing issue which requires changing the boot config, a quick look at the repo does not show anything related to this.
Do you need a Raspian based install? If not I would suggest to use https://github.com/jpmeijers/ttn-resin-gateway-rpi . You could use this on a (spare) sdcard to check the hardware anyway.


(Mvp Iran) #23

hi (sorry for English)
i try semtech packet forwarder with orange pi zero and sx1278(LoRa-RA02)

  1. can i run this gateway ? (in Lora-net say SX1278 supported )
  2. when run packet forwarder ERROR : failed to start the concentrator.?
    • where i can change or set spi pin mosi / miso / sck / reset / Dio0 / CS .( IS necessary )
    • i use wiringOP-zero .
      Thank you for the guide.
      Regards.

(Jac Kersing) #24

You are mixing two projects, sx1278 is a chip for a node. It can be used for a single channel gateway, not for the full gateway software you are trying to run.


(Mvp Iran) #25

Thank you for response.
yes ,but i have only lora-ra02 :kissing_smiling_eyes:.
i run single channel gateway but only supported up link . now i trying to run dual_chan_pkt_fwd.
if you have better suggest , please help me.


(Jac Kersing) #26

Dual_chan_pkt_fwd is the best option. However the error suggests another packet forwarder, not dual_chan_pkt_fwd.

This message is not in the dual_chan_pkt_fwd sources according to github (search). It is part of the source of Lora-net packet_forwarder, poly_pkt_fwd, mp_pkt_fwd etc, software for a full gateway based on sx1301/sx1308.