ERROR: [main] failed to start the concentrator

It’s still not working, but I got closer. There’s a discrepancy between how we talk about pins in the TTN packet forwarder and forks off of Semtech’s. TTN’s reset pin refers to GPIO #, whereas Semtech and others refers to the reset pin by pin #. GPIO 7 = pin 26, so setting that to 26 in got me closer to working.

The last few lines of my verbose output are now:

lgw_spi_rb:373: BURST READ: to trans 1024 # chunk 1024 # transferred 8192 
Note: SPI burst read success
ERROR: Failed to load fw 1
Note: SPI read success
Note: SPI write success
Note: SPI write success
Note: SPI read success
Note: SPI write success
Note: SPI write success
Note: SPI write success
Note: SPI read success
ERROR: Version of calibration firmware not expected, actual:0 expected:2
21:18:55  ERROR: [main] failed to start the concentrator

Hello ehsanmgh,
I am facing the same problem. can you please tell me how you RESET the ic880a-SPI board.

I already tried it but it didn’t worked.
Is any other solutions to start the concentrator ?
Any help ll be appreciating.
Thank you.

Hi, I had the same issue, I could resolve it by resetting the CE0 and RESET pin before running the forwarder. Here is how i did it:

echo "Restarting the CE0 pin..."
echo "$CSPIN" > /sys/class/gpio/export
sleep 1
echo "out" > /sys/class/gpio/gpio$CSPIN/direction
echo "0" > /sys/class/gpio/gpio$CSPIN/value
sleep 1
echo "1" > /sys/class/gpio/gpio$CSPIN/value
echo "Done\n"
sleep 1

echo "Restarting the Concentrator..."
echo "$RSTPIN" > /sys/class/gpio/export
sleep 1
echo "out" > /sys/class/gpio/gpio$RSTPIN/direction
echo "1" > /sys/class/gpio/gpio$RSTPIN/value
sleep 1
echo "0" > /sys/class/gpio/gpio$RSTPIN/value
echo "Done\nLaunching the forwarder..."
sleep 2

cd /PATH_TO_THE_GATEWAY_CODES/packet_forwarder/ && ./lora_pkt_fwd

Save this code in a shell file, change the path according to your own settings and make sure to run it with sudo
The full article can be found here

1 Like

I read your article thank you very much, but I have doubts about how to save or create the code in the console. I am a newbie

As you can see i have the ‘ftdi’. Where can i find the instructions to fix this?
i’am having the same error:
“ERROR: [main] failed to start the concentrator”

Do you mean you have ftdi hardware? Or that you have SPI hardware and the wrong software version?
Which instructions have you used?

BTW the terminal output is ascii text, no need to use an image, just cut-and-paste the text as a quote/code block next time you post.

1 Like

error_post Any idea how I might resolve this error ? I am using LORA gateway along with a risinghf module. What might be the solution to this?

Be precise with details please if you expect help

Which model & configuration of hardware, which firmware, which packet forwarder…etc…

…and as last post above dont post images for such output…

@Jeff-UK Sorry Sir,
I am using RisingHF gateway “RHF2S025BH8-868” for my application to send data on .
These are the steps I have followed:

  1. Created application on and got DevEUI, AppEUI, Application and Network Key.
  2. Added gateway details and the Gateway ID onto
  3. Packet Forward is enabled.

After performing above steps, the gateway is still not showing status as online.

Firewall is disabled, checked IP and it is present in the DHCP client table.
Also the internet speed is sufficient. So, I am not understanding what exactly might be the issue here.
Please suggest a solution for this.

…and TTN fits in where exactly, and what have you done to register there (gw, application, device?), what are you seeing in logs there?

To make Jeff’s post totally clear, it appears that you are not using TTN and this is a TTN forum.

If you are not using TTN, this is not the forum you are looking for.

Okay Sir. Sorry about the post.


I am facing same problem. I am totally new to do this. Can you please describe in details how to resolve this?