EUI already used

Hi Guys

First I apologize if this has been covered. I can assure you all I have searched already.

I have registered my new gateway today (so excited as just arrived 4 hours ago in post) and I had issues getting any communication. I attempted a few resolutions with no luck and then i deleted the gateway as per the docs I had read. The first time I registered the gateway it did register correctly and showed up in my list of gateways.

After I deleted the gateway it did confirm I wanted to remove and then it had gone from my available gateways as I would expect. I did this process twice and everything worked correctly.

On my third attempt to re-register, I got a message saying the gateway was already registered but it had gone from my gateway list and was no longer available.

Could you please point me in the right direction to how I resolve this or where I should be reading to fix myself.

thank you in advance.


Are you using TTN V2 or experimenting with V3, which Gateway make/model/packet forwarder?

Really? So you missed all the threads and posts telling you not to

…and ignoring the various warnings to not delete and asking if you really want to do this?

How recoverable your situation is will depend on answers to 1st questions…

What did you try?

:thinking: So why did you delete it? What search did you do to resolve any issues seen?

Hi Jeff,

Thank you for replying

I have the RAK 7258 and a dragino reed switch.

This is all brand new to me however i have had some experience in watching a colleague who has registered a gateway and some devices for me in the past. I thought i could do it myself this time.

The EUI is ac1f09fffe016280 and i have it on the bench next to me and working fully but i can no longer register it as it keeps telling me it is already registered but is no longer showing after the last time i deleted it.

Thank you again for replying

I am using V3 and believed i should have registered using basic station for better security.

I attempted to delete and re register before going any further which is when i lost the ability to re add the gateway

Hi Jeff,

I do understand you are all volunteers and do this in your own free time.

I apologize if i did not read enough and thank you for your reply anyway. I will go back to reading some more.

Take care and Kindest regards.


I’ve limited my own use of V3 so far, waiting on addditional Integrations and holding off migrating my V2 GWs for now, just testing a few nodes, so paging in Nick @descartes and Jac @kersing as both of them have hammered V3 and TTS a lot harder and also I think Jac has direct experience with the RAK7258. It may be that Gateway ID in V3 is a route out but I am not sure… guys.

That is likely a wise choice going forward…

1 Like

Due to my incredible old age, I’ve learnt what RTFM means (on at least one occasion whilst in flight, handy having your glider manual in the side pocket) so I haven’t got as far as deleting a gateway in v3 as I haven’t had any finger trouble getting one online.

Also, due to the pile of lottery tickets I have that haven’t won, I’m not a betting man, but I am willing to be that if @NealBrown cares to share the actual error message, that no reference will be made to EUI and it will in fact be the **Gateway ID** that the error message refers to.

Why? This is universal to the majority of IDs. Because it stops people inadvertently (or deliberately) recycling an ID and then potentially being able to retrieve some information from the stack due to the way it persists some data.

So, @NealBrown, what’s that error message?


Well all i can say is thank you guys and i really need to do some more reading.

I have just gone to re-register so i could take a screen shot of the exact message and this time it worked and is now online.

I thank you for your replies and apologize for wasting your valuable time.

Once again thank you for your patience, although i am very keen to learn, it is not the easiest of things to grasp with very little experience and so many places to read with many different explanations and advice.

Thanks again

Was the error message related to the Gateway ID??

Hi Nick,

I am not sure now as the message did not come back up and everything connected correctly.
I believe it stated EUI however I am now questioning myself.

Once again thank you for all the help that you and your college offered.