Event API not working (error code:3)

Hi I am trying to get event data of my device on TTN (V3) via API calls.
I’m using cURL in the windows power shell and have tried different examples but I can’t get it to work.
It always gives me a:

{“code”:3,“message”:“invalid character ‘i’ looking for beginning of object key string”}

My input is as follow with API key and app name replaced
curl https://eu1.cloud.thethings.network/api/v3/events -H "Authorization: Bearer NNSXS.XXX.YYYY" -H "Accept: text/event-stream" --data '{"identifiers":[{"application_ids":{"application_id":"test-app"}}]}'


curl https://eu1.cloud.thethings.network/api/v3/events -X POST -H "Authorization: Bearer NNSXS.XXX.YYY" -H "Accept: text/event-stream" --data '{"identifiers":[{"application_ids":{"application_id":"test-app"}},{"gateway_ids":{"gateway_id":"test-gw"}}]}'

Thanks :slight_smile:

Edit: I just tried it on a Linux machine and it does work.
Does anyone know what the problem with windows cURL is?

Okay, solved it. On cUrl for Windows you have to escape quotes inside quotes with a backslash.

So the --data part has to look the following way.