Factory Reset Kerlink Gateway

I have a Kerlink gateway here, and don’t now it’s firmware version and root password.
I tried the reset key procedure (23 times push reset button with pause 4-10 secs), but the gateway seems not to react.
LEDs “station PWR”, “modem PWR” and “GSM1” are lightning, sometimes “MOD1” + “MOD2” are flashing.

What can i do to get access to the gateway?

If you can find its serial number: did you try the default password?

Username: root
Password: root

For 3.1 firmware, the password is pdmk-0 followed by the last 7 characters of the serial


  • Resetting to factory setting is actually the result of detecting an unstable environment, due to the system failing a reboot more than max_bootfail times. Apparently, this is 20 by default, so maybe it needs to be given some time after the 20th reset?

  • Do you still get a SSH prompt since you tried to reset to factory settings? (Maybe even between reboots, to get the timing right?)

  • I’ve read, but cannot confirm, that this reset procedure won’t work when Kerlink’s SPN has been installed.

no dhcp ip visible, neither default ip works. Bevor i tried Update with USB stick, gw did dhcp and ssh, but default ssh connection was closed after 3-4 seconds. Unfortunately i don’t own the console adapter.
Seems gw is bricked :frowning:

But Mod LEDs are flashing from time to time, it seems gw is stuck in some kind of loop?

According to the wiki, that’s instead.

As far as I can tell, that can mean anything. From Kerlink’s “Installation and Maintenance Manual LoRa IoT Station” (which does not give you much helpful details at all):

Status of the Lora IoT Station:

  Name           Color  Mode        Details
  PWR (Station)  Green  Continuous  Station power indicator
  PWR (Modem)    Green  Continuous  Modem power indicator
  GSM1           Green  Continuous  GSM quality level Most Significant Bit
  GSM2           Green  Continuous  GSM quality level Least Significant Bit

WAN quality level:

  GSM1 GSM2 Status
  0    0    SIM Card error
  0    1    No network connection
  1    0    RSSI Level < 17
  1    1    RSSI Level >18

The behaviour of the other LEDs depends on the application software downloaded in the LoRa IoT Station. Only Station LEDS (WAN, MOD1 and MOD2) can be controlled by the application.

…okay, what else did you not tell us…?

Hi Verkehrsrot,
How are you?

I have the same issue with my Gw!
Could you please tell me how you solved this problem?

Kerlink didn’t want to support us directly. We were advised to send the Gateway to the Seller for reconfiguring it. Since we did not find any solution to reset it, we sent it in :frowning:

Hello Verkehrsrot,

did you get your gateway back with a new configuration?
currently, i am facing the same problem with my gateway you had last year…

thanks, Klaus

We had to go via the supplier, Kerlink did not support us.

Just in case a debug probe helps, see DIY Kerlink Wirgrid debug probe.