Frame counter unchecked still sending f_cnt

Even though the frame counter checks are unchecked the ttn still counts them and send them to the device.
Can I stop that?

image

frame_count

it is work.
and also cli we can disable the frame-count by using update device using this command
ttnctl devices set --disable-fcnt-check

Actually it is the device that generateds the frame count and the back end just checks it - it is a potential anti spoofing/anti-replay attack mechanism that helpd form part of the device/network security…if not ignored (checked to ignore in console or set to ignore through the cli) then the back end will effctive disreagard any counts lower than it has registered. If you reset the device but dont reset the back-end count this can cause problems - usually associated with ABP join. Using OTAA join the device and B/E reset and start to count in synch :slight_smile:
The Back End/Console only ‚Äėreports‚Äô the count as received from the device‚Ķits is also useful for tracking e.g. packet loss

1 Like

No you can not. The LoRaWAN specification states transmitted frames should use incrementing frame counters. TTN allows ignoring the counter when receiving data to help users developing and testing ABP nodes however the back-end needs to increase the counter on transmission otherwise nodes might ignore the (potentially duplicate) packets on reception.

Thank you but if I reset the frame counter from ttn console the next time it sends a zero value this means that the ttn is generating that number and it sending it to my device (with the downlink) where probably the device it self is doing some checks. I wanted to know if there is any way to automatically reset the back-end count…

I have already unchecked the frame counter checks, it works only for the uplink for me…

Thank you, it seems that way