Gateway Claim Authorization Key not working for TTIG

I have a TTIG that is currently connected to my (old) sandbox account. I want to move this gateway to a (new) cloud account that has just been created and delete it from my sandbox account. However, after I successfully authorized this gateway for claiming using the CLI tool, I still get the “gateway with EUI {gateway_eui} already exists and is not authorized for claiming” error message when I try to claim it in the cloud account.

This is the sequence of steps in more detail:-

  1. Created a sandbox account some time ago.
  2. Successfully added a TTIG to this sandbox account (and used it for some time).
  3. Created a new cloud account.
  4. Used the CLI tool to authorize my gateway for claiming. I confirmed that this has worked because I can see a new key generated in the console, with the name “Gateway Claim Authorization Key”.
  5. Deleted the TTIG from my sandbox account (note: I didn’t get the option to purge the gateway when I deleted it).
  6. Through my new cloud account, I tried to add the same gateway through the console, using the same EUI but a different ID, and I got the error below:-
  "code": 9,
  "message": "error:pkg/deviceclaimingserver/gateways:gateway_not_authorized (gateway with EUI `58A0CBFFFE804C5F` already exists and is not authorized for claiming)",
  "details": [
      "@type": "",
      "namespace": "pkg/deviceclaimingserver/gateways",
      "name": "gateway_not_authorized",
      "message_format": "gateway with EUI `{gateway_eui}` already exists and is not authorized for claiming",
      "attributes": {
        "gateway_eui": "58A0CBFFFE804C5F"
      "correlation_id": "43d96195e6ee43bca34fb6e7e9638971",
      "code": 9

I am not sure why I don’t have the option to purge my gateway when I delete it, but I also tried to purge it through the CLI (after readding the gateway to my sandbox account) and I got the error below:-

“error:pkg/identityserver:admins_purge_gateways (gateways may only be purged by admins)”.

I checked my sandbox account and I am currently the only user with “All possible rights”, so not sure why I can’t purge the gateway from the CLI. I’ve also read that one solution would be to add my new account as a collaborator, however I can’t find this new account. Any ideas on what I need to do to move this gateway to my new cloud account?